Filament sensor switch in 4 axis Delta



  • Hi there!
    I would like to connect a regular filament sensor switch to my duet wifi with firmware 3.0.
    My machine is a delta printer with 4th axis that carries a flying extruder on the 4th axis.
    My E0 stop port is used for the effector´s switch and the E1 stop port is used for the aditional axis´s endstop(U axis).
    My idea was to use the expasion board´s pin for the filament switch(E2´s stop pin).
    But i don´t mannage to make it work.
    I would also like to know what changes in the web control when you activate this function so i can test properly if works.
    This in my config.g :
    config(6).g


  • Moderator

    Can you send M115 to confirm what firmware version you have? It should be 3.1.1, if not, you should update.

    Here are your endstop pin name options to use in M591 for the filament sensor:

    Endstop inputs
    
    xstop
    ystop
    zstop
    e0stop
    e1stop
    exp.e2stop, exp.4
    exp.e3stop, exp.9, duex.cs6
    exp.e4stop, exp.14, duex.cs7
    exp.e5stop, exp.19, duex.cs8
    exp.e6stop, exp.24
    duex.e2stop
    duex.e3stop
    duex.e4stop
    duex.e5stop
    duex.e6stop
    

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M591_Configure_filament_sensing

    In your config.g you have this: M591 D5 C3 P1 E6.0 but that's not going to work in RRF3. C needs to be the pin name you're using.

    Can you send M98 P"config.g"? I think you'll see a few error messages pop up.



  • @Phaedrux said in Filament sensor switch in 4 axis Delta:

    M98 P"config.g"

    Thanks for the help.
    Yes, my firmware was 3.0 and i uploaded to 3.1.1 but i had some trouble after doing so.
    now the screen shows "connecting" the whole time and it doesn´t work .
    from the duet web control it works normal.
    this is what popped out when i send the comand you asked me to send:
    17/10/2020 12:08:15 M98 P"config.g"
    HTTP is enabled on port 80
    FTP is disabled
    TELNET is disabled
    Error: Z axis maximum must be greater than minimum
    Endstop configuration:
    X: high end switch connected to pin xstop
    Y: high end switch connected to pin ystop
    Z: high end switch connected to pin zstop
    U: high end switch connected to pin e0stopWarning: Heater 0 appears to be over-powered. If left on at full power, its temperature is predicted to reach 365C
    Error: in file macro line 76: M591: parameter 'D' too high
    Warning: Macro file config-override.g not found

    this is what shows now sending m115:
    m115
    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 3.1.1 ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2020-05-19b2

    i don´t know why but an error pops out when i try to update duetwificonbined.bin
    i updated duet2and3firmware3.1.1.zip and worked.

    config(7).g


  • Moderator

    @ander said in Filament sensor switch in 4 axis Delta:

    now the screen shows "connecting" the whole time and it doesn´t work .

    For the PanelDue you'll need to add M575 P1 B57600 S1 to your config.g

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M575_Set_serial_comms_parameters

    @ander said in Filament sensor switch in 4 axis Delta:

    Error: Z axis maximum must be greater than minimum

    ; Axis Limits
    M208 Z-2 U1000 S0 ; set minimum Z

    M208 S0 sets the maximum. So Z max of -2 makes no sense.

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M208_Set_axis_max_travel

    @ander said in Filament sensor switch in 4 axis Delta:

    Error: in file macro line 76: M591: parameter 'D' too high

    ; Custom settings M591 D5 C3 P1 E6.0 ; filament monitor connected to E2 endstop
    I guess it doesn't like your D value, which is for the extruder number. And you don't have 5 of them, so should probably change that to 0.

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M591_RepRapFirmware_Num_3

    @ander said in Filament sensor switch in 4 axis Delta:

    Warning: Macro file config-override.g not found

    That just means you haven't used M500 yet to create the config-override.g file, but you do have M501 at the end of config.g to load it if you did. If you do a PID tuning of your heaters and send M500 it will save the results to config-override.g and then M501 will load them at boot.

    https://duet3d.dozuki.com/Wiki/Tuning_the_heater_temperature_control#Section_Setting_the_model_parameters_by_auto_tuning

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M500_Store_parameters

    @ander said in Filament sensor switch in 4 axis Delta:

    i updated duet2and3firmware3.1.1.zip and worked.

    Uploading the complete zip file as is without extracting it is the correct way to do it.

    @ander said in Filament sensor switch in 4 axis Delta:

    Warning: Heater 0 appears to be over-powered. If left on at full power, its temperature is predicted to reach 365C

    This is a warning. : https://duet3d.dozuki.com/Wiki/FAQ#Section_M307_Heater_1_appears_to_be_over_powered_If_left_on_at_full_power_its_temperature_is_predicted_to_reach_521C



  • Thanks for the help.
    The screen now works thanks to your advice
    the filament sensor value is changed to 0 and is not giving any error but i don´t know yet if works properly (how can i check that?)
    the macro error....you were right, i didn´t send the m500 yet because i just put a new duet and i´m trying to put it to work.
    I changed the z -2 to z0 and i still have the same error.
    this is what i see now after sending M98 P"config.g"
    M98 P"config.g"
    HTTP is enabled on port 80
    FTP is disabled
    TELNET is disabled
    Error: Z axis maximum must be greater than minimum
    Endstop configuration:
    X: high end switch connected to pin xstop
    Y: high end switch connected to pin ystop
    Z: high end switch connected to pin zstop
    U: high end switch connected to pin e0stopWarning: Heater 0 appears to be over-powered. If left on at full power, its temperature is predicted to reach 365C
    Warning: Heater 0 appears to be over-powered. If left on at full power, its temperature is predicted to reach 365C
    Warning: Heater 1 appears to be over-powered. If left on at full power, its temperature is predicted to reach 1232C

    This is my config file:
    config(8).g



  • you have no maximum defined for all axis

    you have no minimum defined for x and y

    your thermistor config is wrong. find the correct beta value in your thermistor documentation.

    M591 D0 CE2_STOP P1 E6.0 ; filament monitor connected to E2 endstop

    that command seems wrong the pin definition is wrong and does not exist


  • administrators

    @Veti said in Filament sensor switch in 4 axis Delta:

    you have no maximum defined for all axis
    you have no minimum defined for x and y

    That's normal when the printer is a delta.

    M591 D0 CE2_STOP P1 E6.0 ; filament monitor connected to E2 endstop

    that command seems wrong the pin definition is wrong and does not exist

    yes indeed, the pin name needs to be enclosed in quotes like this:

    M591 D0 C"E2_STOP" P1 E6.0 ; filament monitor connected to E2 endstop



  • @dc42 said in Filament sensor switch in 4 axis Delta:

    That's normal when the printer is a delta.

    missed that part. thx

    but whats the error then?

    Error: Z axis maximum must be greater than minimum


  • Moderator

    @Veti said in Filament sensor switch in 4 axis Delta:

    but whats the error then?

    Error: Z axis maximum must be greater than minimum

    He's still using M208 S0, which is the maximum, but he went from -2 as the max height to 0 as the max height. Still makes no sense.

    @ander Use M208 S1 Z-2 That sets the low point of the z axis to -2mm below the surface. You'll need a separate line for M208 S0 U1000 to set the max travel for your U axis



  • Thanks for the help, i tried what you (phaedrux) sayd and worked, i don´t have this error anymore.
    Now, the filament sensor switch (it is a regular endstop switch)is connected to pin 4 (E2_stop)in the expansion board.
    and is giving me an error:

    M98 P"config.g"
    HTTP is enabled on port 80
    FTP is disabled
    TELNET is disabled
    Endstop configuration:
    X: high end switch connected to pin xstop
    Y: high end switch connected to pin ystop
    Z: high end switch connected to pin zstop
    U: high end switch connected to pin e0stopWarning: Heater 0 appears to be over-powered. If left on at full power, its temperature is predicted to reach 365C
    Error: Unknown pin name 'e2stop'
    Warning: Heater 0 appears to be over-powered. If left on at full power, its temperature is predicted to reach 365C
    Warning: Heater 1 appears to be over-powered. If left on at full power, its temperature is predicted to reach 1232C

    How can i make it work?
    here is my last config.g
    thanks

    config(9).g



  • @ander said in Filament sensor switch in 4 axis Delta:

    Error: Unknown pin name 'e2stop'

    thats the wrong name. phaedrux posted a list of the pin names that are valid in this thread


  • Moderator

    @ander said in Filament sensor switch in 4 axis Delta:

    Error: Unknown pin name 'e2stop'

    Try exp.e2stop as the pin name.


Log in to reply