Duet 2 Wifi With Gigabot Thermocouple Issue



  • Hello All! This is my first post, and first printer, so bear with me. I received a Gigabot 3 from a friend about a year ago and we've been slowly working on it. In August we put a Duet 2 Wifi in it and got everything working except the bed heater and the extruder heat, obviously thats a problem. I am using 2 type K thermocouples and this thermocouple board:

    https://www.printedsolid.com/products/duet-type-k-thermocouple-daughter-board

    The sensors read 2000c at all times and here's a picture of the duet web interface. Screen Shot 2020-10-20 at 8.32.34 PM.png

    If theres any other useful information I'm missing please let me know, and at this point I'm down to try anything. Thanks in advance!


  • Moderator

    That image looks like an older version of the web interface. I'm pretty sure a firmware update will be in your near future.

    Can you use the Gcode console to send M122 and copy and paste the results?

    Can you also copy and paste the contents of your config.g file?

    Have you seen these?
    https://duet3d.dozuki.com/Wiki/Thermocouple_daughter_board
    https://duet3d.dozuki.com/Wiki/Connecting_thermocouples



  • @Phaedrux
    Thanks for the reply! I have checked both those out and numerous other threads.

    I had tried updating to 3 but had received an error, but that was back in early August, maybe its time I try again.

    The heater section of my config.g looks like this

    ; Heaters
    M305 P1 X100
    M305 P1 X101
    M305 P0 X102
    M305 P0 X103

    I set them both to 2 different channels because I wasn't sure how to determine which channel they were on.

    Heres the output of M122

    === Diagnostics ===
    Used output buffers: 3 of 32 (13 max)
    === Platform ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 1.21 running on Duet WiFi 1.02 or later
    Board ID: 08DLM-996RU-N8PS4-6J9FG-3SD6L-9VURN
    Static ram used: 16152
    Dynamic ram used: 100400
    Recycled dynamic ram: 2232
    Stack ram used: 1224 current, 4448 maximum
    Never used ram: 7840
    Last reset 00:00:46 ago, cause: power up
    Last software reset at 2020-10-20 20:06, reason: User, spinning module GCodes, available RAM 7776 bytes (slot 0)
    Software reset code 0x0003 HFSR 0x00000000, CFSR 0x00000000, ICSR 0x0441f000, BFAR 0xe000ed38, SP 0xffffffff
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min 34.7, current 35.6, max 35.9
    Supply voltage: min 23.7, current 24.1, max 24.2, under voltage events: 0, over voltage events: 0
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2020-10-20 20:44:16
    Slowest main loop (seconds): 0.015620; fastest: 0.000046
    === Move ===
    MaxReps: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 0 is on, I-accum = 0.0
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Responder states: HTTP(1) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 2 of 8

    • WiFi -
      Network state is running
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.23
      WiFi MAC address f4:cf:a2:59:85:c4
      WiFi Vcc 3.37, reset reason Turned on by main processor
      WiFi flash size 4194304, free heap 25872
      WiFi IP address 192.168.0.30
      WiFi signal strength -76dBm, reconnections 0, sleep mode modem
      Socket states: 2 0 0 0 0 0 0 0
      === Expansion ===

    Another possible useful thing would be this error, which I also received earlier. Screen Shot 2020-10-20 at 8.45.12 PM.png

    Thanks in advance!


  • Moderator

    Have you tried reseating the daughterboard in its pins?

    How do you have your thermocouple wired to the daughterboard?

    Was the thermistor ever working before?

    1.21 is a very old firmware. I would say that updating is probably a good idea, though you will need an updated config file. If you post your entire config.g that would help me produce an updated config for you, or you can use the values in there to create a fresh config file for RRF3 using the online tool.

    In this case I would update to 2.0 first, and then 2.05.1 and then 3.0 and then 3.1.1. The last 3 of those are quite easy once you're on 2.0. It may seem tedious to do it this way, but it also ensures you have all the needed files from all the releases along the way.

    First start with the 2.0 bin file. Upload it to the /sys folder and then send M997 to flash it if it doesn't detect it automatically.

    https://github.com/Duet3D/RepRapFirmware/releases/download/2.0/Duet2CombinedFirmware.bin

    At this point you can upload the web interface update zip file to the /sys folder, as is, don't extract it.

    https://github.com/Duet3D/RepRapFirmware/releases/download/2.0/DuetWebControl-1.21.1.zip

    Now you should be able to upload the 2.05.1 zip file, as is, don't extract it, straight to the /sys folder. It should detect and update the firmware and web interface and reboot.

    https://github.com/Duet3D/RepRapFirmware/releases/download/2.05.1/Duet2Firmware-2.05.1.zip

    Then do the same for the 3.0 and 3.1.1 zip files.

    https://github.com/Duet3D/RepRapFirmware/releases/download/3.0/Duet2and3Firmware-3.0.zip

    https://github.com/Duet3D/RepRapFirmware/releases/download/3.1.1/Duet2and3Firmware-3.1.1.zip

    That should get you up to date and then you can upload a config file set zip file you get from the configurator https://configtool.reprapfirmware.org/Start

    Then if you still have some issues we can tackle them then. It will be easier once you're on modern firmware.


  • administrators

    @mosesbuckwalter said in Duet 2 Wifi With Gigabot Thermocouple Issue:

    The heater section of my config.g looks like this
    ; Heaters
    M305 P1 X100
    M305 P1 X101
    M305 P0 X102
    M305 P0 X103

    1. You can't set a single heater to use 2 channels. For example, the M305 P1 X101 command will cancel the M305 P1 X100 command.

    2. Unless the thermocouple board is the older version, you need to use X150 and X151, not X100 and X101. The image on the Printed Solid page shows the newer version, which uses MAX31856 chips, but the text incorrectly says that it uses MAX31855.


Log in to reply