Duet Meastro Extruder Drivers Failing



  • Hello,
    I had the board on my Printrbot Play fail so I thought I'd give the duet Meastro a try as a replacement. I got it and installed it about a year ago and was playing with it for a few months on and off trying to get the config correct on a BL touch I installed, and got it running like a swiss watch. Every so often though I'd get a driver failure/short error on the extruder from the Duet interface I'd usually just restart the printer and restart the print and it would work. Then it started getting really bad and it seemed like when I did close to full volume prints (which on a play are still really small) it would throw the driver error on the extruder. I tried moving to the 4th motor driver and it would still throw the same error mid print but at different points in the same gcode. I swapped the motor ( to a LDO stepper) thinking that maybe that the issue and that's what may have burned out the original board but nope I'd still get the driver short error randomly throughout the print. After not printing with it for a bit and moving, it now throws the error once it starts the print. It'll still extrude if I tell it to in the interface and it will do the purge gcode I have, but once it starts on the print itself it throws the error. I checked all the connections pulled them out and reattached them and alas no success. The only thing I can think of is that maybe the wiring itself is faulty for the extruder. I'm running the below. Any help or input would be appreciated.

    Firmware Name: RepRapFirmware for Duet 2 Maestro
    Firmware Electronics: Duet Maestro 1.0
    Firmware Version: 3.0 (2020-01-03b3)
    Web Interface Version: 1.22.6


  • Moderator

    @Mnorland said in Duet Meastro Extruder Drivers Failing:

    The only thing I can think of is that maybe the wiring itself is faulty for the extruder.

    What was the exact error message?

    You've swapped the driver, and the motor, but the cabling is the same and is a pretty likely culprit. I'd replace the wiring.

    @Mnorland said in Duet Meastro Extruder Drivers Failing:

    Firmware Version: 3.0 (2020-01-03b3)

    Also you should probably update to 3.1.1. Easiest option is to upload the complete 3.1.1 zip file to the system tab in DWC. That will update the firmware and web interface.

    https://github.com/Duet3D/RepRapFirmware/releases/download/3.1.1/Duet2and3Firmware-3.1.1.zip

    Upload it as is, don't extract it first.


  • administrators

    Is the extruder driver configured to run in stealthChop mode? Trinamic warns that using stealthChop at high speeds can lead to false short-to-ground reports. Enabling pressure advance might also make this more likely. Try switching the extruder driver mode to spreadCycle. And upgrade to firmware 3.1.1.



  • @Phaedrux @dc42 First off thanks for the support and quick response! The exact fault I'm getting I'm getting is "Error: short to ground reported by driver(s) 4" I have updated the Firmware (thanks for explaining how to and the download) and tried a print, it started but about 10 seconds in it threw the error. I have switched the driver to spreadCycle from stealthChop, the machine did not like that, a few skipped steps during the purge and then it threw the same error after it started printing. The wiring is looking more and more to be the culprit. Of course my crimper and connectors are buried somewhere. Unless someone has something else I can try, I'll be swapping out the wiring once I get the ambition to do so... I'll keep you updated as soon as swap the wiring. Thanks!


Log in to reply