PanelDue5i - not communicating



  • I've upgraded my BigBox Dual with a Duet3, PanelDue5i and RPI. Initially I only had the 3 components plugged in and all seemed good. Installed the boards and fitted a PT100 daughter board, all still worked. V1.24 PanelDue, 3.1.1 and DuetLite.

    Came back a few weeks later to continue adding the remaining wiring and noticed the PanelDue was stuck on initialising (top right hand side), foolishly upgraded the firmware to the 3.2 beta, no change but decided that it was probably the lack of sensors / steppers.

    I've just finished wiring everything up, all fans, extruders, sensors function correctly but still no PanelDue5i working.

    Will have some time tomorrow to fault find, where should I look?

    Things I've checked.
    (1) Continuity in the cable (made up 2 more cables just in case, tried soldering connections on one of them).
    (2) Swapped over the two data lines (just in case)
    (3) Confirmed M575 P1 S1 B57600 is in config.g
    (4) With the PanelDue5i powered up but not connected to the main board it displays the same characteristics. Touch screen works, menus function.
    (5) Checked the solder connections on the PanelDue5i (as it's easy to get to, nothing obvious)

    Where do I go next, redo all of the firmwares - RPI, PanelDue5i and Duet3 motherboard?


  • Moderator

    I'd go through the firmware flash process on the paneldue and use 1.24 and make sure you've got the right bin file for your version of paneldue.




  • Moderator

    Yup looks correct.

    The 3.2 release should work too with that PanelDue, but just want to see if rolling back makes a difference.e



  • Sorted, many thanks. Not exactly sure what I did differently this time but I ended up with a different result - PanelDue5i is working!

    When I removed the unit I checked the cable and during my belling out a crimp popped out, the connection looked fine but when I tested it it showed open circuit, 50/50 chance for where the bad end was and I lost, it was the end on the motherboard end. Two crimps later and a firmware update and all good.

    Tomorrow is calibration of extruders and fun with bed levelling.


Log in to reply