4 KW Heat Bed Tuning



  • Hi all.
    I am trying to tune my Giant 3D machine. Heat bed is about 3-3.5 kw.
    Basically, slow heating up.
    Board Duet2Wifi r 1.04
    Controlling the high voltage heater with Solid Relay.
    at the first trial;

    Error: Heater 1 fault: temperature rising much more slowly than the expected 0.3°C/sec
    

    I read some articles about PID tuning.
    I have tried ;

    M303 H0 S45
    

    A new error appeared;

    Auto tuning heater 0 using target temperature 45.0°C and PWM 1.00 - do not leave printer unattended
    
    Auto tune cancelled because temperature is not increasing
    

    It does actually rising, not much as firmware expected 🙂 Sensor and heater wire distance a cm distance. So even the bed solid aluminum, it took time to compensate.

    This the Bed Heater parameters ;

    ; Bed Heater
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138     ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0                              ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B0 S0.50                                   ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0                                            ; map heated bed to heater 0
    M143 H0 S100                                       ; set temperature limit for heater 0 to 120C
    
    

    Due to the Size of the Heat Bed ( 120 cm in diameter ) temperature rising slow. It is almost 2-3 celsius/minute.
    Could you recommend a solution?
    Kind Regards


  • Moderator

    Tuning such a large slow heater may be problematic.

    Have you seen this page?

    https://duet3d.dozuki.com/Wiki/Tuning_the_heater_temperature_control#Section_Setting_the_model_parameters_manually

    You may be able to derive appropriate values manually.


  • administrators

    Use M307 to set the D parameter very high, e.g. to 60. Then try M303 again.



  • @dc42 Thanks for the support. Unfortunately, I am in quarantine. As soon as I finish it I will try again.



  • @dc42 said in 4 KW Heat Bed Tuning:

    Use M307 to set the D parameter very high, e.g. to 60. Then try M303 again.

    Hi,

    I have tried D parameter up to 500. But it still error.

    11/9/2020, 1:18:15 PM Auto tune canceled because the temperature is not increasing.
    Despite cold, heat bed actually heated to 32 celsius. It is slow but working.

    Should I increase the higher D parameter or any other suggestions?
    I am using the code for Auto tuning

    M303 H0 S45
    

    For the Configuration ;

    ; Bed Heater
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138     ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0                              ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 D220 B0 S0.50                                   ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0                                            ; map heated bed to heater 0
    M143 H0 S100                                       ; set temperature limit for heater 0 to 120C
    

  • administrators

    Check whether setting a very high D parameter actually worked by sending M307 H0, because there is a limit on the allowed value.

    There will be a new heater tuning algorithm in RRF soon, and in that algorithm I will allow for slower bed heaters.



  • @dc42 said in 4 KW Heat Bed Tuning:

    Check whether setting a very high D parameter actually worked by sending M307 H0, because there is a limit on the allowed value.

    There will be a new heater tuning algorithm in RRF soon, and in that algorithm, I will allow for slower bed heaters.

    Thank you for your support and Saving 🙂

    I have tried the D parameter by incrementing. None of them worked.
    I will try again for different values.

    Do you mean, for now, no way before Firmware update for the slow heaters?



  • pid.png
    By the way,

    I did not work in the Config file.

    I am sorry that I did not get that I have to send the manual M307 command from the console.
    it seems crossed the limits by console command.

    It is still showing tuning.

    I just wanna share the preview.



  • These are the result:

    11/9/2020, 2:05:38 PM Auto tune heater 0 completed in 942 sec
    Use M307 H0 to see the result, or M500 to save the result in config-override.g

    ; config-override.g file generated in response to M500 at 2020-05-01 14:08
    ; This is a system-generated file - do not edit
    ; Heater model parameters
    M307 H0 A233.3 C508.3 D1.3 S1.00 V24.3 B0
    G31 Z1.2
    ; Workplace coordinates
    G10 L2 P1 X0.00 Y0.00 Z0.00
    G10 L2 P2 X0.00 Y0.00 Z0.00
    G10 L2 P3 X0.00 Y0.00 Z0.00
    G10 L2 P4 X0.00 Y0.00 Z0.00
    G10 L2 P5 X0.00 Y0.00 Z0.00
    G10 L2 P6 X0.00 Y0.00 Z0.00
    G10 L2 P7 X0.00 Y0.00 Z0.00
    G10 L2 P8 X0.00 Y0.00 Z0.00
    G10 L2 P9 X0.00 Y0.00 Z0.00
    
    

    M307 H0
    Heater 0 model: gain 34.9, time constant 875.1, dead time 15.4, max PWM 1.00, calibration voltage 24.3, mode PID
    Computed PID parameters for setpoint change: P291.4, I2.513, D3133.1
    Computed PID parameters for load change: P291.4, I6.056, D3133.1


  • administrators

    I am glad that you got a result. The reported gain of 34.9 implies that the maximum reachable temperature will only be about 35C above ambient. Will that be enough for you?

    How large is the bed?



  • @dc42 said in 4 KW Heat Bed Tuning:

    I am glad that you got a result. The reported gain of 34.9 implies that the maximum reachable temperature will only be about 35C above ambient. Will that be enough for you?

    How large is the bed?

    Bed is 120 cm in diameter, 5 cm thick aluminum custom self-made in 4-kilowatt consumption.
    We can cook something or use as Lab heater. It is very functioning 😄
    Thank you for your kindly help.
    It seems it is working. Don`t get me wrong, but I will request a donation to your work for development from our University management. It was worth.



  • @sozkan WhatsApp Image 2020-11-09 at 14.36.14.jpeg

    Work in progress picture of Heat Bed


  • Moderator

    @sozkan So you were able to successfully tune with M397 H0 D160?


  • administrators

    Aha, it's Delta then!



  • @Phaedrux said in 4 KW Heat Bed Tuning:

    @sozkan So you were able to successfully tune with M397 H0 D160?

    Yes, it was. Today It`s warned again about the slow heating issues. I have run the PID process again this time with D60 ( because it says D160 bad command )
    It is solved again.
    Thank you for concerning 🙂



  • @dc42 said in 4 KW Heat Bed Tuning:

    Aha, it's Delta then!

    Yes, it is.



  • @sozkan

    I greatly appreciate this thread as I'm trying to autotune a similar bed (very large aluminum plate with a 1.5KW heater).

    It seems like I get a "Bad Model Parameters" in the M307 command whenever the D value goes above 70.

    Since I have an (intentionally) somewhat underpowered heater, my dead time is probably right around there or a bit higher. This means I am not able to use the autotune on my heated bed, as it's still expecting more temperature rise than the heater produces. My approach now is to guestimate the model manually and then hopefully tweak it by hand once I can see how it's holding a temperature.

    In general, it seems worthwhile to add a parameter to the autotune function which scales its expectations based on a user-input "guess" of how long the whole heatup process should take. I think this would correct a lot of the frustrations around autotuning I've had or seen others experience before.


  • Moderator



  • Actually, going to refine that prior post: It seems like, if I send a fully-formed M307 command, like:

    M307 H1 A100 C800 D100 S1 V24.5 B0

    I can program a higher dead time.



  • @Phaedrux Yes, thank you. Will follow along there eagerly.


Log in to reply