Thermostatic fan and PWM and Duex



  • Hi,
    I have a problem configuring the cooling fan for a heatsink. Probably I just not using the right commands/config.

    What I want to achieve:
    When hotend temperature >45°C turn fan on, full power. Else turn fan off.

    I am using Duet 2 Ethernet board with RRF 3.1.1 and a Duex5. The Fan is connected to the Duex, because it is 12V. Since my main voltage is 24V, I am leveraging the internal 12V power supply of the duex.

    My gcode is:

    M950 F1 C"duex.fan8+^duex.pb6"
    M106 P1 C"HeatSinkFan" S0 H1 T45
    

    The result is: Fan starts turning at the right temperature, but sounds quite unhappy and tacho readings are wrong (largely fluctuating and extremely high)


    For testing purposes I tried the following:

    M950 F1 C"duex.fan8+^duex.pb6"
    M106 P1 C"HeatSinkFan" S0 H-1
    

    This way I can control the fan manually. Observed behaviour is:

    Power = 100% ==> no unhappy noise, good tacho values
    0% < Power <100% ==> unhappy noise, bad tacho values


    From this I think I can say: Thermostatic configuration does some PWM-magic (which my fan does not like) instead of just full-power the fan.

    So my question is:
    How to disable PWM and just go for constantly on or constantly off with thermostatic fans?



  • It seems I have not read the docs as good as I thought. The L Parameter of the M106-Command fixes my problem. This is the minimum Power for this fan.

    M950 F1 C"duex.fan8+^duex.pb6"
    M106 P1 C"HeatSinkFan" S0 H1 T45 L255
    

    I found this out when investigating the fan status by running M106 P1. It only turned with 50% power.