Motors very loud



  • I know there are already a lot of people who addressed this but after reading the forum for a day I still can't get the motors silent. There are very loud when moving but also in idle mode. I have the duetwifi on a ender3 pro. Two weeks ago I also got the ender 3 v2 and those motors are hardly noticable. I don't know what I am doing wrong so maybe someone could give me some suggestions. I tried altering the current to the motors, I tried https://duet3d.dozuki.com/Wiki/Reducing_Stand-Still_Noise but with no effect.



  • Please Post your config.g



  • ; General preferences
    G90                                                ; send absolute coordinates...
    M83                                                ; ...but relative extruder moves
    M550 P"Dennis3D"                                   ; set printer name
    
    ; Network
    ; M551 P"Ender3ProDennis"                          ; set password
    M552 S1                                            ; enable network and acquire dynamic address via DHCP
    M586 P0 S1                                         ; enable HTTP
    M586 P1 S0                                         ; disable FTP
    M586 P2 S0                                         ; disable Telnet
    
    ; Drives
    M569 P0 S0                                         ; physical drive 0 goes backwards
    M569 P1 S0                                         ; physical drive 1 goes backwards
    M569 P2 S1                                         ; physical drive 2 goes forwards
    M569 P3 S0                                         ; physical drive 3 goes backwards
    M584 X0 Y1 Z2 E3                                   ; set drive mapping
    M350 X16 Y16 Z16 E16 I1                            ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E138.50                   ; set steps per mm
    M566 X1200.00 Y1200.00 Z24.00 E300.00              ; set maximum instantaneous speed changes (mm/min)
    M203 X9000.00 Y9000.00 Z180.00 E6000.00            ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z100.00 E5000.00              ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E1000 I30                      ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                            ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1                                   ; set axis minima
    M208 X235 Y235 Z260 S0                             ; set axis maxima
    
    ; Endstops
    M574 X1 Y1 S1                                      ; set active high endstops
    M574 Z1 S2
    
    ; Z-Probe
    M558 P9 H5 F120 T6000                              ; disable Z probe but set dive height, probe speed and travel speed
    M557 X5:235 Y20:220 S40                            ; define mesh grid
    G31 P25 X31 Y18 Z2.25		         	   ; set BLTouch offsets	
    
    ; Heaters
    M305 P0 T100000 B4092 R4700             	   ; set thermistor + ADC parameters for heater 0
    M143 H0 S150                           		   ; set temperature limit for heater 0 to 150C
    M305 P1 T100000 B4092 R4700             	   ; set thermistor + ADC parameters for heater 1
    M143 H1 S275                            	   ; set temperature limit for heater 1 to 275C
    
    ; Disable heater to free up PWM channel
    M307 H7 A-1 C-1 D-1				   ; Disable heater 7 for BLTouch
    
    ; Fans
    M106 P0 S0 I0 F500 H-1                             ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45                          ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    ;M106 P2 S1 I0 F500 H1 T45                        ; set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 T35 H100:101:102
    
    ; Tools
    M563 P0 S"HotEnd" D0 H1 F0                         ; define tool 0
    G10 P0 X0 Y0 Z0                                    ; set tool 0 axis offsets
    G10 P0 R0 S0                                       ; set initial tool 0 active and standby temperatures to 0C
    
    ; Custom settings
    M912 P0 S-6,5					   ; CPU temparature calibration
    
    ; Miscellaneous
    M501                                               ; load saved parameters from non-volatile memory
    M911 S21 R23 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss
    T0                                                 ; select first tool
    
    


  • @dden said in Motors very loud:

    Two weeks ago I also got the ender 3 v2 and those motors are hardly noticable.

    ender 3 v2 uses tmc2208 (or tmc2209) drivers. the duet wifi uses tmc2660.

    the tmc2208 support stealthchop2. that is what makes them silent.
    the tmc2660 does not.

    the duet maestro or the duet 3 have drivers that support stealthchop2.



  • Well that sucks. I bought the duet board because it was advertised to have silent steppers. Since I only have wifi in my room, I thought it a good idea to buy the wifi board. I think I will put in a creality silent board, which is a pity because I really liked the reprap software, way easier to configure than Marlin.


  • Moderator

    @dden said in Motors very loud:

    I tried altering the current to the motors

    What motor currents have you tried? Keep in mind you're limited to 100ma increments.

    I've found the Creality motors to have a lot of whine with the duet drivers as well. I think Creality has just chosen motors that work well with their drivers.



  • So maybe it is better I buy a few new stepper motors? Which ones do you recommend? Oh and I tried lots of different currents and I know I need to use 100 ma increments, I think I started at 500 and went up to 1000



  • if they are the same motors as the ender 3 the specs are here
    https://gist.github.com/knoopx/e6c40a009e796203b93a75a3ed6a5ab8


  • administrators

    I don't think you have told us which Duet you are using, or what VIN voltage you are using.


  • Moderator

    @dc42

    @dden said in Motors very loud:

    I have the duetwifi on a ender3 pro.

    Stock, the ender3 pro is 24v.


Log in to reply