Laser not turning off



  • I've installed a cheap ebay laser controlled with pwm with the additional circuit from the pvm laser guide. When I installed it for the first time it worked as in i could cut cardboard with it.

    Now a few months later i'm trying to get it running again with Lightburn hopefully, but my Laser turns on as soon as i put the machine in laser mode with :

    M452 C"exp.heater3" R255 F5000
    

    and only turns off if I reset the machine, it doesn't react to any of the following:

    M5
    M3 S0
    G0
    G1 S0
    

    At this point i'm afraid i've fried some circuit which would explain why it's always on not so much why it turns off with the reset or stays off before i enable Laser Mode, right ?

    My Machine:

    • MPCNC burly
    • Duet Wifi 2
    • Version: 3.1.1

    Thanks in advance!



  • Can't update my post anymore - sorry - so here is my config:
    My Config:

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.3 on Sun Sep 08 2019 11:43:58 GMT+0200 (Central European Summer Time)
     
    ; General preferences
    G90                            ; send absolute coordinates...
    M83                            ; ...but relative extruder moves
    M550 P"MPCNC"                  ; set printer name
     
    ; Network
    M552 S1                        ; enable network
    M586 P0 S1                     ; enable HTTP
    M586 P1 S0                     ; disable FTP
    M586 P2 S0                     ; disable Telnet
     
    ; Drives
    M569 P0 S1                     ; physical drive 0 goes forwards
    M569 P1 S1                     ; physical drive 1 goes forwards
    M569 P2 S1                     ; physical drive 2 goes forwards
    M584 X0 Y1 Z2                  ; set drive mapping
    M350 X16 Y16 Z16 I1            ; configure microstepping with interpolation
    M92 X100.00 Y100.00 Z400.00     ; set steps per mm
    M566 X900.00 Y900.00 Z12.00    ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00    ; set accelerations (mm/s^2)
    M906 X1700 Y1700 Z1700 I30     ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                        ; Set idle timeout
     
    ; Axis Limits
    M208 X0 Y0 Z0 S1               ; set axis minima
    M208 X579 Y578 Z150 S0         ; set axis maxima
     
    ; Endstops
    M574 X1 S1 P"!xstop"
    M574 Y1 S1 P"!ystop"
    M574 Z0 S1 P"!zstop"
     
    ; Z-Probe
    M558 P5 H5 F120 T3000 C"!^zprobe.in"               ; set Z probe type to switch and the dive height + speeds
    G31 P500 X0 Y0 Z19.20575                      ; set Z probe trigger value, offset and trigger height
    M557 X0:550 Y0:550 S50  
     
    ; Heaters
    M140 H-1                       ; disable heated bed
    M307 H3 A-1 C-1 D-1       ; Disable Heater output on H3
     
    ; Fans
    M106 P0 S0 I0 F500 H-1         ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    ;M106 P2 S1 I0 F500 H-1
    M950 F2 C"!Fan2"
     
    ; Tools
    M563 P1 S"Spindel" F0               ; define tool 0
    G10 P1 X0 Y0 Z0                ; set tool 0 axis offsets
    G10 P1 R0 S0                   ; set initial tool 0 active and standby temperatures to 0C
     
    ; Custom settings are not defined
    M453 C"fan0" R6000 T1 ; CNC MODE
     
    ; Miscellaneous
    T1                             ; select first tool
    M106 P0 I-1
    


  • @marvinosswald if you sent M3 S255 does it turn off?



  • @jay_s_uk it actually does, sorry forget to mention that.



  • @marvinosswald invert your pin then using !
    only issue i can see though is it will probably briefly turn on until the firmware boots



  • @jay_s_uk i'll try that tonight, thanks alot. i'll report back.


  • administrators

    If it use to work but doesn't any more, most likely the 74HCT02 chip on the converter board you made is fried. If you mounted it in an IC socket, you can easily replace it.



  • @jay_s_uk you suggestion worked, i must have figured it out at the time but never committed the "!" to my config. Thanks so much!

    @dc42 i was afraid of that but it seems like i was lucky.

    First cut came out decent 🙂

    First cut came out decent



  • Where did you buy the additional circuit ? I'm in switzerland and I dont know where to buy or how to build it...
    thank you.


Log in to reply