Haeted BEd max temperature



  • I design my personal 3D printers (large format / high temperature).
    I would like to increase my maximum temperature of the heated bed to 160-180 ° C to print exotic materials. I use the command "M143 H0 S180" but I have the impression that the maximum setpoint is 125 ° C
    How can we modify this parameter
    thanks a lot



  • @bast said in Haeted BEd max temperature:

    I use the command "M143 H0 S180" but I have the impression that the maximum setpoint is 125 ° C

    what do you mean you have the impression?

    can you set the temperature to 180 in the web ui?

    btw what kind of bed do you have.

    that are temperature than only special beds can reach.
    like the e3d high temperatures beds.



  • @Veti said in Haeted BEd max temperature:

    what do you mean you have the impression?
    can you set the temperature to 180 in the web ui?
    btw what kind of bed do you have.
    that are temperature than only special beds can reach.
    like the e3d high temperatures beds.

    whoever does not want it gives me this error message by setting the temperature in the web interface
    "M140 P0 S180
    Error: M140: Temperature too high for heater 0 "
    I have a 750w 220v heating silicone mounted under a metrology granite bed to be able to reach these temperatures (with my old megatronicV3 card the heated bed heated to 200 ° c without problem 🙂



  • @bast said in Haeted BEd max temperature:

    M140

    did you observe the order?
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M143_Maximum_heater_temperature

    If the heater is a bed or chamber heater then the M143 command must come after the M140 or M141 command that declares the heater as a bed or chamber heater.



  • If you wanted to confirm, you could always run the M143 H0 command manually from the console once the machine is already on, it will read out the max temp settings.

    Also note that if you want temps of 180, you should set the max temp to a bit higher than 180, else it may throw an error every time it goes slightly above the setpoint, which would get annoying to deal with.



  • See this thread which is potentially related: https://forum.duet3d.com/topic/19031/m143-issue



  • OK you awsome
    My M140 H0 was after M143 so now it would be good

    M143 H0
    Heater 0 monitor 0 uses sensor 0 to generate a heater fault if the reading exceeds 180.0°C
    Heater 0 monitor 1 is disabled
    Heater 0 monitor 2 is disabled

    thanks a lot guys 😉


Log in to reply