Can't use BOSSA to update and fix Duet3 board



  • I make new bin file and update the firmware failure. I download Duet3Firmware_MB6HC.bin and want to use the BOSSA to update. I have erased the Duet3 board. But I can't find the COM port with USB port. How do I fix my Duet3 board?



  • Most people have problems with bad USB cables or ports when not being able to find the USB serial port.

    Does the computer react at all when you connect the board? Are there any LEDs lit on the board?

    Firmware failing doesn't affect the bootloader so it shouldn't prevent the computer finding the USB serial port unless the hardware is damaged.

    https://duet3d.dozuki.com/Wiki/What_to_do_if_your_Duet_won't_respond might help diagnose the issue if it's not a USB issue.



  • Don’t want to break in on this suject, but I have the same issue. On my surface book the duet printer usb is recognised. Com5 is made available. When Flashing the bin file bosa says it is not connected.
    I did reset the board. It is recognised ( first deconnection sound followed by recognition sound. Com5 made available. Then after another reset, my laptop provides the message that the usb device is not recognised and that stays like that.

    Then i took another windows surface, same reaction again, connecting sound no message but com 5 made available, but no possibility to flash (not connected message) luckally the card remains recognised.

    My system has a raspberry pi and the Maestro3. I’m using the maestro usb connection...

    I’ll try a different cable...


  • Moderator

    @ahwitmer There's also the chance that the surface book isn't able to provide enough power from the USB port for the Duet. If you have another system (maybe a desktop or a laptop with a charging port) try that.

    Even the Pi could be used in a pinch.

    The fact that the device detection sound is happening means the cable probably will work.



  • For me it now works!

    Used another cable to another surface tablet on a docking station, and it worked!

    Don't know if it is the cable or the docking station. But I'm happy to see it work!
    Interestig to see that when the printer is switched off but connected to the surface, the genuine BL touch lights up.

    Thanks for the support,

    Harald



  • One thing, it updated correctly, verification was positive.
    After restart however, the RPI still mentions:
    "Failed to connect to Duet3"
    "DCS is unavailable"

    I restarted the system, no change
    Surface disconnected and restarted, no change
    reset the Duet3, no change
    Connecting surface, Duet recognised but Bossa verify does not work.
    repeated the erasing and updating, still the same problem

    Set-up
    Installed bin: 3.2 beta 2 (Duet3Firmware_MB6HC)
    3D printer: Duet 3 and 3 expansion boards 3HC (Januari 2019)
    RPI 4 Model B - 4GB


  • Moderator

    @ahwitmer Try reflashing your pi with a fresh DuetPi image.

    https://duet3d.dozuki.com/Wiki/SBC_Setup_for_Duet_3?revisionid=HEAD#Section_Step_1_Flash_the_image_file

    And then since you've got a beta on the board you'd have to add the unstable update repository on the pi.

    https://duet3d.dozuki.com/Wiki/Getting_Started_With_Duet_3#Section_Software_Installation

    That is, of course, assuming you intend to do beta testing. If you want to stick to the stable branch you'd want to stick with 3.1.1



  • @ahwitmer said in Can't use BOSSA to update and fix Duet3 board:

    Duet recognised but Bossa verify does not work.
    repeated the erasing and updating, still the same problem

    is the erase jumper still in place? and what does the board identify as - duet or bossa on device manager?



  • @bearer The erase jumper has been removed after erasing. After erasing and removing the jumper, my Bossa program says nothing at all. My laptop confirms to see Duet3 after connecting cable again. I can choose a com port. The com port only appears when the laptop is connected via the PI. When updating it shows the prgress monitor from 0 to 100%. When performing the verify it confirms successfull update. I switch off the printer, disconnect the cable and restart the printer. After this it says not to be able to connect to the Duet3. Resetting or restarting has no effect.
    Then trying to perform a verify with bossa again after connecting laptop. Verification is not possible



  • @ahwitmer said in Can't use BOSSA to update and fix Duet3 board:

    My laptop confirms to see Duet3 after connecting cable again

    as what? a duet or a bossa port?



  • @bearer no just as Duet (from the tasktray), the Bosa program does not say anything. The program has only a com port available when plugged in.



  • @bearer @Phaedrux
    I thought to take the latest version not necessarily Beta testing the firmware.
    I will use to the stable version 3.1.1. I will try that one first. If that does not work I will take the reflash of the pi sd



  • @Phaedrux @bearer
    First trial, version 3.1.1 downloaded
    Jumper on duet3
    switch printer on
    after starting up, switch printer off
    jumper removed and switch off
    Printer switched on, wait for startup
    connect laptop to printer via duet3 USB connection
    Bosa makes com 4 available
    Checked: Erase all, boot to flash and lock
    Update 711 pages, verify okay
    switch off, disconnect laptop
    switch on, "failed to connect Duet3"

    I will now download the alternative duet pi image to the pi sd card.


  • Moderator

    @ahwitmer Are you powering the duet and Pi separately?



  • @Phaedrux @bearer
    It finally worked !
    Updating the Pi sd card to the latest version, finally did it. It is connected to the duet3 again, great!

    Also surprisingly this time my pi asked me to update the firmware something it did not do before. So now I upgraded the Duet3 to version 3.1.1 and updated the RPi too.

    Now updating firmware of the three expansion boards

    Thanks for the help



  • @Phaedrux No the RPi is powered via the duet card. I have a separate power available but until now, it was not necessary to use it.

    Ultimately for the problems I encountered it is not an issue!


Log in to reply