Configuration problem?



  • OK, I have switched to a Duet wifi as I hear its the best but now after 2 weeks i have a new issue. When I home all it sounds like the printer is going to destroy its self. The motors move like they are intended to but homing seems to throw it for a loop, I have a buddy who has a D-bot as well and after many hours of trying even he is at a loss. I have videos and will be more then thankful for any help.



  • Post your config.g and homall.g



  • Have you recently upgraded to 1.19betaX? If so and its a corexy machine you need to change your motor plugs as the kinematics have been changed to make them more in line with other firmware.


  • administrators

    @Sharpie:

    OK, I have switched to a Duet wifi as I hear its the best but now after 2 weeks i have a new issue. When I home all it sounds like the printer is going to destroy its self. The motors move like they are intended to but homing seems to throw it for a loop, I have a buddy who has a D-bot as well and after many hours of trying even he is at a loss. I have videos and will be more then thankful for any help.

    Please provide more detail:

    • Are the motors moving in the correct directions when you try to home?
    • if so, do they stop at the homing switches?
    • If you home the axes individually, so you have this problem on all axes, or just one axis, or not at all?
    • Which firmware version are you using?
    • What is your printer configuration: Cartesian, CoreXY, Delta etc. ?
    • Did the problem start immediately after you took some other action, e.g. upgraded the firmware or changed the wiring?


  • Please provide more detail:

    • Are the motors moving in the correct directions when you try to home? I am not sure
    • if so, do they stop at the homing switches? No they don't stop.
    • If you home the axes individually, so you have this problem on all axes, or just one axis, or not at all? It does not home individually it only works with the HomeAll
    • Which firmware version are you using? 1.18.1 (2017-04-09)
    • What is your printer configuration: Cartesian, CoreXY, Delta etc. ? CoreXY (D-Bot)
    • Did the problem start immediately after you took some other action, e.g. upgraded the firmware or changed the wiring? Nope, I took the Duet WiFi out of the box and plugged it in.

    Here is my Config.g

    "; CoreXY sample config file for dc42 Duet firmware

    M111 S0 ; Debug off
    M550 PBig-D ; Machine name (can be anything you like)
    M551 Preprap ; Machine password (used for FTP connections)
    ns)
    ;*** If you have more than one Duet on your network, they must all have different MAC addresses, so change the last digits
    M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0xED ; MAC Address
    ;*** Wifi Networking
    M552 S1 ; Enable WiFi

    M555 P2 ; Set output to look like Marlin
    ;M575 P1 B57600 S1 ; Comms parameters for PanelDue

    ; Machine configuration
    M569 P0 S1 ; Drive 0 goes forwards (change to S0 to reverse it)
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    ; If you use an endstop switch for Z homing, change Z0 to Z1 in the following line, and see also M558 command later in this file
    M574 X1 Y2 Z1 S0 ; set endstop configuration (X and Y and endstops only, at low end, active high)
    M667 S1 ; set CoreXY mode
    M350 X64 Y64 Z64 E64 I0 ; Set 16x microstepping with interpolation
    M92 X400 Y400 Z1600 ; Set axis steps/mm
    M92 E1643:1643 ; Set extruder steps/mm
    M906 X800 Y800 Z800 E800 ; Set motor currents (mA)
    M201 X1000 Y1000 Z300 E4000 ; Accelerations (mm/s^2)
    M203 X15000 Y15000 Z500 E1500 ; Maximum speeds (mm/min)
    M566 X800 Y800 Z24 E1200 ; Maximum jerk speeds mm/minute
    M208 X300 Y185 Z320 ; set axis maxima (adjust to suit your machine)
    M208 X0 Y0 S1 ; set axis minima (adjust to make X=0 and Y=0 the edges of the bed)
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves

    ; Z probe
    ;M558 P1 X0 Y0 Z1 ; Analog Z probe, also used for homing the Z axis
    ;G31 Z2.47 P500 S1 ; Set the probe height and threshold (put your own values here)
    ; The following M557 commands are not needed if you are using a bed.g file to perform bed compensation
    ;*** Adjust the XY coordinates in the following M557 commands to suit your build and the position of the Z probe
    ;M557 P0 X30 Y25 ; Four...
    ;M557 P1 X30 Y155 ; ...probe points...
    ;M557 P2 X250 Y125 ; ...for bed...
    ;M557 P3 X250 Y25 ; ...levelling
    ;M557 P4 X150 Y95 ; 5th probe point for levelling

    ; Thermistors and heaters
    ;*** You can use S and B parameters to define the parameters of the thermistors you are using
    M305 P0 T100000 B4388 R4700 H0 L0 ; Put your own H and/or L values here to set the bed thermistor ADC correction
    M305 P1 T100000 B4388 R4700 H0 L0 ; Put your own H and/or L values here to set the first nozzle thermistor ADC correction
    M305 P2 T100000 B3974 R4700 H0 L0 ; Put your own H and/or L values here to set the second nozzle thermistor ADC correction
    M301 H1 P10 I0.10 D100 T0.50 S1.0 ; PID settings for extruder 0
    M301 H2 P10 I0.10 D100 T0.50 S1.0 ; PID settings for extruder 1
    M570 S120 ; Increase to allow extra heating time if needed
    M307 H0 A86.7 C612.7 D6.0 B0
    M307 H1 A406.3 C166.4 D10.3 B0

    ; Fans
    M106 P1 T50 H1

    ; Tool definition
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 S0 R0 ; Set tool 0 operating and standby temperatures
    ;*** If you have a dual-nozzle build, un-comment the following 3 lines
    ;M563 P1 D1 H2 ; Define tool 1
    ;G10 P1 S0 R0 ; Set tool 1 operating and standby temperatures

    ;*** If you are using axis compensation, put the figures in the following command
    M556 S78 X0 Y0 Z0 ; Axis compensation here
    T0 ; select first hot end"

    HomeAll.g

    G91
    G1 Z5 F6000
    G90

    ; Move quickly to X axis endstop and stop there (first pass)
    G1 X-0 F2400 S1

    ; Go back a few mm
    G91
    G1 X5 F6000
    G90

    ; Move slowly to X axis endstop once more (second pass)
    G1 X-305 F600 S1

    ; Lower Z again
    G91
    G1 Z-5 F6000
    G90

    ; Home Y
    ; called to home the Y axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Feb 25 2017 23:01:01 GMT-0800 (PST)

    ; Lift Z relative to current position
    G91
    G1 Z5 F6000
    G90

    ; Move quickly to Y axis endstop and stop there (first pass)
    G1 Y213 F2400 S1

    ; Go back a few mm
    G91
    G1 Y-5 F6000
    G90

    ; Move slowly to X axis endstop once more (second pass)
    G1 Y205 F600 S1

    ; Lower Z again
    G91
    G1 Z-5 F6000
    G90

    ; Home Z

    G91 ; relative mode
    G1 Z4 F500 ; raise head 4mm to ensure it is above the switch trigger height
    G90 ; back to absolute mode
    G1 X0 Y0 F5000 ; put head wherever you want it to be when you home Z (omit this line if it doesn't matter)
    G91 ; relative mode
    G1 Z-350 S1 F500 ; move Z down until the switch triggers
    G90 ; back to absolute mode
    G92 Z0.3


  • administrators

    I think you are saying that this is a new issue for you since you change to to the Duet, but you haven't ever got it working with the Duet. This is what I suggest:

    1. Choose where the X=0 Y=0 head position should be. The usual choice is at the front left.

    2. That defines which are the correct X and Y movement directions. If X=0 Y=0 is front left, then +X is towards the right and +Y is towards the rear.

    3. Until you have everything working, reduce the motor currents to avoid damage if things go wrong. These are set in the M906 command in config.g. You have them set to 800mA. I suggest you try 400mA for now.

    4. Test the endstop switches, using either M119 or by looking at the Settings -> Machine Properties page of the web interface. They should show correctly whether each endstop switch is triggered or not.

    5. Use the jog controls of the web interface to check that X+10 moves 10mm in the +X direction. Similarly for X-10, Y+10 and Y-10.

    6. Your M574 command indicates that you have a low-end X endstop switch, and a high end Y endstop switch. So if X=0 Y=0 is front left, the X switch is at the left and the Y switch is at the rear. Is this correct?

    If you report the results back then we should be able to diagnose the problem.



  • 1. Choose where the X=0 Y=0 head position should be. The usual choice is at the front left.

    2. That defines which are the correct X and Y movement directions. If X=0 Y=0 is front left, then +X is towards the right and +Y is towards the rear.

    3. Until you have everything working, reduce the motor currents to avoid damage if things go wrong. These are set in the M906 command in config.g. You have them set to 800mA. I suggest you try 400mA for now.

    OK I changed the Currents to 400mA but now my motors dont have enough power to move my parts

    4. Test the endstop switches, using either M119 or by looking at the Settings -> Machine Properties page of the web interface. They should show correctly whether each endstop switch is triggered or not.

    They do show weather they are triggered or not but that does not stop them when I click homeall.g it just moves from left to right until it hits the right side then tries to keep going.

    5. Use the jog controls of the web interface to check that X+10 moves 10mm in the +X direction. Similarly for X-10, Y+10 and Y-10.

    When I move the X and Y it does move in the correct and expected movements.

    6. Your M574 command indicates that you have a low-end X endstop switch, and a high end Y endstop switch. So if X=0 Y=0 is front left, the X switch is at the left and the Y switch is at the rear. Is this correct?

    When I give the M574 command I get this output,

    Endstop configuration: X low end (active low), Y high end (active low), Z low end (active low),

    If you report the results back then we should be able to diagnose the problem.

    Thank you so much again for the help gentlemen 😃


  • administrators

    Regarding #6, are your X and Y endstop switches positioned as described - X switch at the left and Y switch at the back?

    If the X switch is on the left but the head moves right when you try to home, that suggests your homing files are wrong. Please post the contents of all 4 homing files.

    You may find it helpful to generate new homing files using configtool.



  • @dc42:

    Regarding #6, are your X and Y endstop switches positioned as described - X switch at the left and Y switch at the back?

    If the X switch is on the left but the head moves right when you try to home, that suggests your homing files are wrong. Please post the contents of all 4 homing files.

    You may find it helpful to generate new homing files using configtool.

    Yes, my X Endstop is at the Left and my Y is at the back.

    I generated a new Homing files and when I home anything I just get my left "Z" Motor (Z moter1, or ZA) Moves both nothing else.

    HomeAll.g

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Jul 28 2017 17:07:42 GMT-0700 (Pacific Daylight Time)

    ; Relative positioning
    G91

    ; Lift Z
    G1 Z5 F6000

    ; Course home X or Y
    G1 X-305 Y305 F1800 S1
    ; Course home X
    G1 X-305
    ; Course home Y
    G1 Y305

    : Move away from the endstops
    G1 X5 Y-5 F6000

    ; Fine home X
    G1 X-305 F360 S1
    ; Fine home Y
    G1 Y305 S1

    ; Absolute positioning
    G90

    ; Go to first bed probe point and home Z
    G1 X15 Y15 F6000
    G30

    ; Uncomment the following line to lift the nozzle after probing
    ;G1 Z5 F100

    HomeX.g

    ; homex.g
    ; called to home the X axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Jul 28 2017 17:07:42 GMT-0700 (Pacific Daylight Time)

    ; Lift Z relative to current position
    G91
    G1 Z5 F6000
    G90

    ; Move quickly to X axis endstop and stop there (first pass)
    G1 X-305 F1800 S1

    ; Go back a few mm
    G91
    G1 X5 F6000
    G90

    ; Move slowly to X axis endstop once more (second pass)
    G1 X-305 F360 S1

    ; Lower Z again
    G91
    G1 Z-5 F6000
    G90

    HomeY.g

    ; homey.g
    ; called to home the Y axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Jul 28 2017 17:07:42 GMT-0700 (Pacific Daylight Time)

    ; Lift Z relative to current position
    G91
    G1 Z5 F6000
    G90

    ; Move quickly to Y axis endstop and stop there (first pass)
    G1 Y305 F1800 S1

    ; Go back a few mm
    G91
    G1 Y-5 F6000
    G90

    ; Move slowly to X axis endstop once more (second pass)
    G1 Y305 F360 S1

    ; Lower Z again
    G91
    G1 Z-5 F6000
    G90

    HomeZ.g

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Jul 28 2017 17:07:42 GMT-0700 (Pacific Daylight Time)

    ; Lift Z relatively to current position
    G91
    G1 Z5 F6000

    ; Back to absolute positioning
    G90

    ; Go to first bed probe point and home the Z axis
    G1 X15 Y15 F6000
    G30

    ; Uncomment the following lines to lift Z after probing
    ;G91
    ;G1 Z5 F100
    ;G90


  • administrators

    So only one of your Z motors is moving? How are they wired: both to a single driver, or to separate drivers?



  • They are wired like the diagram says (Z moter1, or ZA and Z moter2, or ZB)


  • administrators

    If only one Z motor is moving and they are wired to the two Z moor connectors, that suggests that either there is too much friction on the shaft of the one that is not moving, or the current is much too low. What is the specification of the motors, and what current have you set?





  • ok I was able to correct the only one Z motor moving issue looks like it was binding when it got to a certin level. this has been addressed. My New problem is when I home Z the bed lowers away from the Endstop.



  • Are you sure your Z is going the correct direction? The reason I ask is because my machine is an Ultimaker like clone. When I first configured it, I had stuck in my head that when you hit +10 on the axis movement, the bed should go up. That was incorrect. Minus is up. Mine did the same as yours. Once I switched that, it homed fine.


  • administrators

    Sounds like you need to reverse the direction of the Z motor. Look for the M569 P2 command in config.g and change S0 to S1 in that command, or vice versa.



  • OK that worked, Now when I home Z it does not stop once the endstop is triggered. it tries to brake it.


  • administrators

    Read https://duet3d.com/wiki/Configuring_RepRapFirmware_for_a_Cartesian_printer#Homing_files in particular the parts about 2 different ways of homing the Z axis.



  • When you run an M119 command with none of the switches triggered, what does it show?



  • It Shows

    SENDING:M119
    Endstops - X: at min stop, Y: at max stop, Z: not stopped, Z probe: not stopped

    I have ran the M119 command and even with clicked the red LED goes on on both the motherboard and the endstop but when I run the M119 command it shows as not stopped like quoted above. i have even tried with 2 different endstops


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.