remap endstop

  • The Duet Wifi in my sand table seems to have a bad X endstop input, so I'd like to switch to the Z stop, but that doesn't seem to work.

    I'm using firmware 3.1.1. Here's the config.g file, heavily edited to remove unneeded stuff- endstop mapping is at the end of the file:

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Sat Nov 14 2020 20:09:44 GMT-0600 (Central Standard Time)
    ; General preferences
    G90                                       ; send absolute coordinates...
    M550 P"Arrakis"                           ; set device name
    M669 K1                                   ; select CoreXY mode
    ; Network
    M551 P"xxxx"                              ; set password
    M552 S1                                   ; enable network
    M586 P0 S1                                ; enable HTTP
    M586 P1 S0                                ; disable FTP
    M586 P2 S0                                ; disable Telnet
    ; Drives
    M569 P5 S1 R0 T4.0:5.0:6.0:12.0			; drive 5 reverse, lo enable, timing parameters for servomotors
    M569 P6 S1 R0 T4.0:5.0:6.0:12.0			; drive 6 reverse, lo enable, timing parameters for servomotors
    M584 X5 Y6                         ; set drive mapping- X motor at drive 5, Y motor at drive 6
    M350 X1 Y1                          ; configure microstepping without interpolation
    M92 X31.25 Y31.25        ; set steps per mm
    M566 X1800.00 Y1800.00     ; set maximum instantaneous speed changes (mm/min)
    M203 X90000.00 Y90000.00  ; set maximum speeds (mm/min)
    M201 X10000.00 Y10000.00    ; set accelerations (mm/s^2)
    M906 X300 Y300 I30              ; set motor currents (mA) and motor idle factor in per cent
    M84 S3                                   ; Set idle timeout
    ; Axis Limits
    M208 X0 Y0 Z0 S1                          ; set axis minima
    M208 X600 Y990 S0                   ; set axis maxima
    ; Endstops
    M574 X2 S1 P"!zstop"                       ; configure active-low endstop for Xmax via pin zstop
    M574 Y1 S1 P"!ystop"                       ; configure active-low endstop for Ymin via pin ystop
    M574 Z0

    When I move the carriage to trigger the endstop then send an M119 command, the Y endstop is working fine, but X doesn't want to trigger in either the X or Z endstop input. I measured the voltage swing at the output of the opto endstops- on the Y axis it swings between 2V when open and 0.11V when triggered. At X and Z the voltage swings between 1.87 and 0.1V.

    Any ideas?

  • @mrehorstdmd Never mind- turned out to be a bad cable between the X endstop and the board.

Log in to reply