Voltage issues on a Tool Board 1LC



  • I have a Tool Board 1LC v1.0 that I ordered from Filistruder.

    I am having issues with it that make me think it is a defective board but I wanted to check if I am doing anything wrong.

    I am connecting the Tool Board through a Tool Distribution Board. The voltage is at a solid 24.1v and nothing seems damaged on the Dist Board or the Tool Board.

    The Tool Board CAN-FD will sync with the Duet 3 Mainboard only when the cable is connected to the Distribution Board CAN Out port. A M115 B121 command responds with this;

    M115 B121
    Board TOOL1LC firmware 3.1.0 (2020-05-15b1)

    The Mainboard info is;
    Board: Duet 3 MB6HC (MB6HC)
    DSF Version: 3.1.1
    Firmware: RepRapFirmware for Duet 3 MB6HC 3.1.1 (2020-05-19b2)

    The main problem is the voltages across the board are all running significantly low.

    The Power input is a solid 24.1v

    12v outputs are measuring at 8.33v
    5v outputs are 1.745v
    3.3v outputs are 0.49v

    None of the inputs or outputs seem to do anything and I can’t seem to get any values back or make anything work from the board. These voltages stay stable with or without any equipment connected to the board.

    Am I missing some jumper or configuration settings? Is the board just broken?

    I would like to get this working and am open to any suggestions you have.



  • @drobertson123 Obviously this is an IQ test for me that I failed. The voltage offset happened because the ground wire on my probe was in the wrong port of the multimeter.
    The 24v reference was showing that value because I tuned the power supply using the same multimeter.

    The voltages on the board look perfectly fine, just as I would expect from a Duet product.

    I still have other issues. CAN-FD will only sync when the cable from the Main Board is on the Dist Board Out port and I can't seem to get the board to do anything. I am going to spend some additional time debugging now that I embarrassed myself publicly with this.

    Hopefully, I can sort out the issues.



  • Note - I would have no issue with deleting this post and starting another with a better focus on the issues I am experiencing if you would like.

    The title implies a problem that doesn't exist and that was my fault. I don't want to create a false impression.


  • Moderator

    It's up to you, if you'd like to delete it, I can do that for you. However, you have my respect and admiration for realizing a mistake and admitting it. It's just an example of learning. No shame in that.

    If you still have some issues it might be better to start a new thread with a more accurate title and include detailed descriptions of the problem and what you've tried so far and as much detail about the hardware setup and config as possible.



  • @Phaedrux The perceived voltage issue was a real blocker for me. I am doing some additional debugging now that I am past that.

    I don't mind leaving this here as an object lesson for others. My only worry was the title being misconstrued as an indication of poor quality or a problem when it was in no way justified.

    I am now trying to sort out the details of getting a PINDA v2 sensor and a Hemera extruder configured on the Tool Board 1LC.

    My goal is to eventually have the thermal compensation in the PINDA v2 probe working but let's call that a stretch goal. Now I just need it to act as a basic endstop.

    If this gets beyond me I will start a new thread with an appropriate title.



  • Mark the topic as "solved"


Log in to reply