M0 not working



  • Hi all. Im using the M0, trying to, into my end gcode for turning off all heaters. But Im noticing that if T1 is being used, it is the one being turned off, and T0 is being left on the stand by temperature (while dual extrusion prints)
    Shoudnt the M0 command turn off all heater as the documentation says?



  • Do you have it defined in cancel.g to turn off T0 and T1 heaters?


  • Moderator

    I think the best way to use M0 is to define your own shutdown sequence in stop.g

    But yes, based on the description you'd think M0 would turn off all tool heaters.

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M0_Stop_or_Unconditional_stop

    What firmware version are you using?

    Do you have a cancel.g or stop.g present in the sys folder?



  • @Phaedrux Im using latest stable, 3.1.1?
    Stop.g is in sys with some code in it, cancel.g is not present.
    So I misunderstood the command? M0 does nothing by itself but calls to cancel and stop.g files? Mu confusion comes from:
    "If no H1 parameter is present, the heaters are turned off too. "


  • Moderator

    M0 only has the default behaviour when cancel.g and stop.g are not present. Since you have a stop.g file with commands in it, it's going to execute that. So try removing the stop.g file to see if it will perform the default behaviour, or modify stop.g to make it do what you want.


Log in to reply