Smart effector randomly triggering in mid air after homing



  • I'm running into a peculiar problem. My smart effector seems to behave fine when I have both of my heaters off. I can run G30 and G32 without issue.

    The problem comes when I have both the heated bed and nozzle heaters active. I will G28 to home the carriages and then G30 S-1 to ensure the probe is working properly. I find that if I do this after homing the probe will randomly trigger well above the bed as if it was getting a false trigger. I cannot get it to probe on the bed with both heaters active.

    I have checked my wire connections and fixed those that I thought were bad and the problem will still persist.

    I also notice that after a G30 the green LED will stay on indefinitely. This happens with either a G30 or G30 S-1. I'm at my wits end because I cannot find anything similar enough to what I'm experiencing. I do not believe it is the hotend fan because with it running and the bed heater off I can successfully calibrate my printer.

    My printer is a rostock max V2 with a 12V 29A power supply, the original heated bed, a duet 2 wifi running reprap 3.1.1 and a delta smart effect V2. It might also be helpful to know that I have replaced the 1A blade fuse with a 2A and the 7.5A after they had both blown on me.

    Attached is my config.g file.
    config.g


  • Moderator

    Try adding M558 B1 parameter. This will temporarily turn off your heaters during the probe move to eliminate interference.



  • You believe it may be interference cause the effector to falsely trigger?



  • @Phaedrux That seems to have helped with the effector traveling halfway down then triggering. Right now I'm noticing that it is staying triggered after having moved back up.


  • Moderator



  • @Phaedrux I’ll try resetting the sensitivity and let you know how that goes. I switched the probe type to a P1 based off another forum post and it seems to not be staying high after probing. If I change it to a P5 or P8 it will reproduce the behavior I’m seeing.


Log in to reply