Duet 2 Wifi Perimeter Gaps



  • Hello. For some time, I've been struggling with a minor print quality issue with my printer. With every print, there are gaps between the perimeter and infill, mostly in the X direction (seems like the inner two perimeters are offset from the third). I tried: tuning my slicer (Simplify3D), calibrating extrusion and X/Y steps, playing with belt tension, installing a new X axis belt, modifying my X carriage so it slides smoother, swapping X and Y axis motors, enabling pressure advance. I know it is not my slicer because my bone stock Ender 3 with the same settings does not have this issue. The print comes out great! Im not sure if the issue lies within my firmware.
    ![0_1607113585228_AM8 DUET PETG OVERTURE.fff](Uploading 100%)
    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes backwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X100.78 Y100.67 Z397.27 E414.69 ; set steps per mm
    M566 X500.00 Y500.00 Z150.00 E1500.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X8400.00 Y8400.00 Z250.00 E6000.00 ; set maximum speeds (mm/min)
    M201 X2000.00 Y2000.00 Z100.00 E10000.00 ; set accelerations (mm/s^2)
    M906 X650 Y650 Z650 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X-34 Y-10 Z0 S1 ; set axis minima
    M208 X220 Y220 Z240 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"!xstop" ; configure active-low endstop for low end on X via pin xstop
    M574 Y1 S1 P"!ystop" ; configure active-low endstop for low end on Y via pin ystop
    M574 Z1 S1 P"!zstop" ; configure active-low endstop for low end on Z via pin zstop

    ; Z-Probe
    M558 P9 C"^zprobe.in" H5 F100 T2000 ; disable Z probe but set dive height, probe speed and travel speed
    M557 X20:210 Y20:210 S30 ; define mesh grid
    M950 S0 C"exp.heater3"
    G31 X53 Y6 Z2.898 P25

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4725 C7.06e-8 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M143 H0 S130 ; set temperature limit for heater 0 to 130C
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M308 S1 P"e0temp" Y"thermistor" T100000 B4725 C7.06e-8 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q100 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S70 H-1 ; set fan 1 value. Thermostatic control is turned off
    M950 F2 C"fan2" Q50 ; create fan 2 on pin fan2 and set its frequency
    M106 P2 S150 H-1 ; set fan 2 value. Thermostatic contol is turned off

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C
    M572 D0 S0.3 ; Enable pressure advance

    ; Custom settings are not defined

    ; Miscellaneous
    T0 ; select first tool
    M501

    IMG_20201204_142238.jpg



  • Also using Overture PETG at 240 print temp, 80 degree heat, 40mm/s print speed.


  • Moderator

    Probably printing too fast or too cold or too much fan causing delamination



  • @Tommygunz said in Duet 2 Wifi Perimeter Gaps:

    M92 X100.78 Y100.67 Z397.27 E414.69 ; set steps per mm

    how did you arrive at those numers?

    its likely that you have a lot of backlash in the y direction, that can cause the issues you are seeing.
    grab the nozzle while cold and the motors energiezed. with your fingers see how much you can deflect the nozzle in each direction without using excessive force.
    since you have a bed flinger, do the same for the bed. move it back and forth and see how much play there is.



  • @Veti I got those values from the calibration cube test. Ill check out the free-play of the X and Y axis.



  • @Veti I tightened everything up. No difference at all. Closely watching my printer, it seems like it stops short when printing the first two perimeters hence the large gap. Im not sure what else to try.



  • @Tommygunz said in Duet 2 Wifi Perimeter Gaps:

    I got those values from the calibration cube test. Ill check out the free-play of the X and Y axis.

    thats not a good way to go.
    you dont know if this comes from the play in your system or the actual steps.

    you need to print 2 calibration cubes to verify.

    one normal size one 300% the size.

    you can only adjust of the error is 3 times going to the big cube.


Log in to reply