CNC Spindle enable Pin not working



  • I'm currently trying to a a relay to controle my CNC Spindle. The relay need quite a bit of power, so I would like to use the heated bed Port as the output.
    the problem is, the heated bed output works fine as the PWM pin but simply does nothing when configured as the foreward enable pin.

    ; Tools
    M563 P0 S"Spindel"
    
    ; CNC Mode and Spindle Settings
    M453 C"bedheat+exp.heater3+exp.heater5" T0
    
    

    in this first configuration, it works fine and puts out the PWM frequency

    ; Tools
    M563 P0 S"Spindel"
    
    ; CNC Mode and Spindle Settings
    M453 C"exp.heater3+bedheat+exp.heater5" T0
    

    but when configured like this, it never turns on.

    The Heater3 pin acts the exact same way in both examples, so basically, the foreward (and also backwards) enable pin is not working, and it's a software problem.

    Edit: In addition to that, I can't change the pwm frequency of the heater Output. no matter what it set as the Q value, i alway get 500hz



  • @ruumoo first off, what firmware version are you on?
    Q is only used on RRF 3.2
    You're also missing some things from your M453 command.
    Confirm your firmware version then we can go from there.



  • @jay_s_uk Hi, thanks for the answer, I'm running Version 3.2.
    What am I missing? I took the example code directly from the Duet Gcode website:

    M453 C"exp.heater3+exp.heater4+exp.heater5" Q100 ; spindle PWM on heater 3 pin, on/off on heater 4, reverse/forward on heater 5, PWM frequency 100Hz
    

    Q T and S are optional, but what I am wondering is, why R is not present here, as it's not optional!?



  • Well I found the problem...
    I thought i was on 3.2 but I actually was on 3.1



  • @ruumoo oh well. Glad you got to the bottom of it.
    And it looks as though R is optional then. I'll edit the wiki


Log in to reply