SOLVED BLTouch will not deploy



  • It's entirely possible I am missing something really basic here and if so, I apologize. I have a Duet2 wifi running my CR-10V2 and its working well so when I built an SK-Go corexy this week I chose the same board. I'm in the initial testing and I can't seem to get the BLTouch working at all. It goes through self test on power up...but doesn't respond to the M280 P0 S10 at all. First thought was wiring or a bad BLTouch so I pulled out my new spare with its stock wiring and hooked them up at the board...with the same issue. Ok, then it's my configuration...but I can't find the issue. I have the CR10's config on half the screen and the SKgo on the other half and it looks right.....but clearly I am missing something. Having read in here for a while I know the bigger brains are going to ask for config.g so I'll post it below. Any help you can be would be greatly appreciated....I feel like I've missed something obvious during the build. Firmware version is 3.1.1

    config.g

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.10 on Mon Dec 07 2020 13:07:39 GMT-0500 (Eastern Standard Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"SK-Go2" ; set printer name
    M669 K1 ; select CoreXY mode

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards (X)
    M569 P1 S1 ; physical drive 1 goes forwards (Y)
    M569 P2 S1 ; physical drive 2 goes forwards (Z)
    M569 P3 S0 ; physical drive 3 goes REVERSE (extruder)
    M569 P4 S1 ; physical drive 2 goes forwards (Z on E1)
    M584 X0 Y1 Z2:4 E3 ; two Z motors connected to driver outputs Z and E1
    M671 X-36:363 Y0:0 S3 ; leadscrews at left (connected to Z) and right (connected to E1) of X axis
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X200.00 Y200.00 Z400.00 E393.00 ; set steps per mm
    M566 X600.00 Y600.00 Z18.00 E300.00 ; set JERK maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X750.00 Y750.00 Z40.00 E250.00 ; set accelerations (mm/s^2)
    M906 X700 Y700 Z800 E850 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X330 Y330 Z350 S0 ; set axis maxima

    ; Endstops
    M574 X1 S3 ; configure sensorless endstop for low end on X
    M574 Y1 S3 ; configure sensorless endstop for low end on Y
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z
    M915 X Y R0 F0 ; wws sets up the last main command needed for sensorless homing

    ; Z-Probe
    M307 H3 A-1 C-1 D-1 ; wws added to release heater pin from its default for BLTouch
    M950 S0 C"exp.heater3" ; create servo pin 0 for BLTouch
    M558 P9 C"^zprobe.in" H3 F450 T6000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P25 X-26 Y-5 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 X15:315 Y15:315 S37 ; define mesh grid
    M376 H3 ; wws define fade height

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S110 ; set temperature limit for heater 0 to 110C
    M308 S1 P"e0temp" Y"pt1000" ; wws configure sensor 1 as pt1000 on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit
    M143 H1 S450 ; set temperature limit for heater 1 to 450C

    ; Fans
    M950 F0 C"fan0" Q500 ; PART COOLING create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; HOTEND create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1 T45 ; set fan 1 value. Thermostatic control is turned on

    ; Tools
    M563 P0 S"Hemera" D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined


  • Moderator

    Config looks ok.

    You can remove this M307 H3 A-1 C-1 D-1 as it's not used in RRF3 anymore.

    Can you send M98 P"config.g" to check for any syntax errors?
    Send M122 to confirm you're running 3.1.1

    Double check that the files you're editing are in the system folder and not somewhere else. (it happens)

    IF it's not responding to the servo commands then it's possible there's a bad connection on the wire to the exp.heater3 pin. Check continuity. Recrimp.

    You can also try exp.heater7 pin are an alternative.



  • @Phaedrux I greatly appreciate your help. I was an electronics tech in a former life (a long time ago) so this stuff is usually fun but this one has me stumped. I'm sure I have missed something stupid but damned if I can find it...and I've spent all day on it. Posting the M98 and M122 below.

    My first thought was a wiring issue as they are common with the BLTouch extensions, even new stuff. So I pulled the new extension wire and wired a new (backup) BLTouch to the board using the stock wiring it came with. It acting the same way lowers the chance of a wiring issue (unless I am the wiring issue of course...as you say, it happens). Posting a pic of that as well because two sets of eyes are always better than one. White wire to zprobe in, black to ground same connector, pulled the orange out of the stock connector and dropped it on pin 1, brown pin 2, yellow pin 8. If you don't spot something obvious, I'll try heater7 tomorrow. This is a new board though, have you seen a bad pin before? It's electronics so anything can happen I guess. Again, I do appreciate the help.

    bltouch-skgo.jpg

    m98 p"config.g"
    HTTP is enabled on port 80
    FTP is disabled
    TELNET is disabled
    Warning: Heater 0 appears to be over-powered. If left on at full power, its temperature is predicted to reach 365C

    m122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 3.1.1 running on Duet WiFi 1.02 or later
    Board ID: 08DLM-996RU-N85S4-7JKDL-3S46M-1SBHP
    Used output buffers: 3 of 24 (11 max)
    === RTOS ===
    Static ram: 27980
    Dynamic ram: 93756 of which 68 recycled
    Exception stack ram used: 264
    Never used ram: 9004
    Tasks: NETWORK(ready,384) HEAT(blocked,1224) MAIN(running,1824) IDLE(ready,80)
    Owned mutexes: WiFi(NETWORK)
    === Platform ===
    Last reset 00:02:43 ago, cause: software
    Last software reset at 2020-12-16 22:04, reason: User, spinning module GCodes, available RAM 9036 bytes (slot 1)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task MAIN
    Error status: 0
    MCU temperature: min 26.9, current 30.8, max 31.0
    Supply voltage: min 24.0, current 24.1, max 24.3, under voltage events: 0, over voltage events: 0, power good: yes
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2020-12-16 22:07:38
    Cache data hit count 269538184
    Slowest loop: 8.83ms; fastest: 0.13ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0, resets 0
    === Storage ===
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest read time 3.8ms, write time 2.1ms, max retries 0
    === Move ===
    Hiccups: 0(0), FreeDm: 169, MinFreeDm: 169, MaxWait: 0ms
    Bed compensation in use: none, comp offset 0.000
    === MainDDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0 CDDA state: -1
    === AuxDDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0 CDDA state: -1
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1 -1 -1
    === GCodes ===
    Segments left: 0
    Movement lock held by null
    HTTP is idle in state(s) 0
    Telnet is idle in state(s) 0
    File is idle in state(s) 0
    USB is idle in state(s) 0
    Aux is idle in state(s) 0
    Trigger is idle in state(s) 0
    Queue is idle in state(s) 0
    Daemon is idle in state(s) 0
    Autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 24.44ms; fastest: 0.00ms
    Responder states: HTTP(2) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0), 0 sessions
    HTTP sessions: 1 of 8

    • WiFi -
      Network state is active
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.23
      WiFi MAC address 50:02:91🇩🇪7c:63
      WiFi Vcc 3.37, reset reason Unknown
      WiFi flash size 4194304, free heap 24288
      WiFi IP address 192.168.1.208
      WiFi signal strength -66dBm, reconnections 0, sleep mode modem
      Socket states: 0 0 0 0 0 0 0 0

  • Moderator

    What version of BLTouch is it?

    Trying heater 7 is worth a shot.



  • @Phaedrux Oh my gawd...look at the connector in the pic. It's a three position connector. 2, 4, 6.....Dammit.

    Have not fixed it yet, just saw it......but we both know....



  • @Phaedrux Yeah, that was the problem. I'm not even going to tell you how many times I checked that and counted the pins....

    I'm going to credit you with this one...as you pointed me at the proper pin. Thanks again. Cheers.


  • Moderator

    Glad you figured it out. Simple mistake. Easy fix.


Log in to reply