SOLVED Cannot configure thermistor on Toolboard 1LC

  • Cannot configure thermistor on Toolboard 1LC.

    The board responds to commands:

    M115 B21
    Duet TOOL1LC firmware version 3.2-beta3.2 (2020-11-13)

    But when I try to configure the sensor, I get the following message:

    M308 S1 P"21.temp0" Y"thermistor" T100000 B4725 C7.06e-8
    Warning: Discarded msg src=21 typ=4510 RID=4095 exp 72
    Error: M308: Response timeout: CAN addr 21, req type 6031, RID=72

    In this case, the fan and motor on this board are working.

    The latest firmware on motheboard:

    RepRapFirmware for Duet 3 MB6HC version 3.2-beta4 running on Duet 3 MB6HC v1.01 or later (standalone mode)
    Board ID: 08DJM-956L2-G43S4-6JTDJ-3S46P-9S4AD

    Also I tried another new board at a different address and get exactly the same response.

    Tell me plz where to look?

  • please update to beta 4.1. there were some issues with thermistors on toolboards on earlier builds

  • Thank you! I didn't notice there was an update!
    I will try and write the result.

  • After updating to beta 4.1, everything works fine. Thank you jay_s_uk!

  • The following problems were found:

    1. One of the boards periodically stops working after a reboot. When I change the configuration.g file the motherboard rebooting and the board is not working. The fan is constantly spinning on it. Status is offline. If i turn off and turn on the power, then everything works.

    2. On the same board, it is not possible to change the direction of rotation of the motor. The commands

    M569 P21.0 S0


    M569 P21.0 S1

    work the same way. The stepper always rotates in one direction.

    Perhaps this is due to the fact that he is present in one tool with another?

    M563 P0 S"Extruder-1" D0:1 H1 F0
    M567 P0 E1:1; mixing

    But the second stepper direction is changed by the M569 command.

    Retract and extrude is working. i.e. driver is working fine

  • administrators

    Try putting a G4 delay command in config.g, earlier than the first command in config.g that refers to something on any tool or expansion board.

  • @dc42 Thanks for the advice. I added the G4 P500 and everything works fine now.

    Can you suggest on a question from another topic - how the L parameter works in the M563 command?

Log in to reply