First Layer Way Too High / Extrusion is off?



  • I'm not sure why my first layer is so high up above the bed. I downloaded the plugin for Duet in Cura. It sent the sliced file over to the printer no problem. But the first layer is not close to the bed.

    Below I have posted the first chunk of the print file gcode.

    ;FLAVOR:RepRap
    ;TIME:6861
    ;Filament used: 3.7848m
    ;Layer height: 0.2
    ;MINX:113.127
    ;MINY:90.906
    ;MINZ:0.2
    ;MAXX:179.789
    ;MAXY:129.093
    ;MAXZ:48
    ;Generated with Cura_SteamEngine 4.8.0
    T0
    M190 S50
    M104 S200
    M109 S200
    M82 ;absolute extrusion mode
    M201 X500.00 Y500.00 Z100.00 E5000.00 ;Setup machine max acceleration
    M203 X500.00 Y500.00 Z10.00 E50.00 ;Setup machine max feedrate
    M204 P500.00 R1000.00 T500.00 ;Setup Print/Retract/Travel acceleration
    M205 X8.00 Y8.00 Z0.40 E5.00 ;Setup Jerk
    M220 S100 ;Reset Feedrate
    M221 S100 ;Reset Flowrate

    G28 ;Home

    G92 E0 ;Reset Extruder
    G1 Z2.0 F3000 ;Move Z Axis up
    G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position
    G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
    G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little
    G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line
    G92 E0 ;Reset Extruder
    G1 Z2.0 F3000 ;Move Z Axis up



  • Have you calibrated the probe offset and stored the values with G31?



  • @3dML

    I don’t have a probe yet.



  • Is the nozzle touching the bed if you move to z0 after homing?



  • I homed all. Then used the controls in DWC to move the X and Y axis into position. Then I manually leveled the bed with a sheet of paper.

    After this I went ahead and re-tried the print file again for a simple Benchy. But now it seems like it's not putting out enough material. And the movement of X and Y are wayyy slower than it was with the original board.

    Any thoughts?



  • @tmeryhew said in First Layer Way Too High:

    . But now it seems like it's not putting out enough material.

    check the filament setting in cura. the default is 2.85. its in the machine tab



  • @tmeryhew Remove the lines with M201, M203, M204, M205, M220, M221, they're slowing down your printer. If you can, set the firmware to RepRap in Cura.



  • @Veti

    I’m on a Mac. Where specifically in the Machine tab? Are we talking in the Printers “Machine Settings” area?

    2.85 what? mm/sec? What type of setting is the 2.85 referring to? Thanks!


  • Moderator

    @tmeryhew said in First Layer Way Too High:

    2.85 what? mm/sec? What type of setting is the 2.85 referring to? Thanks!

    2.85mm filament diameter. Cura can sometimes default to that size instead of 1.75 because the Ultimaker printers use the larger filament.

    You can get to the machine tab from the top menu items. Settings > Printer > Manage Printer

    Then choose your printer from the list and click manage printer.

    Then on the machine settings window that pops up you can change the gcode flavor to reprap. Remove the M201, M203, M204, and M205 lines from the start gcode.

    Then in the extruder tab make sure it's set to 1.75 filament.

    Post your full config.g and your homeall.g file as well.
    Also the results of M122 and M98 P"config.g".
    With all of that information we'll have a better idea of what's going on with your printer.



  • @Stephen6309 I went ahead and deleted those and the printer is moving much faster. Thank you



  • @Phaedrux thank you for clarifying, I wasn't sure if we were talking about a speed setting or something else. The setting was in fact at 1.75 mm, so we're good there.

    Below are some screenshots of my printer settings in Cura. However, I have installed the Duet plugin from the Ultimaker website. So far I have been able to send sliced files directly to my printer from Cura. Though, what settings are being incorporated into those G-code files seems ambiguous. Would it be pulling the Start / Stop gcode from this Preferences menu for what I have called "New Style" printer?

    The last screenshot details what appears on my screen. The printer named "Genesis" is through the IP address to the printer. It's what I have named the printer on the Duet side of things. I wanted to be able to differentiate between the different settings areas.

    Screen Shot 2020-12-21 at 12.14.51 PM.png

    Screen Shot 2020-12-21 at 12.15.23 PM.png

    Screen Shot 2020-12-21 at 12.15.55 PM.png

    Screen Shot 2020-12-21 at 12.21.01 PM.png



  • @Phaedrux here is the current "config.g" file

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.10 on Sun Dec 20 2020 20:13:30 GMT-0700 (MST)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Genesis" ; set printer name

    ; Network
    M551 P"REDwagon12!!" ; set password
    M552 P0.0.0.0 S1 ; enable network and acquire dynamic address via DHCP
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S0 ; physical drive 0 goes backwards
    M569 P1 S0 ; physical drive 1 goes backwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S0 ; physical drive 3 goes backwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E420.00 ; set steps per mm
    M566 X600.00 Y600.00 Z60.00 E300.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X9000.00 Y9000.00 Z600.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z120.00 E250.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E900 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X300 Y220 Z300 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"^xstop" ; configure active-high endstop for low end on X via pin ^xstop
    M574 Y1 S1 P"^ystop" ; configure active-high endstop for low end on Y via pin ^ystop
    M574 Z1 S1 P"^zstop" ; configure active-high endstop for low end on Z via pin ^zstop

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; disable Z probe but set dive height, probe speed and travel speed
    M557 X15:285 Y15:205 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T98801 B4185 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S100 ; set temperature limit for heater 0 to 100C
    M308 S1 P"e0temp" Y"thermistor" T98801 B4185 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit
    M143 H1 S250 ; set temperature limit for heater 1 to 250C

    ; Fans
    M950 F0 C"fan0" Q20 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0.9 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q20 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S0 H1 T45 ; set fan 1 value. Thermostatic control is turned on

    ; Tools
    M563 P0 S"HotEnd" D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M501 ; load saved parameters from non-volatile memory
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss
    T0 ; select first tool



  • @Phaedrux here is the "homeall.g"

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.10 on Sun Dec 20 2020 20:13:30 GMT-0700 (MST)
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G1 H1 X-305 Y-225 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X5 Y5 F6000 ; go back a few mm
    G1 H1 X-305 Y-225 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G1 H1 Z-305 F360 ; move Z down stopping at the endstop
    G90 ; absolute positioning
    G92 Z0 ; set Z position to axis minimum (you may want to adjust this)

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning



  • @Phaedrux M122:

    M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 3.1.1 running on Duet Ethernet 1.02 or later
    Board ID: 08DGM-917DA-G4MSJ-6J1F4-3S06K-99PRB
    Used output buffers: 3 of 24 (10 max)
    === RTOS ===
    Static ram: 27980
    Dynamic ram: 93520 of which 24 recycled
    Exception stack ram used: 256
    Never used ram: 9292
    Tasks: NETWORK(ready,368) HEAT(blocked,1224) MAIN(running,1880) IDLE(ready,80)
    Owned mutexes:
    === Platform ===
    Last reset 00:37:09 ago, cause: power up
    Last software reset at 2020-12-20 17:08, reason: User, spinning module GCodes, available RAM 9084 bytes (slot 0)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task MAIN
    Error status: 0
    MCU temperature: min 20.3, current 26.7, max 27.1
    Supply voltage: min 12.1, current 12.2, max 12.3, under voltage events: 0, over voltage events: 0, power good: yes
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2020-12-21 12:26:23
    Cache data hit count 4294967295
    Slowest loop: 147.19ms; fastest: 0.12ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0, resets 0
    === Storage ===
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest read time 2.0ms, write time 0.0ms, max retries 0
    === Move ===
    Hiccups: 0(0), FreeDm: 169, MinFreeDm: 169, MaxWait: 0ms
    Bed compensation in use: none, comp offset 0.000
    === MainDDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0 CDDA state: -1
    === AuxDDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0 CDDA state: -1
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1 -1 -1
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Movement lock held by null
    HTTP is idle in state(s) 0
    Telnet is idle in state(s) 0
    File is idle in state(s) 0
    USB is idle in state(s) 0
    Aux is idle in state(s) 0
    Trigger is idle in state(s) 0
    Queue is idle in state(s) 0
    Daemon is idle in state(s) 0
    Autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 155.28ms; fastest: 0.02ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0), 0 sessions
    HTTP sessions: 1 of 8
    Interface state active, link 100Mbps full duplex



  • @Phaedrux here is that M98 result

    M98 P"config.g"
    HTTP is enabled on port 80
    FTP is disabled
    TELNET is disabled
    Warning: Heater 0 appears to be over-powered. If left on at full power, its temperature is predicted to reach 365C
    Warning: Heater 1 appears to be over-powered. If left on at full power, its temperature is predicted to reach 413C



  • So after deleting M201, M203, M204, M205, M220, M221 from the "Start G-Code" section of the printer settings within Cura, the status quo has changed a little bit.

    I also manually leveled the bed with the bed heater set at 50 C and 200 C for the nozzle.


  • Moderator

    @tmeryhew said in First Layer Way Too High:

    Would it be pulling the Start / Stop gcode from this Preferences menu for what I have called "New Style" printer?

    Yes.

    If you're still printing too high, you need to change either the position of the Z axis endstop switch so that the nozzle is just touching the bed when it stops, or set the actual distance between the nozzle and the bed in the homeall.g file.

    G1 H1 Z-305 F360 ; move Z down stopping at the endstop
    G90 ; absolute positioning
    G92 Z0 ; set Z position to axis minimum (you may want to adjust this)
    

    G92 Z0 could be changed to whatever the gap is between the bed and the nozzle. So if the nozzle is 1mm above the bed when the endstop switch is triggered, you'd use G92 Z1.

    Getting the bed nice and level will be the first thing. Beyond that you would need to use mesh compensation with a Z probe to measure multiple points on the surface of the bed to be able to adjust for a curved bed or other imperfections.



  • @Phaedrux

    So I believe I may have solved the issue of the extruder being too high off the bed, maybe. As soon as I can I will instal a Z probe as it seems that’s the best way to go.

    But check out my pictures below, what would cause my test prints to come out like this?

    65A62A72-0C88-4EF3-BF96-0F3D8D2C65D3.jpeg

    CF8B840B-B629-47FF-B179-78B9FF541820.jpeg

    2F3BBB08-DA96-4970-83B1-89F29C22D93F.jpeg

    8E429766-B12B-4DB1-9EEA-54B59A6E47B2.jpeg

    E7CEE8F6-B059-4D77-A574-7D99647E910B.jpeg

    17337F86-34B8-45D8-A23F-6A08B5BE56BF.jpeg

    1C100655-5DB0-49A9-A156-E305D3A0302E.jpeg

    26E79750-621B-46CE-B4F0-1405FEE33FAF.jpeg

    BBCE98AF-F04E-4883-B2C8-D1810AADEA48.jpeg


  • Moderator

    If that's the bottom layer, likely over extrusion, either from being too close to the bed or extruding too much plastic.

    Maybe give this a read.

    https://duet3d.dozuki.com/Guide/Ender+3+Pro+and+Duet+Maestro+Guide+Part+4:+Calibration/40



  • @Phaedrux

    I added some more pictures to that post. I didn’t think you’d get to a response so quick!

    So are you saying I should go through and calibrate extruder steps per mm? Step 5 on that link you sent me?

    Also, since you seem to have so many answers to my questions, what do I need to do to turn on the part cooling fan (fan 0)? That seems to not be turning on automatically, even though I can go in and turn it on with the G-code commands.



  • Holy crap, I did that test and this sucker pumped out 395mm of filament when I ran the "G1 E100 F60" code in the console....


  • Moderator

    @tmeryhew said in First Layer Way Too High / Extrusion is off?:

    Holy crap, I did that test and this sucker pumped out 395mm of filament when I ran the "G1 E100 F60" code in the console....

    Sounds about right based on those photos.


  • Moderator

    @tmeryhew said in First Layer Way Too High / Extrusion is off?:

    ; Fans
    M950 F0 C"fan0" Q20 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0.9 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q20 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S0 H1 T45 ; set fan 1 value. Thermostatic control is turned on

    For the fan problem, are you use 20Hz works for the fans you have?



  • @Phaedrux I honestly have no idea if 20 hz works for them or not. I was afraid of blowing them up, so I went on the super low end for that.

    I went with the default number on the mA for the motors also. I believe each of my four steppers are rated at 1.5A. And I kept it at the default 800mA that was auto populated by the config tool.

    As for the fans, both are set to 20 hz and the extruder fan comes on no problem so far. But the part cooling fan hasn't come on at all yet.


  • Moderator

    Try 500Hz for the fans. That's the default. Valid values go up beyond 30000, so you'll be fine.

    For the motors, the ideal current is ~60 to 85% of the rated current for the motor.


Log in to reply