Problem with config working with Simplify on the Tool heater



  • Hello guys. I am new to this 3D printing and I'm having trouble with my printer g-code. I'm using simplify 3d. When I make a print file from simplify and send it to the printer using DWC it give me errors 104 invalid tool number, 109 invalid tool number. The bed heater turns on and sets temp as instructed and waits. The tool does not.
    Here is my config file. Not sure what I have wrong. Thank you

    Using firmware 3.1.1 and pi

    ; Configuration file for Duet 3 (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Wed Nov 04 2020 17:27:13 GMT-0600 (Central Standard Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Duet 3" ; set printer name

    ; Drives
    M569 P0.0 S1 ; physical drive 0.0 goes forwards
    M569 P0.2 S1 ; physical drive 0.2 goes forwards
    M569 P0.3 S0 ; physical drive 0.3 goes backwards
    M569 P0.5 S0 ; physical drive 0.5 goes forwards
    M569 P0.4 S0 ; physical drive 0.4 goes backwards
    M569 P0.1 S1 ; physical drive 0.1 goes forwards
    M584 X0.0 Y0.2 Z0.3 E0.5:0.4:0.1 ; set drive mapping
    M350 X16 Y16 Z16 E16:16:16 I1 ; configure microstepping with interpolation
    M92 X64.05 Y64.05 Z800.00 E400.00:800.00:65.00 ; set steps per mm
    M566 X300.00 Y300.00 Z24.00 E300.00:24.00:300.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z300.00 E1200.00:300.00:18000.00 ; set maximum speeds (mm/min)
    M201 X700.00 Y700.00 Z100.00 E250.00:100.00:700.00 ; set accelerations (mm/s^2)
    M906 X2800 Y2800 Z2800 E800:2800:2800 I50 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X625 Y711 Z515 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"io1.in+io2.in" ; configure active-high endstop for low end on X via pin io1.in
    M574 Y1 S1 P"io3.in" ; configure active-high endstop for low end on Y via pin io2.in
    M574 Z1 S1 P"io4.in+io5.in" ; configure active-high endstop for low end on Z via pin io4.in

    ; Z-Probe
    M558 P8 C"!^io7.in" H5 F520 T7200 ; set Z probe type to switch and the dive height + speeds
    G31 P500 X2.8 Y22.8 Z4 ; set Z probe trigger value, offset and trigger height
    M557 X10:580 Y10:700 S40 ; define mesh grid

    ; Heaters
    M308 S0 P"temp0" Y"thermistor" T94400 B4055 ; configure sensor 0 as thermistor on pin temp0
    M950 H0 C"out0" T0 ; create bed heater output on out0 and map it to sensor 0
    M307 H0 B1 S1.5 ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M308 S1 P"temp1" Y"thermistor" T500000 B4723 C1.19622e-7 ; configure sensor 1 as thermistor on pin temp1
    M950 H1 C"out1" T1 ; create nozzle heater output on out1 and map it to sensor 1
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"out4" Q500 ; create fan 0 on pin out4 and set its frequency
    M106 P0 S1 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"out5" Q500 ; create fan 1 on pin out5 and set its frequency
    M106 P1 S1 H-1 ; set fan 1 value. Thermostatic control is turned off
    M950 F2 C"out6" Q500 ; create fan 2 on pin out6 and set its frequency
    M106 P2 S1 H-1 ; set fan 2 value. Thermostatic control is turned off
    M950 F3 C"out7" Q500 ; create fan 3 on pin out7 and set its frequency
    M106 P3 S1 H-1 ; set fan 3 value. Thermostatic control is turned off
    M950 F4 C"out8" Q500 ; create fan 4 on pin out8 and set its frequency
    M106 P4 S1 H-1 ; set fan 4 value. Thermostatic control is turned off
    M950 F5 C"out9" Q500 ; create fan 5 on pin out9 and set its frequency
    M106 P5 S1 H-1 ; set fan 5 value. Thermostatic control is turned off
    M950 F6 C"out3" Q500 ; create fan 6 on pin out3 and set its frequency
    M106 P6 S1 H1 T50 ; set fan 6 value. Thermostatic control is turned on

    ; Tools
    M563 P0 S"Hot End" D0 H1 F6 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings

    M584 X0:1 Y2 Z3:4 E5 ; assign stepper motor channels

    ; Miscellaneous
    M575 P1 S1 B57600 ; enable support for PanelDue
    M501 ; load saved parameters from non-volatile memory
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss
    M591 D0 P7 C" io8.in" S1 R40:120 L6.325 E7.0 ; Duet3D plus-generating sensor for extruder drive 0 is connected to pin io7.in endstop input, enabled, sensitivity 6.rev, 40% to 120% tolerance, 7 mm detection length

    M591 D0 ; display filament sensor parameters for extruder drive 0
    T0 ; select first tool



  • Hi,

    Post the first part of the S3D file that includes the first tool reference.

    Frederick



  • This is showing T1 but in the software I have it set a T0 not sure what's up with that but maybe this is the issue?

    On my FFF settings page in advanced under Extruder 1 Toolhead
    overview toolhead index is Tool 0

    Thank you

    G90
    M82
    M106 S255
    M140 S50
    M190 S50
    M104 S200 T1
    M109 S200 T1
    G28 ; home all axes
    ; process Process1
    ; layer 1, Z = 0.200
    T0
    G92 E0.0000
    G1 E-5.0000 F1800
    ; feature skirt
    ; tool H0.200 W0.400
    G1 Z0.200 F1002
    G1 X254.582 Y264.303 F4800
    G1 E0.0000 F1800
    G92 E0.0000
    G1 X256.222 Y262.811 E0.0737 F1800
    G1 X256.803 Y262.424 E0.0970
    G1 X258.710 Y261.536 E0.1669



  • I’m guessing the T1 is the port the sensor is on after thinking about it.



  • @Work-Horse-XL said in Problem with config working with Simplify on the Tool heater:

    I’m guessing the T1 is the port the sensor is on after thinking about it.

    No, it's the tool number which likely should be T0.

    Frederick



  • I’m not sure why it’s choosing T1 when I have it Tool 0 in the settings. Have you ever seen that?
    Thank you



  • @Work-Horse-XL said in Problem with config working with Simplify on the Tool heater:

    I'm using simplify 3d.

    That's your problem right there, using a dead software 😈

    Are you at least using latest 4.1.2 as previous had a lot more issues with dual head?

    M104 S200 T1
    M109 S200 T1

    Do you have dual extruder configured? Check how you configured it. Looks like you set main extruder to be T1 but then set T0 to be used from process1. Did you do it manually or you went through dual extrusion wizard?

    What's in your start code?

    ; process Process1
    ; layer 1, Z = 0.200
    T0

    I see that for process1 it selects T0 but only after the process started, how many processes you have here?

    p.s. strongly suggest you check out ideaMaker, it is the slicer that looks like simplify3d more than any other slicer but is much better and more powerful than simplify3d. took me a very short time to get accustomed to it after years of using s3d



  • The problem is not S3D.

    I have used S3D since early on and it works fine.

    If it is including a reference to T1 it is because there is something wrong in the S3D settings put in place by the user.

    Frederick



  • @arhi it’s just a single extruder. Not sure on the process. I’m just getting stared. It seems to be working fine for me if I can just get this part fixed. It’s the newest version of s3d

    Thank you



  • @fcwilt I’m sure that’s the issue but I can seem to find the problem. I might try to start over with a clean install.

    Thank you



  • @Work-Horse-XL send the factory file up there on the forum as they asked, that's fastest way to see what you messed up. S3D will not use T1 unless you configured dual extruder machine, you might go through the configuration wizard from scratch



  • You have configured simplify3D to use T1 for the hotend rather than T0. And your config.g hasn’t been configured to recognize tool 1



  • I used the wizard to do a new profile and it fixed the issues it looks like. I need to test it but the g code is coming out correctly now.

    Thank you guys.



  • @Work-Horse-XL said in Problem with config working with Simplify on the Tool heater:

    M584

    as a side note observe the order
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M584_Set_drive_mapping

    M584 must come earlier in config.g than any M350 and M906 commands. If it creates new axes, it must also be earlier than any M92, M201, M203, M208, M350, M566, M574, M667 and M669 commands.


Log in to reply