Duet Wifi possibly failed

  • I was on firmware 2.0.5 and started having a loss of connectivity through network and Paneldue would lose connection also. This wasn't that big of an issue except this weekend I needed to do a couple of multicolor prints with filament changes and on the first one it was locked up when hitting the pause.

    So, I figured I needed to finally go to v3 then v3.2 The update to v3.0 was fine, M115 reported the correct firmware so I uploaded v3.2 and lost all connectivity. No wiring changes were made during any of this, it was installed normally and I had just finished that failed print 30 minutes prior.

    I've tried a full erase/reset, commented out M552 in config.g, but am stuck with the 5v, 3.3v, DIAG, and USB leds lit and no connection via wifi or USB. I've tried multiple USB cables and ports but am fairly certain it's just dead.

    I bought it in Feb 2017 which is almost 4 years of excellent printing running fairly low current steppers and not printing that often, maybe a few hours/week average except for doing faceshields last year for hospitals and a few other times.

    Any other suggestions to try to recover it?

    Also, was it just at its EOL? I expected it to last a lot longer than 4 years.

    What's next, a Maestro or go to a SKR Mini E3 maybe? I'm not sure I want/need to shell out the money for another Duet. I do have a Paneldue, but it's the second of those as my first died after about a year.

  • have you read https://duet3d.dozuki.com/Wiki/What_to_do_if_your_Duet_won't_respond ?

    What's next, a Maestro or go to a SKR Mini E3 maybe?

    next is duet 3 or duet mini 5+

  • Moderator

    I think when you updated to 3.2 the wifi server firmware didn't get flashed correctly. At that point you might have been able to recover by sending M997 S1 from the paneldue to manually force it to try flashing the wifi again.

    So give that a shot and see if you're able to restart the wifi module after it flashes.

  • @Phaedrux
    Here's where I am:
    plugged into 5v power supply or computer, 5v lit, 3.3v lit, USB lit, and DIAG lit. The reset button is not stuck, appears to operate properly. The wifi module has a small blue LED lit. This is with or without the SD card installed.

    With my Paneldue plugged in, it loads the main screen but says Connecting in top right. I can go to the Console and enter M997 S1 but get no response.

    The LEDs that are lit never change no matter what I do.

    I'm fairly frustrated that it has died in under 4 years. Had I been running high currents or printing 24/7 or had some wiring issues, I might understand it, but for a (relative to others) expensive board to fail this soon to me is surprising and disappointing.

  • Moderator

    I get that you are upset, but I don't think it has died. From your description you've lost network connectivity and then wiped the firmware.

    You'll need the SD card in the Duet for the config to be loaded and for the firmware files to be present. To use the Paneldue it needs to be enabled first, hence why it's saying connecting. M997 S1 won't do anything if the SD card isn't present and the PanelDue isn't connected.

    So first steps are to connect the Duet via USB to your PC and see it it shows up in device manager as a Bossa port. Then use Bossa to write the firmware 3.2 bin.

    Then you should be able to connect to the board from YAT and see if the firmware responds to M115 with the currently installed firmware version.

    At this point you should be able to send the M997 S1 command to re-flash the wifi firmware.

    Next is to prepare your SD card. Make sure you have the firmware files for 3.2 present in the /sys folder if they aren't already. and the DWC files in the /www folder.

    In your config.g you'll need to add M575 P1 B57600 S1 for the paneldue to connect. and you should then be up and running.

    If in doubt, go through the link Veti provided. https://duet3d.dozuki.com/Wiki/What_to_do_if_your_Duet_won't_respond

  • Wow.

    I had tried 2 different 'known good' cables on both my gaming desktop and work laptop and never got the port to recognize, no Windows tone, nothing, but as a last resort I grabbed another USB cable here at work and just got the port to recognize.


    The rest should be easy...

    But seriously, always keep trying. (I had been working on this since Saturday trying all the troubleshooting steps but if you can't get the port to appear, it's hard)

  • Moderator

    Always relevant:

    alt text

  • @Phaedrux

    Thank you so much Phaedrux. You are a legend in my book. I was pretty frustrated but wanted to give another last ditch effort before ordering a Maestro (which would have been a step down since I do use sensorless homing) and your post helped motivate me.


  • Moderator

    That's a good sign. It's pretty hard to kill a duet with a firmware update.

Log in to reply