Upgrading from Anet board with Auto leveling



  • Hello everyone,

    I recently had my stock Anet A8 board die and thinking about upgrading to the Duet WiFi.
    My question is will my auto level sensor work with the Duet?

    Sensor - https://www.ia.omron.com/product/item/2202/

    more info on how it is wired up (plugs into stock z endstop connector) - https://www.thingiverse.com/thing:2241424

    below is some of the marlin config info i use for this switch

    [[language]]
    #define Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN
    #define FIX_MOUNTED_PROBE
    #define X_PROBE_OFFSET_FROM_EXTRUDER 0   // X offset: -left  +right  [of the nozzle]
    #define Y_PROBE_OFFSET_FROM_EXTRUDER 53   // Y offset: -front +behind [the nozzle]
    #define Z_PROBE_OFFSET_FROM_EXTRUDER 0   // Z offset: -below +above  [the nozzle]
    // X and Y axis travel speed (mm/m) between probes
    #define XY_PROBE_SPEED 10000
    // Speed for the first approach when double-probing (with PROBE_DOUBLE_TOUCH)
    #define Z_PROBE_SPEED_FAST HOMING_FEEDRATE_Z
    // Speed for the "accurate" probe of each point
    #define Z_PROBE_SPEED_SLOW (Z_PROBE_SPEED_FAST / 2)
    // Use double touch for probing
    #define PROBE_DOUBLE_TOUCH
    #define Z_CLEARANCE_DEPLOY_PROBE   10 // Z Clearance for Deploy/Stow
    #define Z_CLEARANCE_BETWEEN_PROBES  5 // Z Clearance between probe points
    / For Inverting Stepper Enable Pins (Active Low) use 0, Non Inverting (Active High) use 1
    // :{ 0:'Low', 1:'High' }
    #define X_ENABLE_ON 0
    #define Y_ENABLE_ON 0
    #define Z_ENABLE_ON 0
    #define E_ENABLE_ON 0 // For all extruders
    // Disables axis stepper immediately when it's not being used.
    // WARNING: When motors turn off there is a chance of losing position accuracy!
    #define DISABLE_X false
    #define DISABLE_Y false
    #define DISABLE_Z false
    
    

  • administrators

    Yes, you can use that, but you will have to feed it 5V from the expansion connector because the endstop connector only provides 3.3V.



  • So could I use the 5v from the panel connector?
    Then use the zprobe signal and ground pins?
    Or would I connect the probe to the z endstop connector like I have it on the Anet board?
    https://imgur.com/gallery/izfo9



  • https://ibb.co/n7UAuv

    To the 5v on the right.



  • Where would I plug in my sensor? The E0 stop, z stop or zprobe?

    FYI I just ordered the duet wifi!!


  • administrators

    The outer 2 pins of the E0 endstop would be best.



  • Thanks! I'm sure I'll have more questions once my board arrives!



  • Ok so I just received my duet wifi!! I have setup the wifi and am able to access the web interface. I was going through the RepRapFirmware Configuration Tool and had some questions on translating my marlin settings.
    I have provided links below that shows comparisons between marlin and the config tool.

    http://imgur.com/XmuD66n config tool motor settings
    http://imgur.com/mN9kzqM marlin motor settings

    http://imgur.com/lA1gy2o config tool endstop settings
    http://imgur.com/2wqDuZv marlin endstop settings
    http://imgur.com/9gsdyXs marlin z probe settings



  • I think I have everything setup. the only thing I'm having issues with is the zprobe.
    I have the zprobe wired up as dc42 suggested.
    the gnd and signal pins from my sensor are wired to E0 endstop connections E0 stop and GND.
    I have the 5v for my sensor connected to the 5V expansion connector pin 1.
    when trying to run G29 I keep getting this error

    Error: No valid grid defined for G29 bed probing

    Below are some of my config settings for the z probe and my bed.g file

    thanks for all of the help.

    [[language]]
    ; General preferences
    M111 S0                                         ; Debugging off
    G21                                             ; Work in millimetres
    G90                                             ; Send absolute coordinates...
    M83                                             ; ...but relative extruder moves
    M555 P2                                         ; Set firmware compatibility to look like Marlin
    M208 X-14 Y0 Z0 S1                                 ; Set axis minimum set so x0 y0 is at corner of bed x=-14
    M208 X220 Y220 Z240 S0                            ; Set axis maximum
    
    ; ????????? not sure about zprobe configuration 
    
    ; Endstops
    M574 X1 Y1 Z0 S0                                 ; Define active low and unused microswitches
    
    ;zprobe section ??????????
    M558 P4 X0 Y0 Z1 H5 I1 F120 T6000                     ; Set Z probe type to switch, the axes for which it is used and the probe + travel speeds
    G31 X0 Y53 Z2                                     ; Set Z probe offset and trigger height see end of this file.
    
    

    bed.g file

    [[language]]
    M561						;Clear any bed transform
    G28							;Home all axes
    M557 X10:210 Y53:210 S40 	;Define mesh grid 
    G29 S0						;Probe the bed and save height map to file
    M374 						; Save calibration data. Default is sys/heightmap.csv
    
    


  • I think i found my problem. Let me know if I'm right.

    When setting up the grid with M557 I should subtract the z probe y offset (53) from my current numbers.
    I believe it should look like this: M557 X10:210 Y0:157 S40


  • administrators

    You don't need to subtract the Z probe offset, however any points that are not reachable by the Z probe will not be probed.

    My guess is that you had a typo in your M557 command.



  • Thanks for the help. I have everything working now!
    just as a reference below are my zprobe and bed.g configs

    Z-Probe

    [[language]]
    M558 P4 X0 Y0 Z1 H2 I1 F120 T6000 
    G31 P1000 X0 Y53 Z6.582
    
    

    bed.g file

    [[language]]
    M561				
    G28				
    G90 	
    M557 X10:210 Y0:210 S40
    G29 S0				
    M374 
    
    

  • administrators

    You don't need the M374 command, the G29 S0 command will save to heightmap.csv anyway.


Log in to reply