Unusable SBC Image file (https://pkg.duet3d.com/DuetPi.zip)



  • As per the info in https://duet3d.dozuki.com/Wiki/SBC_Setup_for_Duet_3.
    downloading & writing the 'full' version (https://pkg.duet3d.com/DuetPi.zip) results in a non-booting system, the lite version works fine, but I wanted to try out some different webcams & its a tad easier with a working desktop.

    I've tried downloading\unpacking a number of times on different computers, all give the same result.


  • administrators

    I've just downloaded and flashed the full image to a spare SD card, connected a Pi with that SD card to one of my Duets, and I haven't got any problems. Is it possible that your SD card is too small (<= 4GB) or damaged? Did you flash it with the official RaspPi Imager?



  • I've used 8,16,32 & 64 GB Sandisk Ultra cards, & I've used Balena Etcher each time, also I've used Official Octopi, Raspi images lite & full etc. with no issues, its just this 'full' version.

    Looking at the card post a 'successful' write, it appears that there's nothing written to boot partition, i.e. it get created ok, but nothing there...



  • @Dr_Ju_Ju said in Unusable SBC Image file (https://pkg.duet3d.com/DuetPi.zip):

    Balena Etcher

    i know a lot people say to use this over win32diskimager but balena is the only thing I've ever had problems with.

    currently the official raspberry pi imager is the my favourite, maybe worth trying, but admittedly odd only the full image fails. try a fresh download and compare the md5 sums?



  • I also tried Win32DiskImager & the Raspberry pi imager (which looks to be a re-badged Balena clone with a better image selection front end) & writing the extracted *.img file (always using 7Zip to un-pack with multiple downloads & MD5 checked), I ended up with a non booting system.....

    BUT, on a whim, I tried writing the raw zip file directly to the sd card & surprisingly, the system booted !! & I was able to login, so methinks that the zip has some 'funnies'....

    Now to try & remove the pre-installed crap like guggle chrum etc....



  • writing the raw zip file directly to the sd card

    the only way that would work is if the zip file somehow was not an zip file but decompressed to the same filename.

    if you wrote a compressed image to the the card, the card would not have a valid filesystem let alone a valid partition table. (the raspbery pi imager does automatically decompress .zip files so that would work, but it wouldn't be the raw zip file written to the card in that scenario)

    edit: https://pkg.duet3d.com/DuetPi.zip fresh dowload, extracted to 2021-01-05-DuetPi.img and boots fine both on a Pi and in Qemu



  • My bad I should have made it clearer, the software (Balena, Pi imager) didn't write the zip directly to the sd card, but 'internally' unpacked\extracted the zipped data before writing anything to the card....



  • then the decompressing would have had to be the issue, however I also used 7zip (v19.00 x64) when extracting the image to test.


Log in to reply