[SOLVED] Can't connect to Duet 3 mini 5+ after firmware upgrade



  • Hi,

    So it seems like my problems never end 😉

    I was working on configuring a CoreXZ printer today and I noticed some weird behavior when moving on the Z axis (seems as if movement is multiplied by 10).

    I thought it might be just the firmware, so I tried updating it. I downloaded the package (zip file with all Duet2 and 3 firmwares) and uploaded it via DWC.

    I was asked if I want to update, I clicked yes, and then, the board stopped and never came back up. The Status led is flashing red at about 1Hz.

    I tried replacing the files on the SD card - nothing.
    I tried connecting to the board with YAT and Bossa - not possible. They both immediately complain that they can't connect.

    I tried switching over to Mac and trying either screen or SerialTools - I can connect, but I am not getting any responses from the board. I tried Bossa for Mac - I can connect to the board, get info on the chip, but when I try to upload the uf2 file - I get an error telling me memory is exceeded) - and I can't connect the boot to flash option.

    When I connect the board to Windows - I can see for a moment - DuetBOOT appears and I have three files there (current.uf2, .html file that redirects to the Duet web site and info_uf2.txt).

    It appears in the device manager just fine for about 20 seconds and then disappears.

    Seems to be the same on the Mac. I tried copying the files over from DuetBOOT, but can't - I get a disconnection message almost immediately.

    Any tips/hints on how to bring the board back from the dead?





  • Man I'm blind... That did it! Thanks 😉


Log in to reply