New tool too close to Z axis limit. Aborting tool change



  • After upgrading my Duet2 Wifi firmware to 3.2, I keep getting T0
    Error: New tool too close to Z axis limit. Aborting tool change

    I am using a delta



  • @ken340 post your config please



  • ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Tue Feb 26 2019 21:31:01 GMT+0000 (Greenwich Mean Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Delta Settings
    M665 L430.000 R227.000 H421.60 B185.0 X0.0 Y0.0 Z0.0 ; Set delta radius, diagonal rod length, printable radius and homed height

    M666 X0 Y0 Z0 A0.00 B0.00 ; Put your endstop adjustments here, or let auto calibration find them

    ; Network
    M550 P"Anycubic Predator" ; Set machine name
    M551 P"" ; Set password
    M552 S1 ; Enable network and acquire dynamic address via DHCP
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Enable FTP S1 = enable S0 = disable
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes backward
    M584 X0 Y1 Z2 E3 ; set drive mapping

    ; Stepper Configuration
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    ;M92 X80 Y80 Z80.00 E423.5 ; Set steps per mm 1.8
    M92 X160 Y160 Z160 E423.5
    M906 X2400.00 Y2400.00 Z2400.00 E1000.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Normal Speed
    M566 X1200 Y1200 Z1200 E3600 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z18000.00 E10000 ; Set maximum speeds (mm/min)
    M201 X3500.00 Y3500.00 Z3500.00 E3500.00 ; Set accelerations (mm/s^2)

    ; Retraction
    ;M207 S2.5 F7000 R0.1 T2500 Z0.5 ; Firmware retraction

    ; Axis Limits
    M208 Z0 S1 ; Set minimum Z

    ; Endstops
    M574 X2 S1 P"xstop" ; configure active-high endstop for high end on X via pin xstop
    M574 Y2 S1 P"ystop" ; configure active-high endstop for high end on Y via pin ystop
    M574 Z2 S1 P"zstop" ; configure active-high endstop for high end on Z via pin zstop

    ; Z-Probe
    M558 P8 F500 H4 R0.4 C"zprobe.in+zprobe.mod" ; Set Z probe type to switch and the dive height + speeds
    G31 P100 X0 Y0 Z-0.131 ; Z16.927 Set Z probe trigger value, offset and trigger height
    M557 R120 S12 ; Define mesh grid S25
    G29 S1 ; Load the heightmap

    ; Bed Heater
    M308 S0 A"Ultrabase Pro" P"bedtemp" Y"thermistor" T100000 B4300 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M950 H0 C"bedheat" Q100 T0 ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 A137.8 C533.3 D1.5 V24.3 B0 ; Disable bang-bang mode for the bed heater and set PWM limit
    M143 H0 S100
    M140 H0 P0 ; Create bed Heater and heater limit to 120C

    ; Extruder Heater
    ;M308 S1 A"E3D V5 Clone" P"e0temp" Y"thermistor" T100000 B4300 C0 R4700 ; PT100 Temperature Sensor ;C0 B4300
    M308 S1 A"E3D V6 Clone" P"spi.cs1" Y"rtd-max31865"
    M950 H1 C"e0heat" T1
    M307 H1 A679.6 C215.6 D4.4 S1.00 V24.2 B0 ; create nozzle heater output on e0heat and map it to sensor 1

    M305 P1 X200 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S240 ; Set temperature limit for heater 1 to 240C

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 I0 F500 H-1 L0.5 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"!fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S0 I0 H1 T45 ; set fan 1 value. Thermostatic control is turned on

    ;Fans
    ;M950 F0 C"!fan0" Q500 ;HOTEND FAN create fan 1 on pin fan1 and set its frequency
    ;M106 C"HotendFA" P1 I0 H1 T45 ; set fan 1 value. Thermostatic control is turned on

    ;M950 F1 C"fan0+exp.pb6" Q500 ;CPAP create fan 0 on pin fan0 and set its frequency !fan2+exp.pb6 with RPM readout on PB6
    ;M106 C"CPAP" P0 S0 H-1 L0.5 ; set fan 0 value. Thermostatic control is turned off L0.3 X1

    ;Fans
    ;M950 F1 C"fan0" Q500 ;HOTEND FAN create fan 0 on pin fan0 and set its frequency
    ;M106 C"throat" P1 I0 H1 T45 ;set fan 1 value. Thermostatic control is turned on

    ;M950 F0 C"fan1+exp.pb6" Q500 ;CPAP create fan 1 on pin fan1 and set its frequency !fan1+exp.pb6 with RPM readout on PB6
    ;M106 C"Hotend Fan" P0 S0 H-1 L0.5 ;X0.5 ; set fan 0 value. Thermostatic control is turned off L0.3 X1

    ; Tools
    M563 P0 D0 H1 F0 ; tool 0 uses extruder 0, heater 1 (and fan 0)
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured
    M591 D0 P2 C"e1_stop" S1 ; activate Filament Sensor
    M404 N1.75 ; Set for print monitor
    M575 P1 B57600 S1 ; Paneldue baud rate

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory



  • @jay_s_uk

    ; config-override.g file generated in response to M500 at 2021-02-09 00:16
    ; This is a system-generated file - do not edit
    ; Delta parameters
    M665 L424.566:424.566:424.566 R219.579 H421.523 B185.0 X0.234 Y0.361 Z0.000
    M666 X1.215 Y-1.023 Z-1.023 A-0.65 B0.24 ;z-1.023
    ; Heater model parameters
    M307 H0 R0.258 C533.300:533.300 D1.50 S1.00 V24.3 B0
    M307 H1 R3.152 C215.600:215.600 D4.40 S1.00 V24.2 B0
    ; Workplace coordinates
    G10 L2 P1 X0.00 Y0.00 Z0.00
    G10 L2 P2 X0.00 Y0.00 Z0.00
    G10 L2 P3 X0.00 Y0.00 Z0.00
    G10 L2 P4 X0.00 Y0.00 Z0.00
    G10 L2 P5 X0.00 Y0.00 Z0.00
    G10 L2 P6 X0.00 Y0.00 Z0.00
    G10 L2 P7 X0.00 Y0.00 Z0.00
    G10 L2 P8 X0.00 Y0.00 Z0.00
    G10 L2 P9 X0.00 Y0.00 Z0.00
    M486 S-1



  • nothing jumps out at me as being incorrect with that config to cause the error you're seeing.
    I take it you have changed the stepper motors to 0.9 degree ones? I hope you have some sort of cooling on the board for the current settings you have.

    @ken340 said in New tool too close to Z axis limit. Aborting tool change:

    M106 P0 S0 I0 F500 H-1 L0.5 ; set fan 0 value. Thermostatic control is turned off

    F and I aren't valid here.

    @ken340 said in New tool too close to Z axis limit. Aborting tool change:

    G29 S1 ; Load the heightmap

    There no point loading the height map here as it gets unloaded when G28 is ran.

    Can you check the output of M98 P"config.g" and provide the start section of a gcode file? Do you also use start.g?



  • Look at your homedelta.g file

    There are some lines that will put the head down a bit after homing. Still using H1 there will make it fail. Use the H2 to move the motors down a bit.



  • @jay_s_uk I actually bought the same 0.9 stepper as in your guide.

    how should I configure M106?

    I somehow overcome this by manually home and set T0 temp to 50 then turn off.



  • @ken340
    This would be typical for your fan settings

    M106 P0 S0 H-1                                 ; set fan 0 value. Thermostatic control is turned off
    M106 P1 S1 H1 T45                            ; set fan 1 value. Thermostatic control is turned on
    

Log in to reply