Firmware bundle 3.2.2 released


  • administrators

    I am please to announce the release of firmware bundle 3.2.2 for Duets. This fixes bugs in firmware 3.2.

    Users of Duet with attached Raspberry Pi should upgrade via the package server as usual.

    Others users can find the files at https://github.com/Duet3D/RepRapFirmware/releases/tag/3.2.2. If you are already running release 3.0 or later then it should be sufficient to upload Duet2and3Firmware.zip via the System page of Duet Web Control.

    RRF release notes: https://github.com/Duet3D/RepRapFirmware/blob/v3-dev/WHATS_NEW_RRF3.md
    DWC release notes: https://github.com/Duet3D/DuetWebControl/blob/master/WHATS_NEW.md
    DSF release notes: https://github.com/Duet3D/DuetSoftwareFramework/blob/master/WHATS_NEW.md



  • I think this release just broke Wifi on my Duet2 Wifi...

    I upgraded by uploaded the big zip via DWC 3.2.0 to my Duet2 Wifi 1.04 with RRF 3.2.0.
    Upload went fine - DWC asked if I want to install, I clicked yes.
    Printer seemed to do stuff - and my PanelDue came back alive as expected. But no more DWC connection.

    PanelDue Console connects fine to the board, but no activity on the Wifi: no ping or HTTP access possible.
    Trying an M587 via PanelDue says:

    Failed to retrieve network list: another SPI transfer is pending

    Trying M122 via PanelDue says not much, except that it is running RRF3.2.2 now (as expected).

    I'll attempt a downgrade via USB now...

    edit:
    Yes, downgrade to 3.2.0 via SD-card + M997 + M997 S1 brought it back to live.



  • @resam that already happend to me from 3.1 to 3.2 on multiple occasions and I always needed to install the wifi server afterwards to bring wifi back to live



  • @taconite indeed! Thanks! I'm not on RRF 3.2.2 with working Wifi.
    I don't remember having this issue in the past.

    @dc42 Thats a weird bug though because the WifiFirmware did not change at all - so why does RRF fail here after the upgrade? I power-cycled everything a few times. Is this a bug which corrupts data in the eeprom?



  • @resam said in Firmware bundle 3.2.2 released:

    I think this release just broke Wifi on my Duet2 Wifi...

    Well it's not an inherent problem with the 3.2.2.

    I just upgraded as usual from 3.1.1 and it all went fine.

    No problems re-connecting.

    Is your WiFi server up to date?

    Frederick



  • Here the same problem after update from 3.2 to 3.2.2 Wifi is not working anymore i used the Duet2and3Firmware-3.2.2.zip file



  • Worked for me on two printers with Duet 2 Wifi. One was update from 3.1.1 and the other from 3.2. Updated and restarted and both printers appeared on the net.


  • administrators

    For anyone having issues with WiFi after upgrading, I suggest you connect via USB and then send M997 S1 to reinstall the WiFi server.

    If you are already running release 3.2.0 then instead of uploading the full zip file you could install just the new firmware binary and DWC. The WiFi server and IAP files have not changed since release 3.2.



  • thank you !now it's working



  • Have a DuetWifi (v3.1.1)

    Downloaded RepRapFirmware 3.2.2 upgrade and installed, as per notes, Duet2and3Firmware-3.2.2.zip through the System page of Duet Web Control. Once uploaded I was asked if I wanted to apply to upgrade and I said Yes. Web page cycled continuously looking like it was upgrading, left it for 2 mins. Checked the Duetpanel display and it said "ERROR: Operation 3 failed after 5 retries" . I clicked the X xlose gadget and the printer said 'Firmware uploaded in the top right corner of the screen. Checked the web interface and it was still cycling as though it was upgrading. Power cycled the printer and it's not very happy. Stuck saying 'Initializing' to right.

    So I followed Fallback procedure #3 and uploaded 'Duet2CombinedFirmware.bin' via Basso, once the printer was reset it seemed to be OK. So I retried the upgrade via the web interface and got the same issue.

    Not sure what I'm doing wrong


  • Moderator

    @Foden I would try re-downloading the zip file again.

    https://github.com/Duet3D/RepRapFirmware/releases/download/3.2.2/Duet2and3Firmware-3.2.2.zip

    Can you post the results of M122?



  • Hi Phaedrux

    Hope you are safe & well. Have downloaded the file again, 3rd time, and about to retry the update again

    Current M122 is
    M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 3.2.2 running on Duet WiFi 1.02 or later
    Board ID: 08DDM-9FAM2-LW4S8-6J9FD-3S86R-9MYVX
    Used output buffers: 3 of 24 (24 max)
    === RTOS ===
    Static ram: 23460
    Dynamic ram: 73376 of which 76 recycled
    Never used RAM 15168, free system stack 115 words
    Tasks: NETWORK(ready,183) HEAT(blocked,308) MAIN(running,449) IDLE(ready,20)
    Owned mutexes: WiFi(NETWORK)
    === Platform ===
    Last reset 00:43:42 ago, cause: power up
    Last software reset at 2021-01-30 13:14, reason: User, GCodes spinning, available RAM 15168, slot 1
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0041f000 BFAR 0xe000ed38 SP 0x00000000 Task MAIN Freestk 0 n/a
    Error status: 0x04
    Aux0 errors 0,0,0
    MCU temperature: min 25.3, current 30.2, max 31.9
    Supply voltage: min 24.4, current 24.6, max 24.8, under voltage events: 0, over voltage events: 0, power good: yes
    Driver 0: position 18752, standstill, SG min/max 0/88
    Driver 1: position -1152, standstill, SG min/max 0/60
    Driver 2: position 2937, standstill, SG min/max 0/473
    Driver 3: position 0, standstill, SG min/max not available
    Driver 4: position 0, standstill, SG min/max not available
    Driver 5: position 0
    Driver 6: position 0
    Driver 7: position 0
    Driver 8: position 0
    Driver 9: position 0
    Driver 10: position 0
    Driver 11: position 0
    Date/time: 2021-02-16 14:01:23
    Cache data hit count 3203037067
    Slowest loop: 42.50ms; fastest: 0.21ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0, resets 0
    === Storage ===
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest read time 40.4ms, write time 0.0ms, max retries 0
    === Move ===
    DMs created 83, maxWait 80640ms, bed compensation in use: none, comp offset 0.000
    === MainDDARing ===
    Scheduled moves 10, completed moves 10, hiccups 0, stepErrors 0, LaErrors 0, Underruns [0, 0, 0], CDDA state -1
    === AuxDDARing ===
    Scheduled moves 0, completed moves 0, hiccups 0, stepErrors 0, LaErrors 0, Underruns [0, 0, 0], CDDA state -1
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1 -1 -1
    === GCodes ===
    Segments left: 0
    Movement lock held by null
    HTTP is idle in state(s) 0
    Telnet is idle in state(s) 0
    File is idle in state(s) 0
    USB is idle in state(s) 0
    Aux is idle in state(s) 0
    Trigger is idle in state(s) 0
    Queue is idle in state(s) 0
    LCD is idle in state(s) 0
    Daemon is idle in state(s) 0
    Autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 15.54ms; fastest: 0.00ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0), 0 sessions
    HTTP sessions: 1 of 8

    • WiFi -
      Network state is active
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.25
      WiFi MAC address ec:fa:bc:0b:ef:f2
      WiFi Vcc 3.44, reset reason Power up
      WiFi flash size 4194304, free heap 23760
      WiFi IP address 192.168.1.52
      WiFi signal strength -49dBm, mode 802.11n, reconnections 0, sleep mode modem
      Clock register 00002002
      Socket states: 0 0 0 0 0 0 0 0


  • Same error - "ERROR: Operation 3 failed after 5 retries" - Web page shows "Please wait while updates are being installed..." 😞


  • Moderator

    @Foden what version of dwc is it showing installed?


  • administrators

    "Operation 3" means the firmware flasher has initialised, unlocked, and erased the flash memory, but failed to write the new firmware. The failure could either happen when reading from SD card or when writing to flash memory. So it's worth trying a new SD card.



  • K, will try a new card



  • 👎 Not sure what happened - tried a different card but am now NOT able to connect to the DuetWifi via USB and Bossa. Laptop shows the Duet as Com5, Bossa sees Com5 but says "Cannot connect to device on Com5"



  • @Phaedrux It did say 3.2.2 but now I can't get to it via Bossa at all



  • @Foden I'm an idiot - in the process of detailing the above it dawned on me I had NOT pressed Erase 😧 Doing so allowed me to connect via Bossa to upload Duet2CombinedFirmware.bin
    (deleted the large post with photos as it was redundant and in the way - sorry)



  • @Foden Happy Days!!! Was able to apply the 3.2.2 upgrade and it applied OK. Wifi showed as connected but not able to connect to it just yet. Will reset and retry that shortly



  • @Foden Hmm. Duetwifi reports it is connected to Wifi, as does my router, but I cannot connect to it via it's IP address

    Going to switch it all off and walk away for a bit as my brain was obviously in DFU mode earlier and may still be stuck there

    Appreciate your help guys - as always


  • Moderator

    @Foden said in Firmware bundle 3.2.2 released:

    Duetwifi reports it is connected to Wifi, as does my router, but I cannot connect to it via it's IP address

    Double check the IP address. Clear the cache. Try a different browser. Verify that the /www folder contains the right files. If in doubt, replace the files in the /www folder with fresh ones from the DWC zip file.



  • @Phaedrux Hi

    IP was correct, cache was cleared and tried different browser - also tried different PC completely - no go. Left everything switched off for a few hours then powered it up and left it alone for 15mins. Bingo - able to connect to it via the web - no idea what the hell that was all about. Powered it off/on a few times and each time all good. 👍



  • Looks like something in 3.2.2. has broken pressure advance. Just tried my first print which is something that worked fine on an earlier firmware (3.1??) and there was about a 0.5mm gap between the infill and the perimeters and the ends of the infill lines were rough as hell. I disabled PA and the resultant print is fine again.

    Either that, or there is some other random bug which caused the problem and which was cured by editing config.g and re-staring the machine..........



  • Hello, can I get back to version 3.2.0 quickly?

    sudo apt-get upgrade duetsoftwareframework = 3.2.0 not working


Log in to reply