layer count off



  • Noticed during prints that the layer count indicator in webcontrol seems way off

    in this image.. the print only have a few layers to go .. but it does Layer 190 of 1160

    Board: Duet 2 WiFi (2WiFi)
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 3.2 (2021-01-05)
    Duet WiFi Server Version: 1.25

    dfea370e-04d7-4f19-837e-ebf5e298dc3b-image.png


  • Moderator

    Post the sample gcode please. It's likely there is a z move in the start or end code that is confusing it.




  • Moderator

    ;TYPE:Custom
    ; Filament-specific end gcode 
    ;END gcode for filament
    G1 Z30.05 F600 ; Move print bed down
    G1 X50 Y50 F9000 ; present print
    G1 Z290 F600 ; Move print bed down further down
    

    It's picking up the Z290 as the final z move on the file and assuming that's the height.

    Try altering those z move by adding ;E after the feed rate. Like this:

    G1 Z290 F600 ;E

    Do that for all 3 of those z moves.



  • hmm not sure how to accomplish this un prusaslicer, so it dos this every time.
    need to look into it



  • @Adamfilip Edit your ending gcode. Printer Setting->Custom G-code, look in the End G-code box.



  • This is my end g code script

    {if max_layer_z < max_print_height}G1 Z{z_offset+min(max_layer_z+2, max_print_height)} F600{endif} ; Move print bed down
    G1 X50 Y50 F{travel_speed*60} ; present print
    {if max_layer_z < max_print_height-10}G1 Z{z_offset+max_print_height-10} F600{endif} ; Move print bed down further down
    M140 S0 ; turn off heatbed
    M104 S0 ; turn off temperature
    M107 ; turn off fan
    M84 X Y E ; disable motors
    


  • add an "E" to this line like this

    {if max_layer_z < max_print_height}G1 Z{z_offset+min(max_layer_z+2, max_print_height)} F600{endif} ;E Move print bed down
    G1 X50 Y50 F{travel_speed*60} ; present print
    {if max_layer_z < max_print_height-10}G1 Z{z_offset+max_print_height-10} F600{endif} ;E Move print bed down further down
    


  • @Adamfilip Woops, it's at Filament Settings->Custom Gcode. Didn't notice the filament part of the comment.


Log in to reply