heaters misbehaving



  • So i have made a custom machine using and old laser cutter with a bad laser emitter. I have wired everything right its a 24v system. The motors works the machine homes as it is suppose to. The heater also works when it is assigned as a bed heater but it is actually a wired to heater E0 pin.
    The screenshot is from the current config the heater section of the config looks like

    ; Heaters
    M305 P1 T10000 B4100 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    My Printer - Google Chrome 2_18_2021 7_07_34 AM.png

    Heaters;
    M140 H1 ; remap heated bed to heater 1
    M307 H1 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    My Printer - Google Chrome 2_18_2021 7_18_25 AM.png

    The second picture represents the exact same wiring but it reads the right temperature and the heater seems to work and heat as well. I want to know what would be the right config codes for making tool 0 show up correctly.
    Thanks for your help.



  • Also another thing to know if have an external controller for the heated bed so i dont need a heated bed in duet control.



  • What does the heater heat?

    Please post your config.g file using the </> tag.

    Thanks.

    Frederick



  • ; Configuration file for Duet WiFi (firmware version 2.00)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.10 on Wed Dec 23 2020 16:11:52 GMT-0600 (Central Standard Time)
    
    ; General preferences
    G90                                     ; send absolute coordinates...
    M83                                     ; ...but relative extruder moves
    M550 P"My Printer"                      ; set printer name
    
    ; Network
    M552 S1                                 ; enable network
    M586 P0 S1                              ; enable HTTP
    M586 P1 S1                              ; enable FTP
    M586 P2 S0                              ; disable Telnet
    
    ; Drives
    M569 P0 S1                              ; physical drive 0 goes forwards
    M569 P1 S1                              ; physical drive 1 goes forwards
    M569 P2 S0                              ; physical drive 2 goes forwards
    M569 P3 S1                              ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3                        ; set drive mapping
    M350 X16 Y16 Z16 E16 I1                 ; configure microstepping with interpolation
    M92 X153.84 Y100.00 Z1600.00 E420.00       ; set steps per mm
    M566 X900.00 Y900.00 Z60.00 E120.00     ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00     ; set accelerations (mm/s^2)
    M906 X1500 Y1500 Z800 E1500 I30        ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                 ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1                        ; set axis minima
    M208 X675 Y550 Z170 S0                  ; set axis maxima
    
    ; Endstops
    M574 X1 Y1 Z1 S1                        ; set active high endstops
    
    ; Z-Probe
    M558 P0 H5 F120 T6000                   ; disable Z probe but set dive height, probe speed and travel speed
    M557 X15:215 Y15:195 S20                ; define mesh grid
    
    ; Heaters
    M140 H1                                 ; remap heated bed to heater 1
    M307 H1 B0 S1.00                        ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P1 T100000 B4138 R4700             ; set thermistor + ADC parameters for heater 1
    M143 H1 S280                            ; set temperature limit for heater 1 to 280C
    
    
    
    ; Fans
    M106 P0 S0 I0 F500 H-1                  ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H T45                ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 F0                           ; define tool 0
    G10 P0 X0 Y0 Z0                         ; set tool 0 axis offsets
    G10 P0 R0 S0                            ; set initial tool 0 active and standby temperatures to 0C
    
    ; Custom settings are not defined
    
    


  • Hi,

    In your M563 command you don't have the H parameter which associates the specified heater to the tool.

    Still not really sure what question(s) you are asking.

    Frederick



  • @fcwilt The I cant figure out code to set E0 thermistor to Heater 0 to tool 0. No heated bed I have tried multiple possibilities.



  • I figured it out thanks a lot. You have saved the day



  • @Nexmath-LLP

    temp sensor and heater

    M308 S1 P"e0temp" Y"thermistor" T100000 B4267  ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 Q250                      ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00 A403.7 C171.6 D3.4 V11.9      ; values A, C, D, V determined by running heater tuning
    M143 H1 S250                                   ; set temperature limit for heater 1
    
    

    tool

    M563 P0 S"T0" D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0        ; set axis offsets
    G10 P0 R0 S0           ; set active and standby temperatures
    
    


  • he is not running rrf3


Log in to reply