prime line prints in error and print errors mid print



  • I just converted to Duet 2 wifi and reprap from Marlin and Ender 3 board.

    Two issues:

    1. The prime line prints at my z trigger height of 2.5 but all of the part prints correctly on the bed. How do i fix that?

    2. On my second print, the prints halts mid-print with Error: G0/G1: insufficient axes homed. My first print I was able to print with no issues (except the one above) (a calibration cube (sliced in Cura)). Any idea what is happening here? I am able to home all or x, then y, then z with no issues.



  • Post your gcode and give us a hint about where in the print it stopped.



  • CE3_TestPanel.gcode
    It gets all the way through the 5th layer then halts right as it starts to try and print the upright.
    Gcode attached.



  • Correction, the prime line doesn't print above the bed, it prints off the bed. My z probe offset is 61. It seems to print about 30 off the bed and the probe is about 30 on the bed.
    Maybe if I adjust my probe point location such that the nozzle is over the bed, it won't do that. I'll try.

    As to the error, I read that one could put M564 H0 in my config.g to allow homing of axis. I did that and the print did complete. I am not sure I like that solution but if I can't trust the gcode that cura puts out, that is one recourse short of switching to a different slicer. I would still like to know why it happened but I looked through the gcode and can't see anything out of the ordinary.



  • @EricE555 said in prime line prints in error and print errors mid print:

    Gcode attached

    Line 588 right before the first "Pillar":

    • G4 P17038
      This is a delay for 17038 milliseconds which is 17 seconds.

    Is that what you are seeing, or is it pausing for longer than that?



  • It doesn't just pause it crashes there with the error. But I understand it now even if I don't have a good solution yet. The pause of 17 seconds (for cooling) is enough to cause it to timeout. Meaning the delay causes a reset of the "need to home before moves" behavior and the next move spits out the error because it has not homed before the move. So it seems my M564 H0 to allow moves without homing is possibly the correct fix.

    Thank you much.

    I have the x homing now ending with the nozzle over the bed. I am about to try a print to see if that solves the prime line issue.



  • No such luck on the prime issue. I am still looking for a solution to this one. The solution might even have to be within cura because cura does the move commands to place the nozzle for the prime line. Hmmm. I'll try searching the cura forums.



  • Solved the prime line issue by editing the start gcode in Cura under machine settings. I am not sure why it had to be different between RRF and Marlin but it did.


  • Moderator

    @EricE555 said in prime line prints in error and print errors mid print:

    It doesn't just pause it crashes there with the error. But I understand it now even if I don't have a good solution yet. The pause of 17 seconds (for cooling) is enough to cause it to timeout. Meaning the delay causes a reset of the "need to home before moves" behavior and the next move spits out the error because it has not homed before the move. So it seems my M564 H0 to allow moves without homing is possibly the correct fix.

    Thank you much.

    I have the x homing now ending with the nozzle over the bed. I am about to try a print to see if that solves the prime line issue.

    Why are you pausing for 17 seconds?

    You can set the motor idle time out to be longer so that the motors don't turn off. When the motors power off the firmware can't guarantee the position anymore, so the axis are marked as unhommed, hence the G0/G1: insufficient axes homed error.

    In your config.g you probably have M84 S10 which idles the motors after 10 seconds. Change that time out to 60 seconds.

    @EricE555 said in prime line prints in error and print errors mid print:

    Solved the prime line issue by editing the start gcode in Cura under machine settings. I am not sure why it had to be different between RRF and Marlin but it did.

    Could have been a difference in when absolute or relative moves were set? It's best practice to specify your move type before the move so that you're certain it's doing the type of nove you want. In your start gcode it doesn't actually have G90 or G91 set so it would take whatever the last move type was set to.

    T0
    M190 S50
    M104 S200
    M109 S200
    M82 ;absolute extrusion mode
    ; Ender 3 Custom Start G-code
    G92 E0 ; Reset Extruder
    G28 ; Home all axes
    G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
    G1 X0.1 Y20 Z0.3 F5000.0 ; Move to start position
    G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; Draw the first line
    G1 X0.4 Y200.0 Z0.3 F5000.0 ; Move to side a little
    G1 X0.4 Y20 Z0.3 F1500.0 E30 ; Draw the second line
    G92 E0 ; Reset Extruder
    G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
    G1 X5 Y20 Z0.3 F5000.0 ; Move over to prevent blob squish
    M83 ;relative extrusion mode
    G1 F2940 E-7
    

    If you want more specifics, post your config.g and homing files for feedback. The output of M122 and M98 P"config.g" would help too.



  • Thanks Phaedrux. I did indeed have the motor timeout set to 10. I changed it to 60 to solve another problem I was having and now I don't think I would have an issue here. The 17 second wait was for cooling on extremely small layers for PETG (where I have no fan on). The minimum layer time was 20.

    I also took your advice on the Cura machine code and set m90 at the top.

    Thanks again.


Log in to reply