V-king Issues on Duet 2



  • This post is deleted!


  • Ok, so I am an idiot. In my rush last night getting it all connected...I mixed up my X and Y end stops. I have now successfully homed the X and Y.

    Still having issue 2 and 3.

    Thanks



  • @nedmo For your BLtouch, your config looks okay to me. Only comment I'd make is that the trigger (P) in your G31 is P500, I think this is typically set to P25. That would only affect actualy probing though...

    I would look again at the wiring. Double-check that the servo pin is in the right pinon the Duet (not that I did that when setting up mine...). Maybe also double check the connections on your extension wiring.

    For what it's worth, I'm using a BLtouch with my Chimera+. I agree that you can set it to probe somewhere off the bed if you make a mistake (you can do with any hotend/non-nozzle probe), but in the same way, you can mis-type a homing move so that it goes the wrong way and crashes and we don't tend to worry about that! My advice would be to be thorough/careful when setting up your Z-homing file, any bed levelling files, and your mesh grid, then you'll know you've got your machine dialed in correctly and won't have to worry about it in the future.

    On the PT1000's, that sounds like a wiring fault. Especially seeing as it worked, you moved the printer, then it stopped working. Double check your crimping as they can sometimes pull-out if they get strained.



  • Ok so last night, got my temps to work. I realised that when they were working, I was on older firmware 3.1.4, but then I recompiled to the latest trying to sort my homing issue, which killed my temps. Here is the heater config which is working perfectly. I may try and update to the latest firmware and use this same heater configs.

    ; Heaters
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S300 ; set temperature limit for heater 1 to 300C
    M305 P2 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 2
    M143 H2 S300 ; set temperature limit for heater 2 to 300C

    So final issue to solve is this BLtouch. I have triple checked all of my wiring and its correct as per the duet3d docs.


Log in to reply