4 extruder heaters and thermistors with the stepper breakout board



  • Hi

    Just when configuring my new Duet Ethernet + breakout board bundle I realised the heater channels with their dedicated thermistor channels are not available on the main board neither on the breakout board. I bought the breakout board instead of DueX to get the lovely 5v logic level to command my industrial drivers for XYZ after having a lot weird behaviour with several Duet 0.8.5+Duex sets that I had modded a bit to get the signals (3,3v) out for separate amplifier chips before the drivers.

    I see it sort of simple to connect the breakout board's 5v PWM pins to some transistor that then delivers the 24V of the powersupply to the heater elements. Or no?

    How about the thermistors for the added 2 heater channels? Can I just hook them (and a resistors of 4700 Ohms) up to the Therm6 & Therm7 pins of the breakoutboard? (and the other side to ground or where?)

    Would the firmware then understand the readings from these thermistors?

    I already thought that finally there is a ready set for my needs ๐Ÿ˜„ Just heat up the soldering iron and avoid the warrantyโ€ฆ.


  • administrators

    The schematics and other source are all available on github which should help:
    https://github.com/T3P3/Duet/blob/master/DuetWifi/DuetWifiv1.02/DuetWifi_Schematic_v1.02.pdf
    https://github.com/T3P3/Duet/blob/master/Duet_Expansion/Expansion_Breakoutv1.0/ExpBreakoutv1.0_Schematic.pdf

    From those you can see the on board thermistor circuits vs the ones that go to the expansion header.

    If you look on page 7/7 of the first schematic you will see the external thermistor channels have all the circuitry other than the 4k7 pull up so if you connect a 4k7 pullup between the thermistor pin and ADVREF (pin 41 on the expansion header) you will have the correct pullup on the thermistor signal. the other side of the thermistor should go to VSSA which is pin 40 on the expansion header. check page 4 of the schematic.



  • Perfect! Thanks for the fast help ๐Ÿ™‚



  • Hi again

    Today I have been able to test the setup and I can't get the 2 heaters connected in 5V PWM pins to heat up. I have the channels 1-4 set up for the extruder heaters and the temps are showing correct. I have remapped the channels in many ways (all that I can think of) but the mosfets don't get the PWM, I assume. Between the ground and PWM pin there is no real voltage in any case.

    I also tried to change the leads to the mosfets so that they would be driven directly from heater3(Expansion Pin8) and heater4(13) instead of the breakout's PWM pins to avoid remapping confusion, but in this case the mosfets were on on default, without setting the heaters on.

    Here's my heater config:
    ; Heaters
    M143 S280 ; Set maximum heater temperature to 280C
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M305 P2 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 2
    M305 P3 T100000 B4138 C0 R4700 X7; Set thermistor + ADC parameters for heater 3 and remap it to channel 7
    M305 P4 T100000 B4138 C0 R4700 X6; Set thermistor + ADC parameters for heater 4 and remap it to channel 6

    As said I have remapped the P3 and P4 for all the possible channels, and also I tried following:
    M305 P6 T100000 B4138 C0 R4700 X3
    M305 P7 T100000 B4138 C0 R4700 X4

    Before I solder off the mosfets and start blaming my wiring (again) it would be nice if somebody would see and point a (simple) error in here ๐Ÿ™‚

    Thanks!


  • administrators

    Please share the schematic of how you have connected the mosfets to the expansion connector heater outputs.



  • https://ibb.co/hm4tSF

    I hope it's not a facepalm type of a connection error ๐Ÿ˜„ (I'm more of a mechanic than an electrician)

    As said I also tried to take the signal from "normal" heater pins instead of the 5v PWM.

    I measured the nonexistent voltage between the pins on the breakout board. Should I activate the PWM output somehow or it should be working as other heater channels?

    Thanks!



  • Hi

    I managed finally to get the heaters running by inverting the logic of the power mosfets. Now the heater channels 3 and 4 are working the same as the standard 1 and 2.

    One curious thing popped up though: "Temperature reading fault - Temperature above limit" on heaters 1-3. This pops up in the console when heating to 260 degrees and when the temps rise a bit over before settling (about 265 degrees).

    I put the M143 S340 to not trigger the safety turn off but anyway around 265 the 3 heaters get this error message and shut down while heater 1 continues to hold nicely the target temperature. Heaters 1 and 2 are connected to Duet the "normal" way.

    EDIT:

    I managed to run the autotune for all the heaters after several tries with different PWM:s ( ended up using P0.55 and P0.6 to get the tune done and not ending in error).
    Nothing changed regarding the behaviour of heating up - H2-4 still get the error message "Temperature above limit" allthough there is more than 70 degrees overhead (M143 S340).

    EDIT: Fixed! By setting the M143 separately for all the heaters (for example M143 H1 S300)


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.