Duet2Wifi either non-levelled bed or weird offsets



  • I just got a Duet2WiFi to replace my kossel's MKSMini that got the extruder driver blown. Just finished the rewiring and initial setup and I'm experiencing a few issues for which I'll cut separate threads so if I get to resolve them, others can easily find the fixes for their issues in the future.

    2/22/2021, 11:17:12 PM	M115
    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet 
    FIRMWARE_VERSION: 2.05.1 
    ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2020-02-09b1
    

    So Problem #3 is I started printing a calibration cube to check the dimensions and calibration and I noticed on one side the hotend as if scraping the hotbed and on the other squirting tons of filament. I obviously stopped the print, but it was weird. Did auto-calibration a bunch of times and it didn't register any significant geometry skews to compensate for. That said I noticed that the nozzle wasn't spot on the center of the hotbed and whilst homing there was some minor X and Y offset I fixed in the config.g with a G10. I'm yet to retry the test (experiencing more pressing issues atm with it) but what else could I do to compensate if autoleveling doesn't fix the issue?


  • Moderator

    @vlex may be related to your other query, possibly due to overextrusion or printing first layer too close. A picture of the print would help, along with info requested in your other threads

    Ian



  • I might have used a longer screw for one of the sides of the hotbed which might've skewed it or made it wobbly (doh) . Once I fix the other issues with the hotend/extruder I'll revisit this one too to see whether there's any additional compensation I should go for.

    Cheers!



  • So I got a new e3d volcano that i just assembled and ran a quick calibration cube test, which came out kinda okayish.. I think something is wrong with my geometry though - I run delta calibration with the points generated by the reprap config tool online (though I've moved one a bit because the irregular effector interferes with one of the belts). Everything seems to run just fine but then when I run a print with a raft or any other base adhesion aid it seems as if everything is skewed ever so slightly - in one corner seems the nozzle scrapes the bed, in the opposite it seems as if it's squirting molten filament in the air and gobbles it up in big goops during every consecutive pass. Used the edge of a metal ruler to ensure the bed is straight and it is as far as I can see i.e. within 0.1mm edge-to-edge. Perhaps it is worth noting that the bed is a weapons grade chinesium aluminum bed with the heater towards the electronics in the base of the delta and the bare aluminum surface towards the hotend. Not sure whether that is of any importance, or whether I'm doing something insanely stupid by having it all set up like that and I overlook something obvious, so confessing my sins upfront.

    Here's the gcode the reprap tool generated:

    ; bed.g
    ; called to perform automatic delta calibration via G32
    ;
    ; generated by RepRapFirmware Configuration Tool v3.2.3 on Mon Feb 22 2021 09:18:29 GMT+0000 (Greenwich Mean Time)
    M561 ; clear any bed transform
    G28  ; home all towers
    ; Probe the bed at 3 peripheral and 3 halfway points, and perform 6-factor auto compensation
    ; Before running this, you should have set up your Z-probe trigger height to suit your build, in the G31 command in config.g.
    G30 P0 X0 Y84.9 H0 Z-99999
    G30 P1 X68 Y-47 H0 Z-99999 ; <- moved this one to avoid interference with the belt.
    G30 P2 X-73.53 Y-42.45 H0 Z-99999
    G30 P3 X0 Y42.4 H0 Z-99999
    G30 P4 X36.72 Y-21.2 H0 Z-99999
    G30 P5 X-36.72 Y-21.2 H0 Z-99999
    G30 P6 X0 Y0 H0 Z-99999 S6
    ; Use S-1 for measurements only, without calculations. Use S4 for endstop heights and Z-height only. Use S6 for full 6 factors
    ; If your Z probe has significantly different trigger heights depending on XY position, adjust the H parameters in the G30 commands accordingly. The value of each H parameter should be (trigger height at that XY position) - (trigger height at centre of bed)
    

    I decided that may be the self calibration is not good enough for the funky heated bed I've got so I followed the calibration guide here and used the escher bed calibration wizard to generate new code:

    ; bed.g file for RepRapFirmware, generated by Escher3D calculator
    ; 16 points, 7 factors, probing radius: 80, probe offset (0, 0)
    G28
    G30 P0 X0.00 Y80.00 Z-99999 H0
    G30 P1 X51.42 Y61.28 Z-99999 H0
    G30 P2 X78.78 Y13.89 Z-99999 H0
    G30 P3 X69.28 Y-40.00 Z-99999 H0
    G30 P4 X27.36 Y-75.18 Z-99999 H0
    G30 P5 X-27.36 Y-75.18 Z-99999 H0
    G30 P6 X-69.28 Y-40.00 Z-99999 H0
    G30 P7 X-78.78 Y13.89 Z-99999 H0
    G30 P8 X-51.42 Y61.28 Z-99999 H0
    G30 P9 X0.00 Y40.00 Z-99999 H0
    G30 P10 X34.64 Y20.00 Z-99999 H0
    G30 P11 X34.64 Y-20.00 Z-99999 H0
    G30 P12 X0.00 Y-40.00 Z-99999 H0
    G30 P13 X-34.64 Y-20.00 Z-99999 H0
    G30 P14 X-34.64 Y20.00 Z-99999 H0
    G30 P15 X0 Y0 Z-99999 S7
    

    It constantly runs into errors like "Z probe already triggered at start of probing move" due to from what I can see the hotend not going back up between moves and essentially dragging the hotend across the bed towards the mid-test-points.

    P.S. While writing this I notice the wizard generated code has no H-values like the reprap one does. I'll experiment with that and report.


Log in to reply