Z-probe offset and MeshGrid with Original E3D Big Box



  • Hi

    i recently got my DuetWifi and i installed everything with the help from this Forum and the E3D Forum so i am able to move all the Axis and Probe the bed and everything else.

    Now i have 2 Problems i cant solve by my own. I tried to search that but didnt find anything, maybe the search terms i used were wrong, so sorry if that was talked about in another thread.

    First is Setting an offset for the Z-Probe. I tried a few setups other BigBox users are using and it wont work.

    When i Home my axis everything works but when i go back to X0 Y0 the Z-Probe is at that Point and not the Nozzle of T0.

    I looked at the config.g and applied offsets (these are not apllied at the same time, its just to show what i tried)

    [[language]]
    M558 P1[b] X26 [/b]Y5 Z1 H5 F200 T6000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    
    G31 P500 [b]X-26[/b] Y2 Z2.0 ; Set Z probe trigger value, offset and trigger height
    
    

    X-26 is what i measured with my eyes and a ruler so its not that far off of the original X-25.19 that other BigBox users have and can put than in later when i know how it works.

    Inside the override_config.g is a line

    [[language]]
    ; Z probe parameters
    G31 T1 P500 X100.0 Y50.0 Z2.00
    
    

    that doesnt change anything, active or commented out.

    Solution to that is that my axis minima were wrong and i thought the offset would be applied after homing, but it doesn`t. I dont know when it is applied but by now it seems it is when bedlevelling is used.

    My second Problem ist that when i click on "Run Mesh Grid Compensation" the Tool probes at X35 Y0 first and then goes to X-30 and tries to probe, but than the Z-Probe is not on the Bed so it will jam the nozzle in to the bed. I think that there is a fundamental Problem in my config but im absolutely new to RepRapFirmware and this board.

    I will post my Config.g. If you need more i will provide it if i can. I hope you can help me with that.

    [[language]]
    ; Configuration file for Duet WiFi (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Tue Aug 08 2017 20:08:17 GMT+0200 (Mitteleuropäische Sommerzeit)
    
    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M208 X-45 Y0 Z0 S1 ; Set axis minima
    M208 X280 Y240 Z295 S0 ; Set axis maxima
    
    ; Endstops
    M574 Z0 S0 ; Define active low and unused microswitches
    M574 X1 Y1 S1 ; Define active high microswitches
    M558 P1 X0 Y0 Z1 H5 F200 T6000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    G31 P500 X-26 Y2 Z2.0 ; Set Z probe trigger value, offset and trigger height
    M557 X15:205 Y15:185 S20 ; Define mesh grid
    
    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M350 X16 Y16 Z16 E16:16 I1 ; Configure microstepping with interpolation
    M92 X160 Y360 Z1600 E420:420 ; Set steps per mm
    M566 X900 Y900 Z12 E120:120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X15000 Y15000 Z150 E3600:3600 ; Set maximum speeds (mm/min)
    M566 X600 Y600 Z30 E20 ; Minimum speeds mm/minute
    M201 X800 Y800 Z100 E1000:1000 ; Set accelerations (mm/s^2)
    M906 X800 Y700 Z800 E1000:1000 I60 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout
    
    ; Heaters
    M143 S260 ; Set maximum heater temperature to 260C
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 C0 R4700 X200 ; Set thermistor + ADC parameters for heater 1 and remap it to channel 200
    M305 P2 T100000 B4138 C0 R4700 X201 ; Set thermistor + ADC parameters for heater 2 and remap it to channel 201
    M106 F10 ; Fix for Bigbox Blower
    
    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H2 ; Define tool 1
    G10 P1 X38.3 Y0.0 Z0.0 S0 R0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C
    
    ; Network
    M550 PBigBox ; Set machine name
    M552 S1 ; Enable network
    ; Access point is configured manually via M587 by the user
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet
    
    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H2 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 F10
    
    ; Custom settings are not configured
    ;T0  ; select first hot end (All my scripts uses T0 as reference so I always try to remember to set it so no script makes a off bed setting)
    
    

  • administrators

    The X26 and Y5 parameters in the M558 command is wrong, they should be X0 and Y0 (meaning that the Z probe is not used not home the X axis). Z1 is correct if you are using the Z probe to home the Z axis.

    The X-26 parameter in the G31 command is correct if the IR sensor sensing area is 26mm in the -X direction from the head reference point (HRP, which in a single-extrusion machine is the nozzle position). Your HRP is tool 0 nozzle because you have specified zero X and Y offsets in the G10 P0 command.

    The Z2.0 parameter in config.g or config-override.g is what sets the Z probe trigger height.

    You have specified in your M557 command that the first probe point should be at X=15. As you have specified that the Z probe is 26mm in the -X direction from the HRP, it should move the HRP to 15 + 26 = +41mm to probe the first point. After that it should move to +61mm because your grid spacing is 20mm. I don't understand why it would move to -30mm. If it still does that after fixing the M558 command, please see whether version 1.19RC6 has the same problem (read the upgrade notes first), because there may just be time to fix it before the 1.19 release if the problem is still there.

    Make sure you do not use G1 S1 to load a height map before probing. If you do that, then the grid stored in the height map you loaded overrides the one that you defined using M557.



  • Thanks for the answer.

    I will try that when im home again tomorrow. The m558 command in my config.g I posted is x0 y0 z1 but I will double check that before updating to the rc6.



  • I tried to install 1.19RC6 and as far as i can see it has worked M115 reports 1.19RC6. At the moment i have no way to connect it via USB as my laptop is not with me by now but with PanelDue the M122 puts something like === Diagnostics === 1 of 32 Buffers used (11 max) ….... and seems to be cut off so i dont know if Wifi update worked but it connects to my Wifi network and i can connect to it.

    But i dont get the Web Control. All i get is a 404 Page. ERROR! ERROR! ERROR! The Requested file could not be found.

    I did the update like described on this site https://duet3d.com/wiki/DuetWiFiFirmware_1.19beta

    EDIT: I installed RC6 after testing what you suggested but didnt work so i thought ill give it a try.

    EDIT2: Ok i found out what was the Problem and that it was my understanding of "Extract the content from the DWC.zip". I extracted everything even the *.gz cause i thought that whats meant. I now re-extracted the zip only and now the WebControl works. Firmwareupdate was successfull according to Settings -> General.

    I will test the rest tomorrow when i got time.



  • I now found the time to test it and by now it seems to be working. Startet 4 -5 times and it always started at X41 as you said it should. and didnt go back to -30 like before.

    Thanks for your help.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.