Dual extruders issue with tool change



  • HI every one
    I am a happy new owner of a duet wifi did some really nice prints with singe extruder

    My setup is as follow

    1. I have replicated (milled ) the ultimaker2 extend frame ,
    2. all moving part from Misumi ,
    3. extruder/ hot end from E3D an
    4. control board and IRprob from duet3d,
    5. all steppers nema17/0.9deg/ 2amp

    every thing is working great so fare , but I am having issues with the tool change ,

    1. I use a magnetic tool change to save weight on the head.
    2. tool 1 & 2 have there own respective parking space ( its piking up one tool once finished its parked and the head goes to pick up the 2nd tool etc….

    my problem is as follow

    1. the printer starts without any tool on its head ,
    2. the IRprob is located on the tool number1
    3. the IRprob is being used has homing switch for Z-axes

    it seems that I can not pick up a tool before X Y and Z are homed ( logical to make sure there is no problem in the process )

    the procedure I would like to achieve is home X then home Y pickup tool1 then home Z

    FYI i also have a limit switch at the bottom of my printer would i be possible to have 2 triggers for the z homing ?
    for exemple

    1. lower the table when homing all
    2. pick up tool 1
    3. then home z again with the IRprob

    I am little out of idea any help will be welcome

    Thanks in advance for any ideas
    Best Regards
    Manuel Topiol


  • administrators

    I think the problem is that the tool change files (tfree, tpre and tpost) are not run unless all axes have been homed. Perhaps the simplest workaround is to send G92 Z0 before or after homing X and Y, to pretend that Z has been homed too.



  • Good Morning DC42

    Thanks for the quick response !

    I have tried your suggestion and It partially works meaning if a make a Gcode file manually the procedure works
    but I use CURA as a slicer and it disturbs the procedure

    when cura posts the Gcode file it allways start with
    M190 S65
    M104 S210
    M104 T1 S100
    M109 S210
    M109 T1 S100

    and only then the Start Gcode is being added

    what it does

    1. activate tool 1 (cura generated GCODE)
    2. start heating up
    3. then executed the manually added start Gcode in Cura
    4. behave erratically

    the problem seems to be that the tool is activated but not loaded

    I have tried to change or tweak in cura with no success and almost nothing on Google about this

    any idea for me ?

    Thanks in Advance
    Manuel Topiol



  • Hi Again

    Just tried and other approach

    I added the start code in the duet wifi config file

    that seems to work so fare , but I lose the web interface connection until the bed and nozzle are hot only then I can reconnect to the web interface

    it some sort of work around but not so practical

    Thanks in advance
    Best Regards
    Manuel Topiol



  • Good Morning

    I have also tried to load a macro with the config file at start up
    same result , loss of connection to web interface till every heating reached temp.

    the problem is for instance that I cant use the emergency stop if something goes wrong

    something not directly related , what would it take to get radius compensation to the g code list

    best regards
    Manuel Topiol


  • administrators

    With most slicers, if you put the temperature setting commands in your start gcode then the slicer won't generate its own. That gives you control over the order.



  • Hi Manuel,

    I contribute code to Cura so if you have any specific requests for different behaviour, please spell them out and I can put together a mod for a future release.

    Cheers,

    Mark


  • administrators

    It seems to me that most slicers would benefit from having two start scripts: one run right at the start of the file, and another run after the heaters are up to temperature.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.