Ethernet and Heater Issues



  • Hey All,

    I recently got a duet ethernet for a dual extrusion setup and am having two frustrating issues with it. The first issue is related to the ethernet connection and the second is related to my heaters and PT100 sensors. For the ethernet issue I cannot connect to the Duet Web Control at all. I have tried reinstalling the newest file to the www folder and setting a static IP. My router sees the Duet when given a static IP but the M552 command says the ip is 192.168.1.120 which is what I set it to, while my router sees the ip as 192.168.1.137. I am getting no flashing lights on either the duet or my router's ethernet ports. Additionally, the lights on the duets ethernet port DO light up when plugged into a PC. If anyone has any clue of something I could be missing I'd greatly appreciate it.

    As for my second issue, I have 2 extruders set up with 2 PT100 sensors. Both sensors are reading correct temperatures and woirkinded fine on their previous setups, however only the hot end connected to RTD0 works. I have tried physically switching sensors to see no change. I have switched which hotend is set to RTD0 and RTD1 and continue to only get heat when connected to RTD0. It gets weirder because when I tried only configuring 1 hotend both RTD0 and RTD1 worked fine when switching configurations. I also tried setting the second hotend to ADC2 and that allowed both heaters to turn on separately. In this set up both heaters still would turn on concurrently. I am stumped as what to try next, could it be a board failure of either the PT100 expansion on the duet ethernet itself? Again any help is appreciated.

    Thanks in advance


  • administrators

    The first issue sounds like a problem between your router and the Duet. Looks like your router is insisting on give it the .137 address despite you configuring .120. What happens if you configure the IP address either all zeros (to hand over control of the IP address to the router), or 192.168.1.137 ?

    Please clarify the second issue. When you say "only the hot end connected to RTD0 works", what exactly do you mean? Does the other one show the correct temperature, or an incorrect temperature, or fault status, or something else? What happens when you command it to e.g. 100C?

    Which firmware version are you running?


  • administrators

    Another possibility with the Ethernet connection to the router. Some routers do not have MDI/MDIX switching on all ports, most laptop ports do. If you connect to the router and get no lights then try a different port on the router (you may have it in a port designed for be connecting another router/switch rather than a PC) also you could try a crossover cable between the Ethernet and the router.


  • administrators

    Regarding the second issue, there may be a firmware bug in this area. I presume you have RTD1 configured for heater 2, and it is heater to that you can't heat up. If you try to auto tune heater 2 by sending M303 H2 S200, which heater does it say it is auto tuning?



  • Thanks for all the help, for the ethernet issues initially setting the ip to the same one as the router worked, but after restarting the duet it stopped working. Using a patch cable ultimately fixed the problem however. Not sure why it worked then stopped working though before switching cables. After getting into the web control it turns out that simplify3d was not correctly showing the temperatures of the pt100s or the thermistor when it was connected. One of the pt100s was actually faulty. I'm still having trouble getting both heaters to heat at the same time. I am using an e3d chimera so both heaters are different tools, is it by design that different tools cannot be preheated simultaneously? For your reference I am running firmware version 1.18.1. Thanks again for all the help.


  • administrators

    You can preheat both tools simultaneously. Here's an example:

    G10 T0 S200 R150. ; Set tool 0 active and standby temperatures
    G10 T1 S200 R150 ; Set tool 1 active and standby temperatures
    T1 P0. ; Select tool 1 to turn it on but don't execute tool change scripts
    T0. ; Select tool 0
    M116. ; Wait for all temperatures to be reached

    This will turn both heaters on, heating tool 0 heater to 200C and tool 1 heater to 150C.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.