Reconfiguring WiFi Connection



  • Right, I got a new router so I need to reconfigure my DuetWifi to connect to it. Since it can't see the original SSID, the DuetWifi goes into access point mode (good). When I connect to the DuetWiFi AP I have the following problem:

    Basically my IP address is way out of range. I have tired setting my IP manually to 192.168.1.100, mask to 255.255.255.0 and gateway to 192.168.1.1. I've also tried resetting the DuetWiFi multiple times. Am I missing something? Is there a way to do a "factory reset"? I may take this opportunity to move up to the 1.15c firmware.


  • administrators

    Looks like your Windows PC has failed to get an IP address via DHCP. Have you tried runing "ipconfig /renew" from a command prompt?



  • Just tried that, it hangs:

    [c]PS C:\Users\James> ipconfig /renew WiFi
    Windows IP Configuration[/c]
    After approx 5 minutes, Ctrl + C
    [c]An error occurred while renewing interface WiFi : unable to contact your DHCP server. Request has timed out.[/c]

    Unfortunately the baby is asleep in the same room at the moment, so I can't connect via USB right now! Kids, eh?



  • I now have physical access! Connected over USB serial, restarted the web server (M552 S0 followed by M552 S1), connected and it all worked as expected. Not sure why rebooting the whole board did not do this… Happily up and running again though 😄 Thanks for your time dc42.


  • administrators

    Glad you got it working. When you tried "rebooting the whole board" previously, was that by powering off/on or by pressing the reset button?



  • Powering off and on again. USB disconnected, turning ATX PSU off at the wall, then back on again.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.