End of print filament retracting all the way out



  • first week with duet getting somewhat ok with settings, as long as in configuration tool like speeds and direction set ups. but nothing in there for when my print finishes my filament is retracted all the way out. how would a novice find and configure end settings please

    Firmware Name: RepRapFirmware for Duet WiFi
    Firmware Electronics: Duet WiFi 1.0
    Firmware Version: 1.18.1 (2017-04-09)
    WiFi Server Version: 1.03 (ch fork)
    Web Interface Version: 1.15a



  • What slicer are you using?

    Normally this is solved by adding M83 after the G91 command in your end gcode.

    Please let me know if this solves your problem.



  • The usual cause for this is that Duet has been told to interpret the last extruder move as absolute by there being an M82 somewhere, then the last thing in the slicer is to do a retraction of (say 5mm). So instead of it retracting 5mm of filament, it moves the extruder to a position of 5mm from when it was last set to zero. But to be sure, we'd need to the slicer start and end gcodes and your config.g file (or least any M82 or 83 lines that are in config.g).



  • M107
    G1 F2400 E7679.95226
    G0 F9000 X84.871 Y78.894 Z21.000
    ; Default end code
    ;G1 X0 Y0 Z130 ; Get extruder out of way. Uncomment to use!
    M107 ; Turn off fan
    ; Disable all extruder
    G91 ; Relative positioning
    T0
    G1 E-1 ; Reduce filament pressure
    M104 T0 S0
    G90 ; Absolute positioning
    G92 E0 ; Reset extruder position
    M140 S0 ; Disable heated bed
    M84 ; Turn steppers off

    end of program
    found from program not sure how to find config.gfile from web control yet
    ;Generated with Cura_SteamEngine 15.01
    ; Default start code
    G28 ; Home extruder
    G1 Z15 F100
    M107 ; Turn off fan
    G90 ; Absolute positioning
    M82 ; Extruder in absolute mode
    M190 S50
    ; Activate all used extruder
    M104 T0 S210
    G92 E0 ; Reset extruder position
    ; Wait for all used extruders to reach temperature
    M109 T0 S210
    ;Layer count: 80
    ;LAYER:0
    M107
    G0 F9000 X77.748 Y41.852 Z0.300
    ;TYPE:SKIRT
    and that was begining
    also for some reason all my prints are being streched longer vertically
    think these are my last two bugs to this new setup hopfully

    ok just learned how to configure file but what do i change



  • I would try changing the M82 to M83 which will change it to relative positioning, it works for me. What slicer are you using?



  • Editing 0:/sys/config.g this is my config settings

    ; Configuration file for Duet WiFi (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Tue Aug 22 2017 18:08:41 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X200 Y200 Z200 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; Define active low and unused microswitches
    M558 P0 X0 Y0 Z0 H5 F120 T6000 ; Set Z probe type to switch, the axes for which it is used and the probe + travel speeds
    G31 P0 X0 Y0 Z0 ; Set Z probe trigger value, offset and trigger height
    M557 X15:185 Y15:185 S20 ; Define mesh grid

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I0 ; Configure microstepping without interpolation
    M92 X87.489 Y87.489 Z4000 E420 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X21000 Y21000 Z180 E1200 ; Set maximum speeds (mm/min)
    M201 X750 Y150 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X1400 Y1400 Z1400 E1400 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S280 ; Set maximum heater temperature to 280C
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 PTevo ; Set machine name
    M552 S1 ; Enable network
    M587 Schrisnet P"chrisnet" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured

    also besides filament extracting all the way out at end of job the print jobs all stretch parts vertically, i know its in duet someware becouse other printer works fine from repitier sliced files

    ok tried changing m82 to m83 in the repetier slicer but than when printed everything was wrong, motors slow and was making mini micro part. cant print nothing the right size


  • administrators

    If you use M83 in your start gcode you should also select "Relative E coordinates" in the slicer settings.

    The reason your prints are too tall will be because your Z steps/mm are set too high. Unless your printer is an Ormerod, i suspect that your X and Y steps/mm are wrong too. Find out the steps/mm for each axis and put those figures in the M92 command in config.g.



  • turned out was my step setting for E motor, the filament retraction as well as my stretch problem, instead of just retracting few mm it was retracting a foot, now with right setting just backing off pressure at end of print like sopose too, thank you everyone for replying to my petty problems but is my first week in the 3d printing world.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.