New core-xy moves wrong



  • When i jog the Y axis only the X move to the right. This is my first encounter with a corexy, im not sure whats going one with the odd movements.

    https://drive.google.com/open?id=1vrgOj5paX6L6XUfIhekVto4ogg_T0IHTWg

    Any help is welcome

    [c]
    Config.g
    No recorded activity before August 27, 2017
    All selections cleared All selections cleared

    ; Configuration file for Duet WiFi (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun Aug 20 2017 11:15:55 GMT-0700 (Pacific Standard Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin

    M667 S1 ; Select CoreXY mode
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X350 Y350 Z700 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z2 S1 ; Define active high microswitches
    M558 P0 X0 Y0 Z0 H5 F120 T6000 ; Set Z probe type to switch, the axes for which it is used and the probe + travel speeds
    G31 P600 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X15:335 Y15:335 S20 ; Define mesh grid

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M584 X4 Y0 Z2 E3 ; Apply custom drive mapping
    M350 X32 Y32 Z64 E16 I1 ; Configure microstepping with interpolation
    M92 X350 Y350 Z1200 E420 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z180 E1200 ; Set maximum speeds (mm/min)
    M201 X800 Y800 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1800 E800 I45 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S10 ; Set idle timeout

    ; Heaters
    M143 S260 ; Set maximum heater temperature to 260C
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 PCaslte ; Set machine name
    M552 S1 ; Enable network
    M587 SMakerSpace MakerLAN P"aruino1" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured[/c]



  • I was similarily confused when setting up my CoreXY. Did you read the documentation here https://duet3d.com/wiki/Configuring_RepRapFirmware_for_a_CoreXY_printer, espacially the part after the M569 commands and the testing? That helped me getting it right in the end.
    Also there was a change in 1.19 that requires to either swap the X and Y motors or change the directions parameters in the M569 commands for the motors.
    I hope I could help…


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.