Help with layer cooling fans



  • Hello everyone!

    I've recently jumped the fence and joined the Duet Wifi crowd, wired everything up, did my initial tuning and testing, it's all working great, getting better and better… except one thing, layer cooling fans (have 2 wired into 1 connector) don't respond to Gcode from S3D, I have followed what I could find, like disabling their thermistor control etc, but I have to always start them manually.

    Made a mistake of wiring them up in tandem, turns out if I let both go to 100% the board hangs 😛 Keeping them at 50% until I take the carriage off again to add some changes, but if anyone could put me on a right track it would be greatly appreciated. What do I need to add/change either in firmware or maybe in S3D for Gcode to control their speed?

    Many thanks
    Martin



  • Oh, right, forgot about this:

    ; Fans
    M106 P0 S50 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off



  • Hi,

    Have you considered letting the Duet control the fan based on heater temp and disabling fan control in S3D?

    Frederick



  • Did you do the "allocating fan to Tools" part?

    https://duet3d.com/wiki/Connecting_and_configuring_fans

    You need to tell RRF that your fan works with your heater.

    "M563 P0 D0 H1" or something like that…



  • ; Tool definitions
    M106 P1 H-1
    M563 P0 D0 H1 F0

    Is what I have that lets S3D control them part fan.


  • administrators

    If you connect your print cooling fans to the Fan0 connector, then the GCode from S3D should control them without you needing to do anything else.



  • @dc42:

    If you connect your print cooling fans to the Fan0 connector, then the GCode from S3D should control them without you needing to do anything else.

    Yes that's what I thought, for some reason it won't, it did it once only, at the very beginning when I had layer 1 to fans 0% and layer 2 set to fans 100%. I've noticed that it was causing a freeze in the board, so manually dropped it to 40% in the network interface… but since then, many firmware uploads later even, it will not start the fans. I can activate them manually no problems, but no matter what % I set them to in S3D, they don't start.

    @fcwilt:

    Hi,

    Have you considered letting the Duet control the fan based on heater temp and disabling fan control in S3D?

    Frederick

    It wouldn't work, it's the layer cooling fan (well, fans), the whole idea behind it is, they're meant to speed up, slow down or stop according to need (in this case according S3D's slicing), faster for bridging or overhangs, slower or off for other sections 🙂



  • @number40fan:

    ; Tool definitions
    M106 P1 H-1
    M563 P0 D0 H1 F0

    Is what I have that lets S3D control them part fan.

    Thank you sir, this worked, either on it's own, or together with me resetting the main process in S3D, as I was typing my last answer and saw the answer that it should work on it's own when plugged in to Fan0, I remembered a bug that keeps popping up in S3D once in a while, where a change made to a process doesn't get applied at times, no matter what setting you set it to, like say stopping a print at certain height, it remains there, even that you have removed the height restriction later on etc… simply removing and recalling the process clears the issue... no idea why, don't ask 🙂

    Anyway, they work now, thank you!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.