Z-axis stepper engine won't turn



  • Hello,

    I recently recieved my deut wifi (5th batch preorder), unfortunaly i cant get my z-axis to turn they only vibrate (going really fast from left to right). The y-axis, x-axis and extruder are working normally as you may expect. I personally think its a wiring problem, because they get current but I can't find exactly what I'am doing wrong. The things I tried so far are as following:
    -Check the wiring (these are the same as my other axes).
    -Changed the wire with a wire of a motor that works.
    -Changed the motor with a motor that works.
    -Removed the load.
    -Attach just 1 motor.
    -Ramped the current up to 2 amps, I dont want to give it more than that and currently its back at 1.5 amps.
    -Re-installed the firmware.

    I also added some pictures (in the db link below) of the wiring as i thougt it suposed to be. Also there is a picture of the back of the board since I want to know where L1 and L2 stand for. These can be found by the pins of the z-axis, can these also be related to my problem.
    https://www.dropbox.com/sh/bebovoejcxmzctj/AAD3RIh5l7wUH2gvcP7tGh37a?dl=0

    Hopefully anyone can help me so I can print again.
    If there is any thread related to this problem, please let me know because I could not find it.


  • administrators

    It could just be that your product of Z steps/mm and Z acceleration is too high. So try reducing the acceleration.

    If that doesn't fix it, test the Z stepper driver like this - but never connect or disconnect stepper motors while the board is powered. Connect just 1 Z stepper motor, with the 2 jumpers in the other connector. Confirm that Y motion works but Z doesn't. Then power down, swap the Y and Z motor connectors over, power up, and send the following to swap the Y and Z drivers over:

    M584 Y2
    M584 Z1

    Then test Y and Z movement again. If Z movement now works but Y movement doesn't, then the Z driver is only powering one phase.



  • I have set the acceleration to 1 mm/s^2 and still the same problem.

    When I change the Y and Z drivers the Y axis wont move anymore and the Z axis will move, so I think that, as you discribed above, the Z driver is only powering one phase. Is there any way how that can be solved?


  • administrators

    I think your board needs to be replaced under warranty.



  • Thanks for the help, I will send an email for the warranty.


  • administrators

    Rik, we have your email and will contact you with the details tomorrow.



  • Replacement board has arrived and is working great 🙂 thanks again for the great support


  • administrators

    Good news!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.