Error: Short-to-ground on drivers 0 1



  • Hello,
    i got a vew Problems with my Duet WIFI
    Hardware:
    Duet WIFI (firmware up to date)
    Meanwell RSP500-24
    Mosfet (only cause the breakout connector couldn´t handle the thick wires)
    Nema 17 17HS4417 1.8° 1.7A
    Nema 17 1.8° 0.5A (for testing)

    I´m trying to build a Core XY.

    I have connected everething like in the wiki.

    for the first tests, i´ve uploaded some existing configs from someone who build the same printer, just to have a basic setting.
    then is tested the Z-axis, they are working, one turing the other direction, but that doesn´t matter so far, cause there is no load on the motors
    after that i tried X and Y axis, more than a realy quick vibrating doesn´t come withe the Error: Short-to-ground on drivers 0 1
    First i thought i connected something wrong, so i checked every wire and found nothing.
    so i startet to asked unkle Google.
    The only thing i found was this discussion about an broken board. There was something about the motor current, so i raised it from 800ma to 1600ma and tried again…
    https://www.duet3d.com/forum/thread.php?id=2425#p22864
    nothing
    because i don´t know what to do, i´ve ripped of all the wires and connected them again in case there was a fault i didn´t notice, maybe…
    but nothing, the same again.

    no i thougt hey what about a broken motor? new one, but shit may happen. so i tried the Z motors on the X and Y axis, the same Error.
    The X and Y motors on Z are working.
    Tried the other nema 17 with 0.5A the same.

    Because of all that, i think there couldn´t be something wrong in the wires and connectors, a broken motor is also impossible it only could be some settings, i don´t know, or i got a broken board.

    So now i don´t know what to do, can annybody help me, or do i have to send the board back?

    Thanks for your Help

    Greetings from Germany

    M122
    === Diagnostics ===
    Used output buffers: 3 of 32 (13 max)
    === Platform ===
    RepRapFirmware for Duet WiFi version 1.19 running on Duet WiFi 1.0
    Board ID: 08DDM-9FAM2-LW4SD-6JKFA-3S46N-K3XBW
    Static ram used: 21176
    Dynamic ram used: 95976
    Recycled dynamic ram: 1632
    Stack ram used: 1304 current, 4904 maximum
    Never used ram: 7384
    Last reset 00:25:01 ago, cause: power up
    Last software reset reason: User, spinning module GCodes, available RAM 7416 bytes (slot 3)
    Software reset code 0x0003, HFSR 0x00000000, CFSR 0x00000000, ICSR 0x00400000, BFAR 0xe000ed38, SP 0xffffffff
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min 23.8, current 24.9, max 25.3
    Supply voltage: min 23.8, current 24.4, max 24.6, under voltage events: 0, over voltage events: 0
    Driver 0: stalled short-to-ground standstill
    Driver 1: short-to-ground standstill
    Driver 2: stalled standstill
    Driver 3: standstill
    Driver 4: standstill
    Date/time: 2017-09-02 19:46:37
    Slowest main loop (seconds): 0.005705; fastest: 0.000000
    === Move ===
    MaxReps: 2, StepErrors: 0, FreeDm: 240, MinFreeDm 235, MaxWait: 489ms, Underruns: 0, 0
    Scheduled moves: 3, completed moves: 3
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heater = 0, chamber heater = -1
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    Network state is running
    WiFi module is connected to access point
    WiFi firmware version 1.19
    WiFi MAC address 5c:cf:7f:ef:6a:b2
    WiFi Vcc 3.12, reset reason Turned on by main processor
    WiFi flash size 4194304, free heap 38992
    WiFi IP address 192.168.178.65
    WiFi signal strength -62dBm
    HTTP sessions: 1 of 8
    Socket states: 2 0 0 0 0 0 0 0
    Responder states: HTTP(1) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0)


  • administrators

    If you disconnect the X and Y stepper motors and command X and Y movements, do you get the same message, and do the driver chips get hot?



  • Good morning,
    with disconected stepper motors i don´t get any mesage
    without the fan i didn´t notice any temperature
    i would say that the chips are a little bit warmer (2-3°)above environmental.
    waited for 5minutes, is this long enough?


  • administrators

    If the drivers don't get hot when you enable them (by commanding movement) with no motors connected, and you don't get the warning messages either, perhaps you really do have either a short between wires or a short to ground in the motor wiring.



  • seems legit, but
    why does the z-motors with the z-cable work on the Z connector and doesn´t work on the X and Y connector?
    the X and Y motors either work with their calbles on the Z Connector



  • i got other cables her, will crimp a plug on them and test again


  • administrators

    Is there any sign of damage to the X or Y stepper driver chips, such as a round mark off-centre?



  • can´t see any damage.
    but now it´s getting strange!
    the new cable, only 15cm long 4 seperate wires so i can see that there is absolutely no connection to each other
    Motor current is set to 800mA

    This i tried on the Y-connector
    trying the small nema 0,5A in my handworking, but doing verry strange movements
    trying the one of the nema 1.7A (Z-axis), witch are build on the hypercube, the error comes again. That motor worked on the Z-axis connector without problems

    This on the X-connector
    now i plugged the Z-motor (giving an error on Y) on the X connector. working for 2seconds doing trange movements and then i had the error.
    the small 0,5A nema working, but doing that strange movements

    strange movements:
    i would say he´s getting an right and left at the same time, so he doesn´t know what to do.

    i wired everething like on this page
    https://duet3d.com/wiki/Duet_WiFi_wiring_diagrams

    first i thought, i have connected 2 wired wrong, so i turned the 2 A wires, the same movement of the motor


  • administrators

    I think there must be a fault on your Duet, if the motors work OK when connected to the Z connector but not when connected to the X or the Y connector. Please ask your supplier to replace it.



  • here a picture of the wires connected to the motor
    http://www.youscreen.de/metmbwqaj02.jpg



  • ok thanks for your help
    have a great day


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.