G32 uses wrong start Point



  • Hey Guys,

    I've got a Question about the G32 Probing.
    I use this bed.g in my System Directory and calculated my own Probe Points but it looks like he ignores them for some Reason.

    Here my bed.g:

    [[language]]
    ; bed.g
    ; called to perform automatic bed compensation via G32
    ; Clear any bed transform
    M561
    
    ; Probe the bed at 20 points X5 Y4
    G30 P0 X64 Y28 H0 Z-99999
    G30 P1 X128 Y28 H0 Z-99999
    G30 P2 X192 Y28 H0 Z-99999
    G30 P3 X256 Y28 H0 Z-99999
    G30 P4 X320 Y28 H0 Z-99999
    G30 P5 X320 Y85 H0 Z-99999
    G30 P6 X256 Y85 H0 Z-99999
    G30 P7 X192 Y85 H0 Z-99999
    G30 P8 X128 Y85 H0 Z-99999
    G30 P9 X64 Y85 H0 Z-99999
    G30 P10 X64 Y142 H0 Z-99999
    G30 P11 X128 Y142 H0 Z-99999
    G30 P12 X192 Y142 H0 Z-99999
    G30 P13 X256 Y142 H0 Z-99999
    G30 P14 X320 Y142 H0 Z-99999
    G30 P15 X320 Y200 H0 Z-99999
    G30 P16 X256 Y200 H0 Z-99999
    G30 P17 X192 Y200 H0 Z-99999
    G30 P18 X128 Y200 H0 Z-99999
    G30 P19 X64 Y200 H0 Z-99999 S-1
    
    

    And this is where it starts:
    https://drive.google.com/open?id=0BxLYV9G8oHT2RGFsZkZBdVE2bDg

    And this is the Position where it should start…
    https://drive.google.com/open?id=0BxLYV9G8oHT2QTBpTW9JOVRtdW8

    Any Ideas what i can/should change?



  • Hey buddy.

    I'm no expert, but just an idea as its an easy mistake to make, do you have the probes offsets set correct in the config.g file?

    As the probe is on the left side of the nozzle you'd need to use minus values in the X axis at least to set it's position in relation to the hot end.
    So if you are using positive values it would add that value to your start point coordinates.

    Ian



  • What is your probe offset? Adding G31 (probe offsets here) to your bed should help.

    Edit: Coolice beat me to the punch.



  • [[language]]
    G31 P600 X-64 Y-30 Z1.15 ; Set Z probe trigger value, offset and trigger height
    
    

    The Probe is 18mm and is from the Nozzle to the Center of the Probe about 40mm away.

    Should i use:

    [[language]]
    G31 P600 X-40 Y-30 Z1.15 ; Set Z probe trigger value, offset and trigger height
    
    

    and change eatch Value on the bed.g by -40 ont the X and -30 on the Y?



  • Just add the G31 P600 X-40 Y-30 Z1.15 ; Set Z probe trigger value, offset and trigger height to your bed file, before the probing points, and it should adjust for you.



  • Ok shure i can try that but if you look on the Pictures it got a offset aswell on the Y.
    I will try to check the 30 again but it looks to mutch for me.

    //EDITE:
    I checked again the Distance from the Y to the Probe center and see what i get… 14mm instead of 30.
    But start Point is again strange... (the old one)

    Maybe this has something to do with it...
    The Orange Sheet is 200x300 but the Alu Plate got a other size.

    [[language]]
    M557 X0:320 Y10:200 S40 ; Define mesh grid
    
    


  • This is the first Position where he starts probing….

    Should be G30 P0 X64 Y28 H0 Z-99999



  • If i set it to X0 and Y0 in the Probe Offset it does his job ok.

    But with this Values it add those to my Points…. X-40 Y-14


  • administrators

    The firmware will attempt to put the probe (not the nozzle) at the XY offsets you specify, taking into account the probe offsets that you declare in the G31 command. The offsets are the X and Y distances from the nozzle to the probe, not the other way around.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.