Weird behavior of the printer



  • Hi guys,

    I have a H-bot system with Duet Wifi. The weird problem is that everytime after I print a calibration cube 20x20x20 (i have designed in solidworks 2014) the printer head goes down into the print and I have to press emergency stop. I print different other objects and never did this. I tried cura and slic3r and in both cases behaves the same. Here's my start/end gcode from slic3r:

    start:

    G21 ; set units to millimeters
    G90 ; use absolute positioning
    M83 ; relative extrusion mode
    G28 ; home all axes
    G32 ; ABL
    G92 E0.0 ; reset extruder distance position
    M117 ;printing

    end:

    M104 S0 ; turn off extruder
    M140 S0 ; turn off heatbed
    M107 ; turn off fan
    G1 Z5 F3600
    G1 X0 Y0;
    M84 ; disable motors

    What's the problem?



  • I guess the [c]G1 Z5 F3600[/c] line is the problem. In absolute mode, it moves Z to 5 mm. Use [c] G91[/c] to enable relative positioning mode first, and it should work better.



  • So should it be:

    .
    .
    .
    G91
    G1 Z5 F3600
    .
    .
    I think I'm gonna make like this:

    G21 ; set units to millimeters
    G91 ; use relative positioning
    M83 ; relative extrusion mode
    G28 ; home all
    G32 ; ABL
    G92 E0.0 ; reset extruder distance position
    M117 ;printing

    M104 S0 ; turn off extruder
    M140 S0 ; turn off heatbed
    M107 ; turn off fan
    G1 Z5 F3600
    G1 X0 Y0;
    M84 ; disable motors


  • administrators

    No, the G91 needs to be in the end gcode, because it's just the G1 Z5 that you want to use relative axis coordinates for, not the whole print.

    If you disable motors at the end of the print, you will need to home the printer again before starting the next print. The alternative is to leave them enabled. The current will be reduced to the idle value (default 30% of normal) after 30 seconds.



  • Oh, i got it. Off course this is how it should be…. sometimes I'm so....... Thanks alot!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.