Remapping issue?



  • Hi guys im trying to remap x axis to different driver since im using external driver?

    Im connecting the x motor to driver 8:
    PUL-, ENB-, DIR- –-- GROUND
    PUL+ ---- EXPANSION PIN 20
    ENB+ ---- EXPANSION PIN 22
    DIR+ ---- EXPANSION PIN 21

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 0 goes forwards
    M569 P5 S1 ; Drive 1 goes forwards
    M569 P6 S1 ; Drive 2 goes forwards
    M569 P7 S1 ; Drive 3 goes forwards
    M569 P8 S1 R1 T10; Drive 3 goes forwards
    M584 X8 Y6 Z7 E:0:1:2:3:4:5 ; Driver 5 controls the X motor, 6 controls Y, 7 control Z motors, 3 control E motors
    M350 E32 I0 ; Configure microstepping without interpolation
    M350 X32 Y32 Z32 I1 ; Configure microstepping with interpolation
    M92 X160 Y160 Z160 E837 ; Set steps per mm
    M566 X1200 Y1200 Z1200 E3000 ; Set maximum instantaneous speed changes (mm/min)
    M203 X39960 Y39960 Z39960 E3000 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z1000 E1500 ; Set accelerations (mm/s^2)
    ;M906 X1800 Y1800 Z1800 E1500 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    I could not get X axis to move using the Machine Control on the web interface?
    Can someone help me how to do this? Thanks!


  • administrators

    The enable signal needs to be inverted when using external drivers. One way of doing this is to connect ENB+ to +3.3V and ENB- to the expansion connector pin. The other way is to use the option to invert Enable in the M569 command for that driver.

    You may also need to extends the step pulse timing for that driver, which again is done in the M569 command. Try 2us.



  • I have tried the M569 command. The only thing effect is the motor on and off.
    If i use:
    M569 P8 S1 R1 T2; the motor stay on

    and if i use
    M569 P8 S1 R0 T2; the motor stay off

    I assuming the enb signal is wroking however the other is not that is what confusion me.


  • administrators

    The motor should not be energised when the Duet starts up and has processed config.g, and should become energised the first time you command it to move. If you have the enable signal the wrong way round, then the motor will be energised after config.g has run, and will be turned off the first time you command it to move - so it won't move.



  • So i just set the M569 P8 S1 R0 T2; in the config.g which the motor is not energize the first time. I try to move it but it still not moving?



  • I also tried to move the motor from pointerface. Nothing works except home X axis button. So I dont think is a connection problem.



  • I had a similar issue a while back. What kind of driver are you using? Is that driver set to have microstepping?


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.