Z start height and then a jump



  • After running the meshbed macro to level the entire bed, my Z height is still 1mm too high. During a test print, I have to MOVE the z head -.5 twice. The z height shows 1.38 to start and then after the move (twice) it shows .30. This is the ONLY way the the first layer will stick. Anything less than the two moves, the z height is too high.

    Then the second layer goes to 1.70. To high. ugly layers.

    How do I correct this?
    I'm running 1.19beta8.


  • administrators

    Sounds like you need to increase the Z probe trigger height in your G31 command by 1mm. Please note, if you have a config-override.g file in /sys then the G31 command that matters is probably in there, not the one in config.g.



  • I change G31 to 0.35. After the hotend heats up to the desired settings, the z will show .35 but as soon as it starts to print is goes to 1.30.

    I have searched config.g for 1.30 and found none.
    I have no config-override file.


  • administrators

    What was your original Z probe trigger height in G31 set to?

    If you probe you bed then command Z to "0" is there a gap between the nozzle and the bed? if not then there is something funny in your slicer lifting the head by 1mm.



  • I had to set a -1mm offset in my slicer (Slic3r)
    So far I can print. But the z lift (or hop) is not working. Is there a setting in DuetWifi config that can control that?

    This is where after every layer or retract, the head will lift so as not to plow over the print.


  • administrators

    You can either configure your slicer to generate Z hop, or you can configure your slicer to generate firmware retraction commands and then use M207 to configure the amount of retraction and Z hop.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.