G30 and G29 doesn't reach the bed

  • just as it says, my effector never makes it to the bed, its about 30mm too high and stops. homed height is 514.98 I increased the values in the Config.g thinking it might not be enough. the deploy and retract probe files have been deleted VIA the DWC interface. Been combing the 1.19 upgrade stuff even though I was using it before just fine, and going through the page with the SE info as well. I was hoping not to be back so soon looking for help, lol.



  • manual moving it does the same

  • Hi,

    Well if you set the homed height incorrectly then when moving down Z may reach 0 before the reaching the bed.

    And since you have set Z min to 0 you cannot go below that.

    Try setting Z min to -50 or -100.

    Then home and then move down until the nozzle just touches the bed.

    Check the Z reading at that point and adjust the homed height setting accordingly.

    The only other thing I can think of is that the controller thinks a z-min end stop has been triggered.


  • Is the effector being triggered on the way down?

    Since you have M501 in the config.g, have you checked that your config-override.g has the correct height? The config.g you posted shows 585 while you are stating that you are seeing 515.

    What was the length of diagonal arms you previously used?

  • fcwilt: I set the Z-min and found my new overall height with a new G30, I forgot to change it in the override file as I had just deleted it with the other stuff that didn't apply right before this and it didn't show up until I turn the machine off physically. it didn't pop up after a M999. I don't know if that is normal or not.

    number40fa: old arms were 390, and my dyslexic self got all happy when he found 360s and ordered them. I'm thinking I can make it work with the longer belts I installed I have 100cm of height to play with 😄 The 515 it was doing was based on the number in the override, as said above.

    The new height is 552.1, and the little green light came on when I touched the bed.

    Thanks for eth help guys, you pushed all the right buttons!

  • Hi,

    Glad to hear you got it working.



Looks like your connection to Duet3D was lost, please wait while we try to reconnect.