Rr_download failing

  • I have noticed that rr_download (clicking the download button in the web interface) seems to fail with large files. It cuts out somewhere half-way and inserts an HTTP response, with headers and all, in the middle of the file data. I tried running it in curl:

    [c]curl ""[/c]

    [c][…tons of of G-code...]
    G1 Z9.028 F3600
    G1 X-2.120 Y21.120 F9000
    G1 Z8.928 F3600
    G1 E0.0000 F360HTTP/1.1 200 OK
    Cache-Control: no-cache, no-store, must-revalidate
    Pragma: no-cache
    Expires: 0
    Content-Type: application/json
    Content-Length: 9
    Connection: close

    curl: (18) transfer closed with 31668467 bytes remaining to read

    Is this a known bug? Thanks!

  • administrators

    I've just tried downloading some large files via the web interface, and they fail at around 2.5Mb with a similar symptom. Also the web interface disconnects. I didn't implement rr_download, but I'll take a look at the code when I get more time.

  • Excuse my ignorance but where is the Web Interface [Download] meant to Download to?
    If on the PC what Path & FileName?

  • The download should default to where ever your browser is set for.

  • Now I see why I could not find my 'Download' it always save it as rr_download.txt
    or rr_download-<n>.txt if you take the [Create New File] option instead of overwrite.</n>

Log in to reply