PanelDue is not starting any print job [SOLVED]



  • Hi,
    I'm a owner of this little Monster and even it was new and I'm sensitive to noise and rattling Hardware I threw out the mks for my personal "peace of mind". After configuration and script customization I put my printer to a even more abandoned dungeon to keep the fumes and remaining noise out of my livingroom.

    Now I have S3D configured that if I save the file I do a postprocessing script to:

    1. Save the file to the SD-Card on the printer
    2. Start heating the bed and the nozzle to standby (even there is no standby for the bed)

    It takes me two minutes to walk to the printer and if I get there it is preheated, nice and warm so that the actual doing (the print) can start almost immediately.
    I expected to use PanelDue to "just select and start" the file which is already (much faster than me) on the printer.
    So I select it and it starts to print on a bar within seconds and is done -> just without even moving. I can repeat that procedure infinte times. If I need 10 printouts ->20 seconds and its done :-).

    What do I have?
    I have the newest firmware on duet3d/ethernet 1.19 and 1.17 on PanelDue.
    Scripts for S3D:

    Postprocessing Script

    [[language]]
    
    path=[output_filepath]
    file=${path##*/}
    curl -# -d "@[output_filepath]" -X POST http://192.168.0.85/rr_upload?name=gcodes/[output_filename].gcode
    curl http://192.168.0.85/rr_gcode?gcode=M140S44
    curlhttp://192.168.0.85/rr_gcode?gcode=G10P0R122
    curl http://192.168.0.85/rr_gcode?gcode=T-1
    
    ```#### Start Script
    

    [[language]]
    T0 ; make sure the only hotend is selected
    M190 S[bed0_temperature] ; set bed target temperature and wait unitl reached
    M109 S[extruder0_temperature] ; set heater/nozzle target temperatuer and wait until reached
    G4 P2000 ; pause workaround for the rrf/paneldue bug

    [[language]]
    M106 S0 ; turn off cooling fan
    M104 S0 ; set extruder temperature to 0C
    M140 S0 ; set bed temperature to 0C
    M144 ; turn off BED
    G0 X0Y0Z500 F7500 ; Go back up to almost home

    [![](https://thumb.ibb.co/ncarPQ/Tevo_Converted1.jpg)](https://ibb.co/ncarPQ)
    [![](https://thumb.ibb.co/eMhXW5/Tevo_Converted2.jpg)](https://ibb.co/eMhXW5)
    
    Would be nice if somebody could give me a hint, what could be wrong or out of my scope so that I can print of, PanelDue.
    
    All the best from duetolino

  • administrators

    Check the Console page of the PanelDue and the web interface for error messages. Perhaps you didn't home the printer?



  • Hi I checked the console and it says File selected for printing…. and even in the web interface it does the same, but no error at all? Fast bargraph done -> reprint -> same again.

    Totally lost here?



  • Can you just confirm that the web interface does the same. i.e is it as the thread title that you can't print from Pane Due, or is it acse that you can't print from either the web interface or PanelDue? And does it show print complete 100% done?



  • have you definitely got a tool selected I have seen this behaviour if you don't



  • Hi,
    As you can see from the start script I got T0, which is pretty much a tool selection I guess, or do I have to confirm it somewhere?

    all the best



  • try putting a T0 at the end of your Config.g I agree the one in the start should do it but S3D can ignore things like that from time to time



  • try putting a T0 at the end of your Config.g I agree the one in the start should do it but S3D can ignore things like that from time to time

    I have that multiple times now everywhere

    OK, now I can say if I take the uploaded file from S3D and want to print it via WebControl. It does not print as well. Same behaviour. But if I upload the file via WebControl via Upload and Print it does it fine.

    all the best



  • OK I figured it out now…. Whooheee!!!!

    Slightly modified postprocessing script:

    [[bash]]
    path=[output_filepath]
    file=${path##*/}
    curl --data-binary "@[output_filepath]" http://192.168.0.85/rr_upload?name=gcodes/[output_filename].gcode
    logger "Writing file to 3DPrinter via: curl --data-binary "@[output_filepath]" http://192.168.0.85/rr_upload?name=gcodes/[output_filename].gcode"
    curl http://192.168.0.85/rr_gcode?gcode=M140S50
    curl http://192.168.0.85/rr_gcode?gcode=G10P0R120S200
    curl http://192.168.0.85/rr_gcode?gcode=T-1
    
    

    If you are courious what the difference is
    1. I tried to find a debug possibility with logger -> install logutils and you can directly log into syslog | Check
    2. I found out that the file I uploaded was completely different in size and behaviour -> changed to data-binary option | Check

    Voila printing from PanelDue and WebControl -> no problemo

    Could have been so easy, but the dog lies in detail (or whatever you say in english)

    all the best duetino



  • How can I mark the thread as solved?



  • @duetino:

    How can I mark the thread as solved?

    Edit the title in the opening post is one way.



  • Thanks guys, even no direct hint brought me to THE solution, and also edit the title is even better… did that and I guess nobody can tell if I did hit a button or not.

    BTW, there is an Answer button, which marks the solution of the thread, don't know if that leads to a double solved ?

    Great work/help/assistance anyway



  • Actually I want to leave it like this but for everybody to visualize the difference of a little misconfiguration…
    The (left) part with line numbers is correct, the other is as well just without carriage return and linefeed uploaded as one big line.

    all the best duetino


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.