Macro Can't open 0:/sys/0 to read, error code 1 ( Solved)



  • I put a file named SetNetworks
    in /macros
    the file contains
    [c]M552 S0
    G4 P1000
    M587 S"CasaBisi" P"binbin1973" I192.168.0.104 [/c]
    I execute throug repetier

    M98 P/macros/SetNetwork
    and the answer is

    23:04:18.698 : Can't open 0:/sys/0 to read, error code 1
    23:04:18.698 : Macro file 0 not found.
    23:04:18.698 : ok

    Now I am stuck

    I tried calling other macros without succes but M503 works.
    Tested other sd card with same results.

    My folder structure is
    gocdes
    macros โ€“hereI placed SetNetwork
    sys
    www

    Any idea what I am missing?


  • administrators

    Perhaps Repetier is failing to send the M98 command exactly as you sent it. Try using another program, such as Pronterface or a terminal emulator.



  • Thank you , you answered at the same time I am going to post the solution ๐Ÿ™‚
    You are right repetier can't handle M98 correctly , solved using simplify3d console.
    Lightning answer anyway ๐Ÿ™‚

    thank you



  • Connected but I am receiving this error, what this mean?

    Can't open 0:/sys/oem.json to read, error code 4

    Also I am on 1.19.2 running on Duet WiFi 1.0
    My corexy axis is screwed my last functionally config was
    [c]M569 P0 S1 ; Drive 0 goes forwards (change to S0 to reverse it)
    M569 P1 S0 ; Drive 1 goes forwards. (Change if motor goes wrong way. Or just turn the motor connection 180 degrees around..)
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M574 X1 Y2 Z0 S0 ; set endstop configuration (X1 is at MIN end. Y2 is at MAX end. (active high switch = S1, active low switch= S0)
    M667 S1 ; set CoreXY mode[/c]

    can you suggest me how can change it?



  • Read the notes. Have to swap connectors.



  • thank you , I read it , but I prefer to change the config setting instead of swapping connector ,and I didn't remember the drive order , then I found that Y is number 1
    so
    M569 P1 S1 fix the problem.

    thank you for answering me.

    Andrea


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.